Error after updating Joomla 3.7.5 to 3.8

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
sylwekb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Mon Mar 14, 2011 5:08 pm

Error after updating Joomla 3.7.5 to 3.8

Postby sylwekb » Thu Sep 21, 2017 7:26 am

Hello
After updating from version 3.7.5 to version 3.8, the following errors appear to me. My php version 7.1

How to solve them?

Fortunately, getting back to version 3.7.5 is a temporary solution.

Frontend - 500 - JHtmlBehavior::mootools not found.

Backend - .../libraries/fof/input/jinput/input.php on line 39

User avatar
mbabker
Joomla! Hero
Joomla! Hero
Posts: 2027
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Error after updating Joomla 3.7.5 to 3.8

Postby mbabker » Thu Sep 21, 2017 12:23 pm

JHtmlBehavior::mootools hasn't existed since 3.0.0. Apparently you have some extension with conditional logic trying to call that method and it has a bad check.
Production Department Coordinator, Release Lead, CMS Maintainer, Framework Maintainer, Security Team Member, .org System Administrator

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281


Return to “Administration Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 4 guests