New redirect feature on menu ids apparently not working

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
emeyer
Joomla! Explorer
Joomla! Explorer
Posts: 352
Joined: Thu Sep 29, 2005 2:37 am

New redirect feature on menu ids apparently not working

Postby emeyer » Wed Oct 11, 2017 11:03 pm

Some time ago, when Joomla 3.3x was top of tree, I posted in the dev forum that one can still link to pages with menu ids without redirection to the actual menu. For example:

https://www.yofiel.com/100

opens the page https://www.yofiel.com/100 instead of redirecting to https://www.yofiel.com/software/reaktor ... rl-presets

This has three problems:
  • External sites can link to the url with the menu id which causes GOOGLE WEBMASTERS to indicate an error and downgrades SEO.
  • The menu is not activated for the page so the menu doesn't show the current page active.
  • Modules which are meant to appear on some pages are linked to the menu, not the id, so the modules don't show up.

So I posted PHP code for a system plugin towards fixing the problem. After being pissed on by at least three google developers who said I was wrong and told me I was an [censored]. After appealing to the dev team directly, I was told I was right, and I was asked to start a new code branch and fix it myself in core. I really didn't have the time to do that, so I posted a plugin to the extensions directory. After a year of waiting, it still wasn't approved, so I deleted it.

Meanwhile, the core was changed in Joomla 3.4, causing all my extensions to stop working. At the same time, it was announced that the next release of Joomla would fix this very problem. Concluding I was not wanted at all, I deleted all my extensions from the JED and unpublished all my articles on Joomla support.

Since that time, there have been at least three releases saying the redirection was meant to be working in the last release, but wasn't. So this month, I saw it stated again for the current version of Joomla 3.8. So I updated Joomla, and a few good things improved, thank you, but for some reason, it still doesn't redirect to the menu item when the URL fragment is a number. Am I meant to change some setting for it to start working? I looked in the redirect plugin, where there used to be some option that was meant to do something, but now it has no options at all, so I don't know if it's something I didn't configure right, or if it still doesn't work as claimed. Sorry for the long message. I kind of got frustrated with the whole thing quite a while ago.

Return to “Administration Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 10 guests