Warning Your PHP version, 7.0.31

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Locked
User avatar
cspgsl
Joomla! Explorer
Joomla! Explorer
Posts: 315
Joined: Thu Nov 09, 2006 11:35 am

Warning Your PHP version, 7.0.31

Post by cspgsl » Mon Sep 03, 2018 1:13 pm

I am receiving the warning

Your PHP version, 7.0.31, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-09-03. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.

Checked with my host who indicates that
7.0.31 is the current version, and it's supported until December with security support for another year after that.

https://en.wikipedia.org/wiki/PHP says

Release history
Version Release date Supported until
5.6 28 August 2014 31 December 2018
6.x Not released N/A
7.0 3 December 2015 3 December 2018
7.1 1 December 2016 1 December 2019

Why the warning on my sites?

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4173
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Warning Your PHP version, 7.0.31

Post by gws » Mon Sep 03, 2018 1:17 pm

7.2.x is the current version. Latest joomla runs on this with no problems,not all extensions do though,so check your extensions before updating.

User avatar
cspgsl
Joomla! Explorer
Joomla! Explorer
Posts: 315
Joined: Thu Nov 09, 2006 11:35 am

Re: Warning Your PHP version, 7.0.31

Post by cspgsl » Mon Sep 03, 2018 1:17 pm

thanks

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12875
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: Warning Your PHP version, 7.0.31

Post by toivo » Mon Sep 03, 2018 2:01 pm

Apparently the current PHP version check is not accurate. The following topic has link to a patch to the plugin that checks the PHP version, which may fix the issue with the wrong date:

viewtopic.php?f=714&t=965158

https://github.com/joomla/joomla-cms/pu ... de99e74649
Toivo Talikka, Global Moderator


Locked

Return to “Administration Joomla! 3.x”