back end menu changed but site still working

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Thomsterdam
Joomla! Intern
Joomla! Intern
Posts: 70
Joined: Mon Dec 12, 2011 5:55 pm

back end menu changed but site still working

Post by Thomsterdam » Thu Jul 11, 2019 10:21 am

Hi there,
Some time ago my back end menu changed (see image)
ERV joomla menu.png
As you can see there is a complete mix up of the Extensions menu tab.

The functioning of the site seems OK, but it makes me worry it may come crashing down one of these days.

Does this happen more often?
Is it as bad as it looks? (or is it impossible to say?)
Can I repair this? Is it necessary?

Thanx,

Thom
You do not have the required permissions to view the files attached to this post.
Give a man a fish and you feed him for a day;
teach a man to fish and you feed him for a lifetime.

User avatar
paulala
Joomla! Explorer
Joomla! Explorer
Posts: 301
Joined: Sat Oct 30, 2010 12:32 pm
Location: Scotland
Contact:

Re: back end menu changed but site still working

Post by paulala » Thu Jul 11, 2019 10:43 am

Probably a daft question but what did you do to make it change?
Warm Regards,
Paula Livingstone, Skydiving Instructor and Network Security Consultant
https://paulalivingstone.com
http://rustyice.co.uk

Thomsterdam
Joomla! Intern
Joomla! Intern
Posts: 70
Joined: Mon Dec 12, 2011 5:55 pm

Re: back end menu changed but site still working

Post by Thomsterdam » Thu Jul 11, 2019 10:57 am

Hi Paulala,
That is a very interesting question, which could be preceded with the question: “Did I do anything to change it?” I haven't got the foggiest idea if I did anything...

Thom
Give a man a fish and you feed him for a day;
teach a man to fish and you feed him for a lifetime.

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 7884
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: back end menu changed but site still working

Post by sozzled » Thu Jul 11, 2019 11:06 am

The menu items are located in the _menu table. If you spend a bit of time looking at the rows in that table (and, say, compare the table in the affected site with the same table in another website where things are "normal") you may be able to deduce what went haywire. It may not have been something you did, per se, but it may have happened as a result of a database corruption over time or because of a incompleted J! update. Just guessing.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Post Reply

Return to “Administration Joomla! 3.x”