Sometimes, adding URL to a-href-attribute in article gives 503-error

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 5:57 am

Hello,

For at least a week now, it appears that, sometimes, I cannot add an href with URL to a HTML anchor (a-tag) in an article body. If I set the href to #, all is well and I can save the article or close the page. If I set the URL to an internal link (SEO-URL like "home", all is well and I can save the article or close the page.

If I add a full external URL like (Rick Astley) https://www.[youtube].com/watch?v=dQw4w9WgXcQ, sometimes I then get a download prompt for "index.php" containing a bare HTML-file with a 503-server fault.

Code: Select all

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>503 Service Unavailable</title>
</head><body>
<h1>Service Unavailable</h1>
<p>The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.</p>
</body></html>
When I then remove the URL and add a #, the "save"- and "close"-buttons work as expected.

These are the system properties of the shared hosting I'm on:
  • PHP Version: 7.3.7
  • Web Server: Apache/2.4.39 (Unix)
  • WebServer to PHP Interface: cgi-fcgi
  • Joomla! Version: Joomla! 3.9.6 Stable [ Amani ] 7-May-2019 15:00 GMT
  • Joomla! Platform Version: Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
I have tried using another browser-profile, another browser, another SuperUser-account. The same thing happens, most of the times, but not always.

I have tried pulling the site to my local machine, but I could not reproduce the problem (yet). Trying again at this very moment.

Can anyone help me pin this problem down and solve it?

Thanks,
Frans-Willem

harperlala
Joomla! Guru
Joomla! Guru
Posts: 672
Joined: Mon Aug 24, 2015 5:55 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by harperlala » Mon Aug 26, 2019 6:28 am

maybe it is from your editor config, if use tiny mce, you can see option: Prohibited Elements
Or you can give link site with that anchor, so we can look into.

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 6:47 am

Thanks for the quick response.
I have disabled all editors, am working with pure and plain HTML source code.
Do you mean a link to the admin-panel's form or the public URL of the problematic page?

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 6:51 am

On my dummy testpage having one anchor, the problem is not always showing.

On the real page (article) I ran across this issue, it ALWAYS happens. This is that page's HTML (in Dutch, a list of [youtube]-links for our choir):

Code: Select all

<p>Hieronder staan veelal originele uitvoeringen van nummers die wij in een ander (koor-)arrangement zingen. De onderstaande video's zijn enkel ter oriëntatie. Luistervoorbeelden van de koorarrangementen vind je op de pagina <a href="luister-links">Luister-links</a> in het ledenmenu.</p>
<ul>
<li><a href="https://youtu.be/2LuGzwNy2ws" target="_blank" rel="noopener">Angel</a></li>
<li><a href="https://youtu.be/muQw1EsyDxo" target="_blank" rel="noopener">Ave Maria No Morro</a></li>
<li><a href="https://youtu.be/UOsOd87ArX8" target="_blank" rel="noopener">Blue Moon</a></li>
<li><a href="https://youtu.be/c-3vPxKdj6o" target="_blank" rel="noopener">Breakaway</a></li>
<li><a href="https://youtu.be/dN3GbF9Bx6E" target="_blank" rel="noopener">California Dreamin’</a></li>
<li><a href="https://youtu.be/zO6D_BAuYCI" target="_blank" rel="noopener">Crazy little thing called love</a></li>
<li><a href="https://youtu.be/KeKtB2EhdaE" target="_blank" rel="noopener">Everything</a></li>
<li><a href="https://youtu.be/KLVq0IAzh1A" target="_blank" rel="noopener">Fields of Gold</a></li>
<li><a href="https://youtu.be/TxGc2brzMQM" target="_blank" rel="noopener">Gimme some lovin'</a></li>
<li><a href="https://youtu.be/iellXDUHxdc" target="_blank" rel="noopener">Hallelujah</a></li>
<li><a href="https://youtu.be/TYM9OwgIn64" target="_blank" rel="noopener">I've Got the Music in Me</a></li>
<li><a href="https://youtu.be/ErfH5K45FkM" target="_blank" rel="noopener">Inside Your Heaven</a></li>
<li><a href="https://youtu.be/yWoTYJqZkpI" target="_blank" rel="noopener">On my One</a></li>
<li><a href="https://youtu.be/m4j_wrmpMnU" target="_blank" rel="noopener">Ordinary Miracle</a></li>
<li><a href="https://youtu.be/UMcZI8pOjjA" target="_blank" rel="noopener">Perhaps Love</a></li>
<li><a href="https://youtu.be/8E8xMcXmI9E" target="_blank" rel="noopener">The Lion Sleeps Tonight</a></li>
<li><a href="https://youtu.be/7q0ply8RfVs" target="_blank" rel="noopener">The prayer</a></li>
<li><a href="https://youtu.be/oR6okRuOLc8" target="_blank" rel="noopener">The Rose</a></li>
<li><a href="https://youtu.be/U2DBcbZc3ck" target="_blank" rel="noopener">Venus</a></li>
<li><a href="https://youtu.be/dvgZkm1xWPE" target="_blank" rel="noopener">Viva La Vida</a></li>
<li><a href="https://youtu.be/joF5HOpdstQ" target="_blank" rel="noopener">Your Mama Don't Dance</a></li>
</ul>
<h3>Kerst</h3>
<ul>
<li><a href="https://youtu.be/iLeXw3SHgSo" target="_blank" rel="noopener">A gospel Noel</a></li>
<li><a href="https://youtu.be/VcpHJKWqFHA" target="_blank" rel="noopener">A Welsh Noel</a></li>
<li><a href="https://youtu.be/mtPLD_bNI_Q" target="_blank" rel="noopener">Christmas (Baby Please Come Home)</a></li>
<li><a href="https://youtu.be/yQSvUGNu2kY" target="_blank" rel="noopener">Christmas Kum Ba Ya</a></li>
<li><a href="https://youtu.be/OR4G2xZR_4k" target="_blank" rel="noopener">Peace, Peace</a></li>
<li><a href="https://youtu.be/v59mHXed2AU" target="_blank" rel="noopener">Shepherd's joy (a Celtic Christmas Celebration)</a></li>
<li><a href="https://youtu.be/WxrBhZvvSIQ" target="_blank" rel="noopener">Stille Nacht</a></li>
<li><a href="https://youtu.be/1hifwrvNOQI" target="_blank" rel="noopener">Tiny little baby is born</a></li>
<li><a href="https://youtu.be/Q8R67wHD_FY" target="_blank" rel="noopener">When a child is born</a></li>
<li><a href="https://youtu.be/A3uQ7ZXeUHk" target="_blank" rel="noopener">Winter wonderland</a></li>
</ul>

harperlala
Joomla! Guru
Joomla! Guru
Posts: 672
Joined: Mon Aug 24, 2015 5:55 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by harperlala » Mon Aug 26, 2019 6:55 am

yes. post all source in body of article, then give link front-end of view, then we can see which html was created?

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 7:11 am

https://koorvoyage.nl/topic-973967

On this page, I cannot add an external URL to the href-attribute. I always get the download-prompt with 503, and have to do a global check-in.

harperlala
Joomla! Guru
Joomla! Guru
Posts: 672
Joined: Mon Aug 24, 2015 5:55 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by harperlala » Mon Aug 26, 2019 7:16 am

maybe this view you not add source link. Please add code that you has error, open modal source code in body article and add all link. Then we can see it.

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 7:51 am

This is the code, body of the article. At this moment (2019-08-26-09:50+02:00) I can save this page as is.

Code: Select all

<ul>
<li><a href="https://youtu.be/2LuGzwNy2ws" target="_blank" rel="noopener">Angel</a></li>
<li><a href="https://youtu.be/muQw1EsyDxo" target="_blank" rel="noopener">Ave Maria No Morro</a></li>
</ul>
I have no idea why, but an hour ago, I could NOT save or close the page with this exact content.

When I now open the full page (mentioned a few posts up), the error occurs again. The "versions"-button works (I see a modal overlay), but "Save", "Close" etc. do not work.

harperlala
Joomla! Guru
Joomla! Guru
Posts: 672
Joined: Mon Aug 24, 2015 5:55 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by harperlala » Mon Aug 26, 2019 7:55 am

- when add this html, you must open modal "source code" to add
- later, when save article, please f12 browser and see tab "console", if there is any error, it will show with red color

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 11:57 am

I have followed your advice and opened the Firefox console (F12, tab 'Console'). It shows no errors, only the following message and warnings:

Code: Select all

JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:552
Array.forEach is deprecated; use Array.prototype.forEach instead mootools-core.js:9:303
Array.slice is deprecated; use Array.prototype.slice instead mootools-core.js:13:197
When I then press the 'Close' or 'Save' buttons, the console is empty and I receive the download-prompt for index.php.

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Mon Aug 26, 2019 1:06 pm

Still pursuing this problem, I took a closer look at the actual response from Joomla! when I push the "Save" or "Close" button on the edit-form. I get the following HTTP headers - mind the status 200! How can this be? The body of the result shows the 503 error..?

Code: Select all

Request URL: https://koorvoyage.nl/administrator/index.php?option=com_content&layout=edit&id=90
Request method: POST
Remote address: [2a01:238:20a:202:1084::]:443
Status code: 200
Version: HTTP/2.0
Referrer Policy: no-referrer-when-downgrade
Having pulled another complete backup to my local machine, the issue does NOT appear local. Only on my (shared) hosting.

fwiep
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Feb 09, 2019 10:07 pm

Re: Sometimes, adding URL to a-href-attribute in article gives 503-error

Post by fwiep » Sat Aug 31, 2019 6:21 pm

The problem still persists. When editing the specific article (be it via back-end or front-end), I get the index.php-download containing a bare HTML 503 page.

I can NOT edit this page in any way. Can anyone (else) help me solve this issue?
Thanks,
FWieP


Post Reply

Return to “Administration Joomla! 3.x”