End of PHP 7.3

Need help with the Administration of your Joomla! 3.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
gilplane
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Mon Sep 03, 2012 2:25 pm

End of PHP 7.3

Post by gilplane » Fri May 28, 2021 1:46 pm

The 6 december arrive the end support of PHP 7.3 https://www.php.net/supported-versions.php
Does it mean that after this dead line PHP 7.3 is unsecure?
Many templates are build with PHP 7.3 for example all the Yootheme warp 7 templates aren't compatible with PHP 7.4 idem with the Yootheme extension Widegetkit. It seems that Rocketheme are also build for PHP 7.3.
How will you do about all that? Any templates providers compatible with PHP 7.4 ? Any infos about PHP 7.3 risks after the end off life ?
Thanks

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 23366
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: End of PHP 7.3

Post by pe7er » Fri May 28, 2021 7:50 pm

gilplane wrote:
Fri May 28, 2021 1:46 pm
Does it mean that after this dead line PHP 7.3 is unsecure?
No, it only becomes insecure when a security flaw is found,
and it won't be patched because 7.3 is no longer supported.

Many templates are build with PHP 7.3 for example all the Yootheme warp 7 templates aren't compatible with PHP 7.4 idem with the Yootheme extension Widegetkit. It seems that Rocketheme are also build for PHP 7.3.
How will you do about all that?
Have you tested your website with PHP 7.4 (with PHP Error Reporting to Max) ?
Do you get any errors?

Going from PHP 7.3 to PHP 7.4 is less drastic than 5.6 to 7.0.
I guess that you won't have too many troubles going from 7.3 to 7.4.

See: https://www.php.net/manual/en/migration74.php
in particular: Backward Incompatible Changes.

Any templates providers compatible with PHP 7.4 ?
I know that Yootheme Pro is compatible with PHP 7.4.

Any infos about PHP 7.3 risks after the end off life ?
No.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
The best website: https://the-best-website.com

gilplane
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Mon Sep 03, 2012 2:25 pm

Re: End of PHP 7.3

Post by gilplane » Sat May 29, 2021 10:21 am

Thanks pe7er for your answer and infos,
No I didn't make the test but other users yes ... https://yootheme.com/support/question/140251
I don't want to use Yootheme Pro because it seems that is not only a templates but also a content manager. So if you use this > impossible to easly change of template provider. You will have to remake all your Joomla website...
Regards

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 23366
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: End of PHP 7.3

Post by pe7er » Sat May 29, 2021 11:03 am

gilplane wrote:
Sat May 29, 2021 10:21 am
I don't want to use Yootheme Pro because it seems that is not only a templates but also a content manager. So if you use this > impossible to easly change of template provider. You will have to remake all your Joomla website...
Ok, I understand. Usually I use custom templates. Sometimes Yootheme Pro. I don't have much experience with other commercial templates the last few years.

Joomla's Protostar is compatible with PHP 7.4. You can copy that to your own template name and change it to your liking.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
The best website: https://the-best-website.com


Post Reply

Return to “Administration Joomla! 3.x”