Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
hashem59
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Apr 20, 2018 2:10 pm

Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby hashem59 » Tue May 01, 2018 12:25 pm

my sit home page https://o2morny.com/demo/en/ takes 1.4 to laod
but if i entered sub dir page like https://o2morny.com/demo/en/perfumes it loads normally in about 3sec

any help what the problem could be, or what the best strategy to figure out where is the problem

krishna123
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue May 01, 2018 12:03 pm

Re: Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby krishna123 » Tue May 01, 2018 12:58 pm

May be first time ... have u checked it again. if you experience the same delay in subsequent loads as well then there may be other issues check with your host .. may be cache issues or may be database.

I am new to Joomla but speaking out of experience....

User avatar
starazure
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 101
Joined: Mon Sep 11, 2017 5:18 pm
Location: OH, United States
Contact:

Re: Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby starazure » Fri May 04, 2018 10:21 pm

hashem59 wrote:my sit home page https://o2morny.com/demo/en/ takes 1.4 to laod
but if i entered sub dir page like https://o2morny.com/demo/en/perfumes it loads normally in about 3sec

any help what the problem could be, or what the best strategy to figure out where is the problem


Oh my !! Thats a very very slow page.

You can use tools like this one to see what the bottlenecks are - https://tools.pingdom.com/#!/d33s1s/htt ... m/demo/en/
Its too slow so Im getting connection error.

Another option is to use chrome dev tools - Pres CTRL+SHIFT+C.. Then click on performance., Then 'Click to record'... Chrome will analyse your site..


Please dont be offended by my suggestion - My suggestion - You need to throw this site away and redo it. Look at the source of your page - It loads more than 50 css, js etc files...
view-source:https://o2morny.com/demo/en/

According to Google, any page that takes more than 4 seconds to load is useless.

hashem59
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Apr 20, 2018 2:10 pm

Re: Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby hashem59 » Sat May 05, 2018 12:04 am

starazure wrote:
hashem59 wrote:my sit home page https://o2morny.com/demo/en/ takes 1.4 to laod
but if i entered sub dir page like https://o2morny.com/demo/en/perfumes it loads normally in about 3sec

any help what the problem could be, or what the best strategy to figure out where is the problem


Oh my !! Thats a very very slow page.


thanks for your answer starazure, you are right but there is some thing you may not noticed which is got me confused that if you head to any sub dir page the page load normally why loads so slow on home page

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4860
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby sozzled » Sat May 05, 2018 12:21 am

@hashem59: This topic started four days ago. The affected website is crippled (due to circumstances that are beyond our knowledge or understanding). If this had been my website I would not have waited four days for an answer; I probably would not have waited four hours (if the matter was important to me).

This is what we know: we know nothing!

I agree with @starazure: I think it would be better to start again with a clean installation of Joomla (not some "quick start" package or webhost-provided script but the real thing by using the installation kit downloaded from https://downloads.joomla.org). Of course, if you want to do it some other way and spend time attempting to figure out what none of us knows, that's your business.

There is only one expert who knows everything there is to know about your J! website. That expert is not me and it's not @starazure or any other member of this community. The expert is you!

If you want our help then we suggest that you read the links contained in the pink-coloured section near the top of this page (especially the information about the Forum Post Assistant). Other people use the FPA report tool and get fast help; perhaps that's something you might consider doing yourself?

Yes, I went to your website and I gave up waiting for a response. I think that's what most other people would be doing also. It's your site, it's your business but—to be totally honest—it's also your problem.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
starazure
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 101
Joined: Mon Sep 11, 2017 5:18 pm
Location: OH, United States
Contact:

Re: Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby starazure » Sat May 05, 2018 12:25 am

Ok so I have an approach I would suggest. Unpublish one module at a time on the home page checking the speed each time. Write down what unpublishing each module improves the speed by. Its not happening on all pages so your template may not be the main culprit. It could be a module. I am surprised that I am writing detailed answers for you and your response is just one line without indicating what you have tried so far yourself. We would like to know what you have done too to debug this issue.

hashem59
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Apr 20, 2018 2:10 pm

Re: Home page takes 1.4 min to load but sub dir pages load normally in 3 seconds

Postby hashem59 » Sat May 05, 2018 2:29 pm

i really want to say thank you for you effords and your answer

@starazure if you are totally right about what you said

i'm nit the developer who made the site i started working on it about 10 days ago and i copied a back up and puplised it on sub domain https://o2morny.com/demo my main domain is https://o2morny.com it has the same problem but it has just from 8 to 20 secs delay on the home page espasilly if i entered the domain name with the en to loal the english version and i https://o2morny.com/en

i posted the problem on the sub domain thinking that if i could sovle it on the sub domain i 'll get rid of the 8-20 secs delay on the main domain home page i was discovering the site and the moduls and tried for now to install good cache plugins like jotcache which make the site load faster some times but now i fugured out the the home page has too many trashed and unpublished modules positioned on it i'm going to try work on the site on local host and try delete all these moduls and try and for sure i 'll try your suggestion by unpublishing one of the published modules each time

i have a question how could i make sure that it's not a servere issue i pinged my domain and the ping time was 187 mls

and i tried run a perfomance check on google chrome and got high idle time 17 secs which is the main problem
Image

i just got confused and didn'n know what to do to even debug the problem

thank you again guys


Return to “Performance - Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 2 guests