Slow loading, culprit unknown

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 189
Joined: Thu Oct 01, 2015 7:52 pm

Slow loading, culprit unknown

Post by tychapogoy » Thu Nov 19, 2020 2:36 pm

Dear users,

I wish to make loading our pages faster, if it is possible. The basic page on the site is loading up a 2 seconds. A basic example of an average public article is here with https://svjsvetova523-1.cz/81-clanky/ge ... lem-v-dome with debugging allowed and results in the bottom of the page.

Regularly, there are relatively large loading times at
  • afterInitialise
  • afterRenderComponent com_content
  • afterRender
I already reviewed the list of plugins and modules, which are allowed. I know that they may cause overhead, eve they are not loaded on the page.

What else can I review, please?

Some restricted content for login users is more complicated (more modules, sometimes embedded PDFs), but I do not care about the loading time there yet.
You do not have the required permissions to view the files attached to this post.

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2870
Joined: Sun May 04, 2008 12:37 pm

Re: Slow loading, culprit unknown

Post by waarnemer » Thu Nov 19, 2020 3:56 pm

see my comment on this: viewtopic.php?f=715&t=982995

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27296
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Slow loading, culprit unknown

Post by Per Yngve Berg » Thu Nov 19, 2020 4:03 pm

Mod. Note: Relocated the topic to the Performance Forum.

tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 189
Joined: Thu Oct 01, 2015 7:52 pm

Re: Slow loading, culprit unknown

Post by tychapogoy » Thu Nov 19, 2020 7:22 pm

Yey! By disabling "System - JCC - JS CSS Control" and "System - JCH Optimize" the afterRender section went from red to green. That alone saved seconds. Thank you! Earlier I feel for "You must optimize these!" advertisement.

tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 189
Joined: Thu Oct 01, 2015 7:52 pm

Re: Slow loading, culprit unknown

Post by tychapogoy » Thu Nov 19, 2020 9:15 pm

So, afterRender was the only section which I was able to "repair" with disabling JS optimisation. Thank you. Can you please point me to other ideas of performance optimisation?

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2870
Joined: Sun May 04, 2008 12:37 pm

Re: Slow loading, culprit unknown

Post by waarnemer » Fri Nov 20, 2020 8:03 am

turn off the debug at the bottom would already help a little..

tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 189
Joined: Thu Oct 01, 2015 7:52 pm

Re: Slow loading, culprit unknown

Post by tychapogoy » Fri Nov 20, 2020 9:38 am

Uff, what a change without debugging. It should be documented somewhere near the option, that Debugging increases afterInitialise overhead, or similar.

Thank you, dear waarnemer.


Post Reply

Return to “Performance - Joomla! 3.x”