Problem reading codes

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
piny008
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed May 01, 2013 11:39 pm

Problem reading codes

Post by piny008 » Wed May 01, 2013 11:42 pm

I have a problem with the article's editor.

i write the article content and when i try to add a "read more" line, it appears perfectly ( i mean the red dotted line appears indicate that the system is reading the order) but after i save it, instead the red line, just appear a gray line. this looks horrible in the maing page !!!! so i tried to insert the read more line with the html code in the html code editor:
<hr id="system-readmore" />
but after i save it looks like this
<hr id="\"system-readmore\"" />

i changed the defalut editoy from TinyMCE to NONE but id doesnt work.
i have this "reading html code" problem in all the site,
when i try to insert an image in my article it appears in the WYSIWYG editor, but after i save the article, it just dissapear. Please help me !!!! im loosing my mind !!

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27258
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Problem reading codes

Post by imanickam » Thu May 02, 2013 2:58 am

I believe that the PHP setting Magic Quotes was ON in this environment. For Joomla! 3.x, the PHP setting Magic Quotes has to be OFF.

Check with your host service provider about setting Magic Quotes to OFF.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

piny008
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed May 01, 2013 11:39 pm

Re: Problem reading codes

Post by piny008 » Thu May 02, 2013 3:48 am

How can i know if they are On ?
When i installed the JOomla pack i turned it off creating a Php.ini file because i havent one created.
This file has this:

register_globals = off
register_argc_argv = On
post_max_size = 8M
gpc_order = "GPC"
magic_quotes_gpc = off

Should i add more ?
ALso i dont have a .htacces file so i copy one of another host but i copy it as a htacces.txt

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27258
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Problem reading codes

Post by imanickam » Thu May 02, 2013 1:29 pm

You can review the information the System Information (System -> System Information).
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

piny008
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed May 01, 2013 11:39 pm

Re: Problem reading codes

Post by piny008 » Fri May 03, 2013 12:32 am

Yo are right.
MAgic Quotes appeared On.

After a long fight with mi php.ini file and the .thacces file i disable it
i will post if the problem is solved.

piny008
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed May 01, 2013 11:39 pm

Re: Problem reading codes

Post by piny008 » Fri May 03, 2013 12:46 am

Its solved !!! Thanks so much !!!!!!!!


Locked

Return to “Performance - Joomla! 3.x”