"404 - Article not found" for new articles

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
tehribo
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Sun Jan 02, 2011 3:42 pm

"404 - Article not found" for new articles

Post by tehribo » Mon Jan 16, 2017 11:08 am

Today I had to add new article, but when I save it and tried to open "404 - Article not found" error appeared.
No matter in which category or menu I move the article - the result is 404.

When I stop the "Search Engine Friendly URLs" option in the Site Settings the article loads normally.

All older articles opens normally.
My last successfully added article was added on 06.01.2017.

My site is in Bulgarian language.

Thank you in advance for your help!

tehribo
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Sun Jan 02, 2011 3:42 pm

Re: "404 - Article not found" for new articles

Post by tehribo » Mon Jan 16, 2017 11:31 am

1 year ago I made a change in administrator\components\com_content\config.xml, which enables "Sef Advanced Mode"

It is described here and removes the numbers from the URLs:

https://joomlaseo.com/blog/how-to-remov ... omla-url-s

Now I checked the config.xml file and these option wasn't there.
Then I added it again and disabled it, so the articles IDs were there again

The articles appeared, but I do not want this article IDs to be in my URL.

At least it will kill my SEO

rrohitbca
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jan 12, 2017 9:33 am

Re: "404 - Article not found" for new articles

Post by rrohitbca » Mon Jan 16, 2017 12:27 pm

Hi,
404 Article not found it indicate when some one file or data are deleted or misplaced and if you post an article and it not able to open as well as display the massage 404 - Article not found, its mean file is removed or corrupt. so check your file again.

itoctopus
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4026
Joined: Mon Nov 25, 2013 4:35 pm
Location: Montreal, Canada
Contact:

Re: "404 - Article not found" for new articles

Post by itoctopus » Mon Jan 16, 2017 4:46 pm

The problem is that you have another trashed article with the same alias. Delete that article and you should be OK.
http://www.itoctopus.com - Joomla consulting at its finest
https://twitter.com/itoctopus - Follow us on Twitter

tehribo
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Sun Jan 02, 2011 3:42 pm

Re: "404 - Article not found" for new articles

Post by tehribo » Tue Jan 17, 2017 6:58 am

Thank you itoctopus, but this is not the problem. Trash is empty. I have created maybe 10 different articles trying to solve the problem .... in different categories, formating and etc....nothing



Update: If I create an menu item for the article I can open it from everywhere.
But as soon as I remove the menu item - the 404 error comes back.
I do not want to create a menu item for each article ... :(

tehribo
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Sun Jan 02, 2011 3:42 pm

Re: "404 - Article not found" for new articles

Post by tehribo » Tue Jan 17, 2017 7:10 am

Today the strange saga continues...

If I add a dash " - " in the article Alias the problem is solved and the article can be opened

Thank you in advance for your support!

rkuenen
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Mar 20, 2018 8:07 pm

Re: "404 - Article not found" for new articles

Post by rkuenen » Tue Mar 20, 2018 8:10 pm

Hello, I'm new here....

I have the exact same problem as described above.
The only difference is that the "-" add does not work.

My Joomla version is 3.8.6.

Anyone a suggestion?

Regards, René


Post Reply

Return to “Performance - Joomla! 3.x”