Page 1 of 1

Slow site prior to first initial connection

Posted: Sun Oct 14, 2018 4:57 pm
by ggossamer
Hi, we have a joomla-3.8.8 site running on fedora28 and the time before the initial first connection, according to watching access_log, is very long.

I don't believe it's a DNS issue because I've visited the site before and it should be cached. Are there specific server tuning parameters you recommend to improve the initial time it takes before the first page is loaded?

How does the site load for you?
https://webstage.linuxsecurity.com/

Re: Slow site prior to first initial connection

Posted: Sun Oct 14, 2018 5:22 pm
by Webdongle
Both your Joomla and Fedora are out of date.

Re: Slow site prior to first initial connection

Posted: Sun Oct 14, 2018 5:29 pm
by ggossamer
Webdongle wrote:
Sun Oct 14, 2018 5:22 pm
Both your Joomla and Fedora are out of date.
Yes, thank you. However, fedora29 is still beta, and joomla is not all that far from being the latest that it should be an issue.

Re: Slow site prior to first initial connection

Posted: Sun Oct 14, 2018 7:52 pm
by Webdongle
Update Joomla first and update all your extensions
Then please viewtopic.php?f=714&t=793531

Re: Slow site prior to first initial connection

Posted: Mon Oct 15, 2018 8:09 am
by csthomas
Since you have many articles on your site, you must start with optimizing your database queries.

Re: Slow site prior to first initial connection

Posted: Mon Oct 15, 2018 8:41 am
by SharkyKZ
Also disable JCH Optimize or at least lower its settings. It can be very taxing in terms of PHP/server performance.

Re: Slow site prior to first initial connection

Posted: Mon Oct 15, 2018 2:51 pm
by occultfish
Personal experience with jch optimize is that it can conflict with other caching resources that are server and joomla side. Disable it and tell us what the difference is in the speed of your site. Also, try clearing your server-side chache (purge) so it can be re-created. Sometimes it can bloat your website.

Re: Slow site prior to first initial connection

Posted: Mon Oct 15, 2018 4:23 pm
by ggossamer
Thank you all so much for your help. We're working on updating joomla and the extensions.

I've also disabled JCH-optimize and it made no difference. I don't think that was the problem.

Looking at the logs, the delay is prior to the first entry. On mobile 3G, it's probably 45 seconds before the first entry in the access_log. It then loads the rest of the site nearly instantly.