Website + Backend extremly slow/not working

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Sascha-RT
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Feb 13, 2019 11:25 pm

Website + Backend extremly slow/not working

Post by Sascha-RT » Wed Feb 13, 2019 11:35 pm

Hey,

I'm running a fairly large website on Joomla 3.8.13 with PHP 5.6.36.
My website has a multiple components and modules installed, the major one being Virtuemart 3.2.2 and the newest version of HIkashop.
I'm using virtuemart as a product catalog and hikashop as a shop.

This morning, without any major changes/updates to the website, it got incredibly slow. With slow I mean it takes 10+ minutes to load a page. What wonders me is, that the pages eventually load. Front- and Backend.
That's why I'm a little lost. If it's a module that's broken, it would be only the Front-End.

I talked to the Hosting and they said everything looks fine on their end and it has to do with the 'efficiency' of my page.

Two things I noticed:
1. My error log got filled with this:
[13-Feb-2019 19:38:56 UTC] PHP Strict Standards: Non-static method modFeatureProdGridHelper::createThumb() should not be called statically in /home/**/modules/mod_vm2_featureprodgrid/helper.php on line 192
After hours of waiting I was able to delete that module, but nothing changed, beside the error log stopped filling.

2. My virtuemart and page cache keeps filling, even though nobody is on the page (checked analytics). Fills right up again, even if I delete through joomla or manually via fto.

I tried accessing pages directly, inside and outside of virtuemart, but same issue.

Any help or tip is highly appreciated, since I'm not sure where to search for next.

Thank you!

User avatar
DaveOzric
Joomla! Ace
Joomla! Ace
Posts: 1543
Joined: Sat May 22, 2010 10:29 pm
Contact:

Re: Website + Backend extremly slow/not working

Post by DaveOzric » Sat Apr 27, 2019 8:06 pm

Did you get this sorted out? It's been a while but no replies.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4732
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Website + Backend extremly slow/not working

Post by AMurray » Sat Apr 27, 2019 11:15 pm

An old post but some observations and suggestions to fix.

VirtueMart current release is 3.4.1 (Oct 2018) so don't know why OP was using v3.2.2 in Feb 2019 at time of posting this question.

PHP 5.6.x was EOL in December 2018, needs to be updated to at least 7.1/7.2

Joomla v3.8.13 was released October 2018, but latest release (as at Feb 2019) was v3.9.3

Hika Shop 4.0.1 (March 2019).

Since this is in the Performance forum, the first thing, update those extensions, then see if your host offers PHP 7.2 or higher which should result in some speed and efficiency improvements.

Other things to check are that all other extensions (third party) are updated, and compatible with the latest Joomla (3.9.5 at time of writing this response) and compatible with more recent or latest PHP (7.2.x / 7.3.x).
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
DaveOzric
Joomla! Ace
Joomla! Ace
Posts: 1543
Joined: Sat May 22, 2010 10:29 pm
Contact:

Re: Website + Backend extremly slow/not working

Post by DaveOzric » Sat Apr 27, 2019 11:26 pm

The reason I asked, was because I had a very similar thing happen years ago. I had a VPS hosting that one day just went molasses on me. Backend saves took minutes. Drove me batty. My hosting company fought me tooth and nail it was some Joomla issue. After weeks of arguing with them, their tier 2 support found a server setting/update that was not correct. It was a while ago, so a bit fuzzy but I think they said a mismatched something needed to be updated. Then it was all good again. Obviously, this is just an example and speculation. Web hosting companies will always argue your site is the issue. So annoying, but it probably usually is the case.

All I am saying is don't ever rule out a hosting issue.

Dolios
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sat Apr 27, 2019 9:39 pm

Re: Website + Backend extremly slow/not working

Post by Dolios » Mon Apr 29, 2019 6:52 am

Recommendation from me would be php 7.3 & nginx webserver. Nginx is a lot faster than apache. If you want you could try to use a cdn such as cloudflare too to speedup the website even more!


Post Reply

Return to “Performance - Joomla! 3.x”