Almost bare bones and still only PageSpeed 52

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Almost bare bones and still only PageSpeed 52

Post by Forsh » Wed Dec 04, 2019 10:53 am

It's just the latest Joomla install with a Gantry front page. No pictures, just some text and small icons and loads slow. When I use the RokBooster caching plugin I get a few milliseconds faster but that's all. Joomla caching is enabled as well. Any suggestions for this? I have no pictures or anything, didn't expect it to be this slow....5-seconds to render that box and text....what the heck.

These are the Page Speed Insights
denver-donate-pagespeed.jpg
You do not have the required permissions to view the files attached to this post.

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2857
Joined: Sun May 04, 2008 12:37 pm

Re: Almost bare bones and still only PageSpeed 52

Post by waarnemer » Wed Dec 04, 2019 11:31 am

Do follow the hints an tips where possible


I see all loaded twice in my debugger... (F12 network) ... on second visit.
Something with a wkpwa_sw.js triggering this as initiator... which is a webkul dot com script. do you have PWA installed?

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Wed Dec 04, 2019 11:38 am

I have Webkul PWA installed, yes. I will disable it right now and see how that goes. What about all of that CSS/JS under render blocking resources, any suggestions for those?
denver-donate-render-blocking.jpg
You do not have the required permissions to view the files attached to this post.
Art Gallery in Denver Colorado http://denver.gallery

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2857
Joined: Sun May 04, 2008 12:37 pm

Re: Almost bare bones and still only PageSpeed 52

Post by waarnemer » Wed Dec 04, 2019 12:20 pm

usually not much... as these are doing your design/template mostly (99.9%)

your woff files have no expiry time (fonts)

also in your style-5.3.2.min.css there is a font videoJS as base64... which is ok if you used it, but I don't see any videos on your site.

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Wed Dec 04, 2019 12:25 pm

I wonder if my hosting might also have something to do with it? I used this exact same template, with this exact same website (I'm setting it up again after taking it down) and I was with Siteground hosting. My page speed for that exact page was 99. I am with Namecheap now and I am at 52.
Art Gallery in Denver Colorado http://denver.gallery

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Wed Dec 04, 2019 1:10 pm

Ok, here we go. I turned off RokBooster and installed and configured JCHOptimize and......holy crap. That's what you call a performance boost and I even added an image on the page.
denver-donate-page-speeds-98.jpg
You do not have the required permissions to view the files attached to this post.
Art Gallery in Denver Colorado http://denver.gallery

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2857
Joined: Sun May 04, 2008 12:37 pm

Re: Almost bare bones and still only PageSpeed 52

Post by waarnemer » Wed Dec 04, 2019 2:20 pm

Great! That is some improvement!

And, for testing purposes, what without JCH Optimize?
Out of interest since I have the experience some stuff breaks when optimizing css and js.

Also what without the wkpwa (as I still see double file loads initiated by wkpwa_sw.js)?

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Wed Dec 04, 2019 2:24 pm

I disabled the PWA for that test and currently still have it off. I will turn it back on and run another test and see if it affects the performance. I really want that PWA because it's really a cool thing to offer people. Saving your website to their phone like and app and push notifications being sent to it...that's a really cool thing. I'll test enabling it and see what happens here shortly.
Art Gallery in Denver Colorado http://denver.gallery

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2857
Joined: Sun May 04, 2008 12:37 pm

Re: Almost bare bones and still only PageSpeed 52

Post by waarnemer » Wed Dec 04, 2019 2:55 pm

Oh.. it still showed here while I had cache disabled in my browser...

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Wed Dec 04, 2019 3:30 pm

How about now?
Art Gallery in Denver Colorado http://denver.gallery

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39204
Joined: Sat Apr 05, 2008 9:58 pm

Re: Almost bare bones and still only PageSpeed 52

Post by Webdongle » Wed Dec 04, 2019 3:56 pm

Forsh wrote:
Wed Dec 04, 2019 2:24 pm
I disabled the PWA for that test and currently still have it off...
You need to clear Joomla cache after disabling something and prior to testing. Also test with Protostar as default Template.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2857
Joined: Sun May 04, 2008 12:37 pm

Re: Almost bare bones and still only PageSpeed 52

Post by waarnemer » Wed Dec 04, 2019 9:05 pm

much better :)

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Thu Dec 05, 2019 2:46 pm

waarnemer wrote:
Wed Dec 04, 2019 9:05 pm
much better :)
Quick question on the PWA topic, do you happen to have a PWA up and running on Joomla (a live site) that works?

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2857
Joined: Sun May 04, 2008 12:37 pm

Re: Almost bare bones and still only PageSpeed 52

Post by waarnemer » Thu Dec 05, 2019 3:25 pm

No nothing but I can imagine you actually only would want to run it when a mobile device visits and not when a desktop/laptop comes along... you may want to ask the developer..

Forsh
Joomla! Explorer
Joomla! Explorer
Posts: 298
Joined: Sat Aug 20, 2005 3:05 pm
Location: 1135 N Broadway #213 Denver, CO 80203
Contact:

Re: Almost bare bones and still only PageSpeed 52

Post by Forsh » Fri Dec 06, 2019 2:05 pm

Small update on this so others can see if they have the same problem. My mobile was less than 52. Just basic setting brought me to 82 mobile and 98 desktop. Google PageSpeed told me to preload. By enabling a preload option in JCE I bumped everything higher especially my mobile score.
denverdonate-pagespeed.jpg
You do not have the required permissions to view the files attached to this post.


Post Reply

Return to “Performance - Joomla! 3.x”