Is it my host or my joomla website causing the issue?

Discussion regarding Joomla! 3.x Performance issues.

Moderators: General Support Moderators, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
UnderGroundMics
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jun 16, 2020 4:10 pm

Is it my host or my joomla website causing the issue?

Post by UnderGroundMics » Tue Jun 16, 2020 4:35 pm

Hello everyone,

I recently installed a Joomla website through Cpanel of hostgator. The site has been running a few weeks now. It doesn't have much content as I am still building the website. It mainly is JomSocial and a few links.

Today it is taking 1-2 minutes for a page to load and sometimes it even times out. I contacted my host and they recommended to upgrade Joomla from 3.9.18 to 3.9.19 which I did but it has not fixed the problem. I have tested it on 2 different browsers and my phone and I am having the same issue.

How do I know if it is my website or the host causing the issue? Either way how can I fix it?

My website is UnderGroundMics.com if you would like to see the slow load times.

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4214
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Is it my host or my joomla website causing the issue?

Post by gws » Tue Jun 16, 2020 4:56 pm

Run your site through Gtmetrix and see what the report says.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27553
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Is it my host or my joomla website causing the issue?

Post by Per Yngve Berg » Tue Jun 16, 2020 7:00 pm

Please use the Forum Post Assistant. See pink frame above.
Your site returns a 500 server error.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6475
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Is it my host or my joomla website causing the issue?

Post by AMurray » Tue Jun 16, 2020 10:31 pm

I don't see any Error 500 (perhaps that was temporary) and the site (for me) is not taking 1-2 mins to load.

Out of interest, ran this through GtMetrix, and the only things of note were focus on improving optimisation of images, using caching and optimising (minifying) javascript.
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1707
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: Is it my host or my joomla website causing the issue?

Post by darb » Wed Jun 17, 2020 4:46 am

Site runs fast for me and MrJameZtown.

So no problem any more @UnderGroundMics ?

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2291
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Is it my host or my joomla website causing the issue?

Post by JAVesey » Mon Jun 22, 2020 7:38 pm

Pretty quick for me here in the UK. Only looked at the homepage though.

Flagged as "Not secure" due to no SSL Certificate but that's about it.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.24 and PHP7.4.11

noxidsoft
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Sun Aug 16, 2009 2:39 pm
Location: Queensland Australia
Contact:

Re: Is it my host or my joomla website causing the issue?

Post by noxidsoft » Thu Jun 25, 2020 9:34 am

In Google Chrome, hit F12 and reload the website on the Network tab:

107 requests
7.8 MB transferred
10.6 MB resources
Finish: 1.0 min
DOMContentLoaded: 3.58 s
Load: 16.87 s

That's what I get, but it is from Australia.

I can see immediately, you have 2x large images, 1.7mb and 2.0mb, may be profile pictures? You might need to limit 3rd party profile image uploads/sizing.


Post Reply

Return to “Performance - Joomla! 3.x”