Joomla! does not read max_input_vars from .user.ini Topic is solved

Discussion regarding Joomla! 3.x Performance issues.
Post Reply
User avatar
cherchri
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 150
Joined: Wed Aug 31, 2005 7:17 pm
Location: Austria

Joomla! does not read max_input_vars from .user.ini

Post by cherchri » Wed Jan 13, 2021 12:07 pm

Hello community,

I came across a very weird issue with a site I manage. The page runs on a shared hosted environment. (Apache 2.4.38 / PHP 7.4.13). Suddenly the creation of new modules and the modification of present modules is not possible anymore.

*Whenever I try to change any settings of a present module, and hit the "save" button in the backend the module's settings, the site loads the modules list and marks that specific module as "locked". But no settings are changed.
*Whenever I create a new module and hit "save" or "save and close", in any case the list of module will be loaded, but without any new module. No new entry in the database.

So I did some research and came across a similar topic here in the forums: viewtopic.php?f=708&t=980833&p=3608249& ... s#p3608249
and also a entry at stackexchange: https://joomla.stackexchange.com/questi ... ny-modules
Both entries say something about the php value max_input_vars, so I checked to find out it was set to '1000' by my hosting provider.
For the next step I cloned the site to my local environment to test out if a change of that value would resolve the issue. Yes, it did! When I set the value to 1000 the same behaviour would occur. After I set the value to 5000 the module creation and modification were possible again without any problems.

Fine.

My provider (obviously) won't change the settings for the whole server but provided a new value for the specific webhost my site is running in by overriding the standard with a .user.ini file.
Now I can see two values when calling a <? PHPINFO(); ?>:

max_input_vars:
*master value 1000
*local value 5000

So here comes my question / issue: In the backend of my Joomla! installation still the standard (master) value of '1000' shows up. Why would Joomla! ignore the value set by .user.ini file? And: Is there a way to make Joomla! read that specific local value?

Thanks for your inputs!
cherchri
Last edited by cherchri on Wed Jan 13, 2021 12:58 pm, edited 2 times in total.
der mensch lebt nicht vom brot allein

User avatar
cherchri
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 150
Joined: Wed Aug 31, 2005 7:17 pm
Location: Austria

Re: Joomla! does not read max_input_vars from .user.ini

Post by cherchri » Wed Jan 13, 2021 12:19 pm

answering to myself!
Just in case anyone is looking for a similar solution.

The setting will not be inherited to subfolders.
I needed to put the user.ini file to the /administrator folder.
Problem solved!
der mensch lebt nicht vom brot allein


Post Reply

Return to “Performance - Joomla! 3.x”