Upgrade 3.4.8 to 3.5 [solved]

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Locked
matthiaswkamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Mar 11, 2015 9:46 am
Location: Kloster Allerheiligenberg, Lahnstein
Contact:

Upgrade 3.4.8 to 3.5 [solved]

Post by matthiaswkamp » Tue Mar 22, 2016 10:31 am

Hi, I just tried to updated my site as offered in the backend.
Now, I can't approch the backenend anymore and the frontend throws a SQL Collateration error:
Error displaying the error page: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=' SQL=SELECT template, s.params FROM #__template_styles as s LEFT JOIN #__extensions as e ON e.type='template' AND e.element=s.template AND e.client_id=s.client_id WHERE s.client_id = 1 AND home = '1' ORDER BY home: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=' SQL=SELECT template, s.params FROM #__template_styles as s LEFT JOIN #__extensions as e ON e.type='template' AND e.element=s.template AND e.client_id=s.client_id WHERE s.client_id = 1 AND home = '1' ORDER BY home
____

Change of configuration.php (Cache off, Debug on, Maintainance on) doesn't change anything.
Help urgently needed.
Greeting
Matt
Last edited by mandville on Fri Mar 25, 2016 11:26 am, edited 1 time in total.
Reason: marked solved as shown by OP

User avatar
JacquesR
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Tue May 19, 2009 3:00 pm
Location: Cape Town, South Africa
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by JacquesR » Tue Mar 22, 2016 1:13 pm

Since you cannot access the admin, a quick temporary fix is to re-install your most recent backup.

Which template are you using? (or template framework)

matthiaswkamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Mar 11, 2015 9:46 am
Location: Kloster Allerheiligenberg, Lahnstein
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by matthiaswkamp » Tue Mar 22, 2016 2:20 pm

I am using the Gantry Framework

wilsonge
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Wed Jan 20, 2010 4:33 pm
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by wilsonge » Tue Mar 22, 2016 2:29 pm

This looks like the upgraded got botched halfway through - otherwise all the core tables would have unicode collation rather than one table with general and one with unicode.

What happens when you try to get into the backend?

matthiaswkamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Mar 11, 2015 9:46 am
Location: Kloster Allerheiligenberg, Lahnstein
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by matthiaswkamp » Tue Mar 22, 2016 4:27 pm

exactly the above screen. nothing else.:

Error displaying the error page: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=' SQL=SELECT template, s.params FROM #__template_styles as s LEFT JOIN #__extensions as e ON e.type='template' AND e.element=s.template AND e.client_id=s.client_id WHERE s.client_id = 1 AND home = '1' ORDER BY home: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '=' SQL=SELECT template, s.params FROM #__template_styles as s LEFT JOIN #__extensions as e ON e.type='template' AND e.element=s.template AND e.client_id=s.client_id WHERE s.client_id = 1 AND home = '1' ORDER BY home

matthiaswkamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Mar 11, 2015 9:46 am
Location: Kloster Allerheiligenberg, Lahnstein
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by matthiaswkamp » Tue Mar 22, 2016 4:40 pm

System up and runnign again:

What I did: from SQL Workbench I run the latest akeeba db Database Backup - script.

I tried that before via putty directly on the server -> run on script error.

What stays : some errors in displaying content (collateration errors). I will find out, which tables are involved. If you have hints, please tell me.

matthiaswkamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Mar 11, 2015 9:46 am
Location: Kloster Allerheiligenberg, Lahnstein
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by matthiaswkamp » Tue Mar 22, 2016 4:55 pm

Ok : as far as I can see it is only the content of modules (Custom - HTML) involved. In the Backend the Umlaute (öäüß) are correct, in the frontend not.

matthiaswkamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Wed Mar 11, 2015 9:46 am
Location: Kloster Allerheiligenberg, Lahnstein
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by matthiaswkamp » Tue Mar 22, 2016 5:02 pm

After cleaning the cache files the "Umlaute" also are displayed correct in frontend.

Thanx for help. Ticket can be put to solved.

gilman01
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Sat Jan 16, 2010 6:44 pm

Re: Upgrade 3.4.8 to 3.5

Post by gilman01 » Wed Mar 23, 2016 12:10 am

Thanks for the info. I had the same issue going from 3.4.8 to 3.5 on a 2 day old website with only one page except I was able to get to the backend. Loaded Akeeba AdminTools and ran the database collation tool. Changed the setting from UTF-8 multibyte to UTF-8 Joomla (Default). That cleared up my problems. I cleared the cache and reverted back to to UTF-8 multibyte and the site is working fine.

Thanks for sharing - saved me a lot of headaches.

demor
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Oct 04, 2006 11:27 am

Re: Upgrade 3.4.8 to 3.5

Post by demor » Thu Mar 24, 2016 9:11 pm

after a successful upgrading while I still have access to back end, in the front end I get the:
Fatal error: Using $this when not in object context in /home/digiworx/public_html/libraries/joomla/filter/input.php on line 233

Please advise

User avatar
JacquesR
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Tue May 19, 2009 3:00 pm
Location: Cape Town, South Africa
Contact:

Re: Upgrade 3.4.8 to 3.5

Post by JacquesR » Fri Mar 25, 2016 6:51 am

demor wrote:after a successful upgrading while I still have access to back end, in the front end I get the:
Fatal error: Using $this when not in object context in /home/digiworx/public_html/libraries/joomla/filter/input.php on line 233

Please advise
You most likely have the Ari Image Slider installed.
Update to their latest version and it should fix the issue.
See: http://forum.joomla.org/viewtopic.php?f ... 3#p3379239

demor
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Oct 04, 2006 11:27 am

Re: Upgrade 3.4.8 to 3.5

Post by demor » Fri Mar 25, 2016 9:08 am

Thnx a lot. I resolved the issue this way

Nick95
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jun 15, 2013 4:14 pm

Re: Upgrade 3.4.8 to 3.5 [solved]

Post by Nick95 » Sat Apr 09, 2016 6:44 pm

I have just had a similar error after an update to Joomla 3.5 from 3.4.8. The session timed out during the update.
Logging on to myphp admin I looked at the extensions table. Looking at the structure I could see that the collations were all utf8_unicode_ci . I changed this for the type,name and element fields to utf8_general_ci .

My front and backends now work!

DEEP JOY


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”