Joomla upgrade 3.7 to 3.8 kills website

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
websroger
Joomla! Intern
Joomla! Intern
Posts: 84
Joined: Tue Jan 04, 2011 4:23 pm
Location: Fort Collins, CO, USA
Contact:

Joomla upgrade 3.7 to 3.8 kills website

Post by websroger » Fri Feb 23, 2018 5:43 pm

I have a Joomla website hosted on Siteground, with an auto-upgrade facility. When I tried to upgrade from 3.7.5 to 3.8.5 the website went down with errors that related to the joomla code, not any of mine. Are there known errors in the autoupgrade? If so have they been fixed? Could there be a template incompatibility?

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5501
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by sozzled » Fri Feb 23, 2018 6:26 pm

I'm sorry to hear that, as a consequence of updating from J! 3.7.5 to J! 3.8.5 your site "went down" with a number of unspecified errors that involved changes with Joomla and not as a result of anything that you might have done. The short answers to your three questions are:

1) No (but there have been six releases since J! 3.8 first appeared seven moths ago, involving 30000+ lines of PHP and other code, so I can't say what may be involved with any complete authority)
2) Not applicable
3) Possibly

Does that help?

On a more serious note: we don't know what you're attempting to describe. J! 3.8.5 has been successful with only a small handful of non-catatrophic errors involved. When people do encounter problems, it helps to be a bit more specific is describing the details of those problems. LastlyImage
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

websroger
Joomla! Intern
Joomla! Intern
Posts: 84
Joined: Tue Jan 04, 2011 4:23 pm
Location: Fort Collins, CO, USA
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by websroger » Fri Feb 23, 2018 7:04 pm

The only way to show what the error sheet says, that comes up instead of the front page after upgrade attempt, is to try another upgrade. Unfortunately, I did not copy the error page, as I should have. I really don't want the website to die again with another upgrade attempt.
Can someone tell me what templates are or are not compatible with 3.8 (but are with 3.7)?

websroger
Joomla! Intern
Joomla! Intern
Posts: 84
Joined: Tue Jan 04, 2011 4:23 pm
Location: Fort Collins, CO, USA
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by websroger » Fri Feb 23, 2018 7:14 pm

sozzled indicated I should use the Forum Post Assistant. Fine, but I cannot find a link to this on the Forum site, although there are several references to it{ "see top of this Forum..."]

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5501
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Cannot find a link to the FPA report on the forum

Post by sozzled » Fri Feb 23, 2018 7:26 pm

1) Go to the pink section at the top of this page (as you see in the picture I posted above).
2) Find the words that are written in blue text that say "Forum Post Assistant" (within that pink area).
3) If you are using a mouse, click somewhere on those words.
4) When the target of that link opens on your browser, read the instructions.
5) If you have questions about using the FPA tool, please create a new topic on this forum, with the subject "How do I use xxxxxxxxxxxxxxxxxx with the Forum Post Assistant tool?", and we'll be happy to answer those questions.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5501
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by sozzled » Fri Feb 23, 2018 7:31 pm

websroger wrote:The only way to show what the error sheet says, that comes up instead of the front page after upgrade attempt, is to try another upgrade.
If you show us a screen shot of what the "error sheet says" we may be able to help you. Unfortunately, we can't see what you can. Surely you have a backup of your website and it should be a simple matter to revert the site back what it was with J! 3.7.5, no?
websroger wrote:Can someone tell me what templates are or are not compatible with 3.8 (but are with 3.7)?
There are more than 1 million—I'm not exaggerating—different Joomla templates that exist in the world. It would be impossible to list every template that is incompatible with J! 3.8, if (and only if) the errors you're having are, in fact, related to the template. It would be a waste of time attempting to compile and maintain that kind of list. Sorry.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

freeloader
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Oct 03, 2010 1:57 am

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by freeloader » Fri Feb 23, 2018 10:05 pm

Joomla upgrade from 3.74 to 3.85 is breaking the site to the point that I only get "ERROR" in typewriter font and nothing else. I am unable to access the html portion of the website; I can only see files in CPanel.
I am also not able to run any files on the site kickstart.php for example, won't load.
I manually created a post-update.php file and afterwards, it responded that 3.7.4 update successful.
Afterwards, running the update repeats the error condition.
As it is, I have yet to find a way to upgrade to 3.8.
Suggestions?

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5501
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by sozzled » Fri Feb 23, 2018 10:45 pm

freeloader wrote:Suggestions?
Use the Forum Post Assistant report generator, post it here, and perhaps someone may be able to help you.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3838
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by AMurray » Fri Feb 23, 2018 10:52 pm

To reiterate once again, the Forum Post Assistant is in the pink (red) section with a bold heading, "Forum Rules" .......scroll up to the top of screen of this very thread (your question) and you will see it there. If you don't then can you post a screenshot of what you see, or don't see, of the forum screen?

This is what you should be seeing (click the image for larger version):
fpa.JPG
If you can't find it then click the link: viewtopic.php?f=621&t=582860.
You do not have the required permissions to view the files attached to this post.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

freeloader
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Oct 03, 2010 1:57 am

Unable to upgrade from J3.7.4

Post by freeloader » Sat Feb 24, 2018 3:21 pm

Joomla upgrade from 3.74 to 3.85 is breaking the site to the point that I only get "ERROR" in typewriter font and nothing else. I am unable to access the html portion of the website; I can only see files in CPanel.
I am also not able to run any files on the site kickstart.php for example, won't load.
I manually created a post-update.php file and afterwards, it responded that 3.7.4 update successful.
Afterwards, running the update repeats the error condition.
As it is, I have yet to find a way to upgrade to 3.8.
Suggestions?
TIA!
Forum Post Assistant (v1.3.9) : 24th February 2018 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.7.4-Stable (Amani) 25-July-2017
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Writable (640) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 3.7
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 0 | SEF ReWrite: 1 | .htaccess/web.config: Yes | GZip: 1 | Cache: 2 | CacheTime: 10 | CacheHandler: vmfile | CachePlatformPrefix: 0 | FTP Layer: 0 | Proxy: 0 | LiveSite: | Session lifetime: 90 | Session handler: database | Shared sessions: 0 | SSL: 2 | FrontEdit: 1 | Error Reporting: default | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 0 | dbConnection Type: mysqli | Database Credentials Present: Yes

Host Configuration :: OS: Linux | OS Version: 3.10.0-714.10.2.lve1.5.8.el7.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 5884.77 GiB |

PHP Configuration :: Version: 7.1.7 | PHP API: cgi-fcgi | Session Path Writable: No | Display Errors: | Error Reporting: 22519 | Log Errors To: /dev/null | Last Known Error: 11th January 2018 23:16:10. | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 128M | Max. POST Size: 128M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 512M

MySQL Configuration :: Version: 5.5.5-10.2.11-MariaDB-log (Client:mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 15.58 MiB | #of Tables:  200
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.7) | date (7.1.7) | libxml (7.1.7) | openssl (7.1.7) | pcre (7.1.7) | zlib (7.1.7) | bcmath (7.1.7) | bz2 (7.1.7) | calendar (7.1.7) | ctype (7.1.7) | curl (7.1.7) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.7) | ftp (7.1.7) | gd (7.1.7) | gettext (7.1.7) | SPL (7.1.7) | iconv (7.1.7) | session (7.1.7) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.7) | mcrypt (7.1.7) | standard (7.1.7) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $) | mysqli (7.1.7) | PDO (7.1.7) | pdo_mysql (7.1.7) | pdo_pgsql (7.1.7) | pgsql (7.1.7) | Phar (2.0.2) | posix (7.1.7) | pspell (7.1.7) | Reflection (7.1.7) | imap (7.1.7) | SimpleXML (7.1.7) | soap (7.1.7) | sockets (7.1.7) | exif (1.4 $Id: 8bdc0c8f27c2c9dd1f7551f1f9fe3ab57a06a4b1 $) | tidy (7.1.7) | tokenizer (7.1.7) | xml (7.1.7) | xmlreader (7.1.7) | xmlrpc (7.1.7) | xmlwriter (7.1.7) | xsl (7.1.7) | zip (1.13.5) | cgi-fcgi () | Zend Engine (3.1.0) |
Potential Missing Extensions :: mysql | suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (755) | --protected-- (---) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 3744159 | Threads: 390 | Questions: 5902438624 | Slow queries: 67813 | Opens: 88272247 | Flush tables: 1 | Open tables: 32768 | Queries per second avg: 1576.439 |
Extensions Discovered :: wrote:Strict Information Privacy was selected. Nothing to display.
Templates Discovered :: wrote:Strict Information Privacy Nothing to display.
[/size]
[/quote]
Last edited by toivo on Sat Feb 24, 2018 4:06 pm, edited 1 time in total.
Reason: mod note: merged, cross posting not allowed in the forum rules, available from https://forum.joomla.org/viewtopic.php?f=8&t=65

freeloader
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Oct 03, 2010 1:57 am

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by freeloader » Sat Feb 24, 2018 3:23 pm

Apologies -
I've created viewtopic.php?f=710&t=959542

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5501
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by sozzled » Sat Feb 24, 2018 7:06 pm

According to the truncated FPA report that you posted—it would have helped if you'd attempted to post a more complete report—the following facts are established:

1) The website shows that J! 3.7.4 is still being used;
2) The session path is not writeable (you may need to discuss this with your webhosting provider)
3) The collation method and character encoding for the database are wrong for J! 3.7.4; they should be utf8_general_ci / utf8 respectively

If you want further advice then you should try providing us with a more comprehensive FPA report.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

freeloader
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Oct 03, 2010 1:57 am

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by freeloader » Sat Feb 24, 2018 9:40 pm

Problem Description :: Forum Post Assistant (v1.3.9) : 24th February 2018 wrote:RE: Unable to upgrade from J3.7.4
Forum Post Assistant (v1.3.9) : 24th February 2018 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.7.4-Stable (Amani) 25-July-2017
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Writable (640) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 3.7
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 0 | SEF ReWrite: 1 | .htaccess/web.config: Yes | GZip: 1 | Cache: 2 | CacheTime: 10 | CacheHandler: vmfile | CachePlatformPrefix: 0 | FTP Layer: 0 | Proxy: 0 | LiveSite: | Session lifetime: 90 | Session handler: database | Shared sessions: 0 | SSL: 2 | FrontEdit: 1 | Error Reporting: default | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 0 | dbConnection Type: mysqli | Database Credentials Present: Yes

Host Configuration :: OS: Linux | OS Version: 3.10.0-714.10.2.lve1.5.8.el7.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 5879.97 GiB |

PHP Configuration :: Version: 7.1.7 | PHP API: cgi-fcgi | Session Path Writable: No | Display Errors: | Error Reporting: 22519 | Log Errors To: /dev/null | Last Known Error: 11th January 2018 23:16:10. | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: | Uploads: 1 | Max. Upload Size: 128M | Max. POST Size: 128M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 512M

MySQL Configuration :: Version: 5.5.5-10.2.11-MariaDB-log (Client:mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 15.58 MiB | #of Tables:  200
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.7) | date (7.1.7) | libxml (7.1.7) | openssl (7.1.7) | pcre (7.1.7) | zlib (7.1.7) | bcmath (7.1.7) | bz2 (7.1.7) | calendar (7.1.7) | ctype (7.1.7) | curl (7.1.7) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.1.7) | ftp (7.1.7) | gd (7.1.7) | gettext (7.1.7) | SPL (7.1.7) | iconv (7.1.7) | session (7.1.7) | intl (1.1.0) | json (1.5.0) | mbstring (7.1.7) | mcrypt (7.1.7) | standard (7.1.7) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $) | mysqli (7.1.7) | PDO (7.1.7) | pdo_mysql (7.1.7) | pdo_pgsql (7.1.7) | pgsql (7.1.7) | Phar (2.0.2) | posix (7.1.7) | pspell (7.1.7) | Reflection (7.1.7) | imap (7.1.7) | SimpleXML (7.1.7) | soap (7.1.7) | sockets (7.1.7) | exif (1.4 $Id: 8bdc0c8f27c2c9dd1f7551f1f9fe3ab57a06a4b1 $) | tidy (7.1.7) | tokenizer (7.1.7) | xml (7.1.7) | xmlreader (7.1.7) | xmlrpc (7.1.7) | xmlwriter (7.1.7) | xsl (7.1.7) | zip (1.13.5) | cgi-fcgi () | Zend Engine (3.1.0) |
Potential Missing Extensions :: mysql | suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (---) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 3766981 | Threads: 390 | Questions: 5934275606 | Slow queries: 68125 | Opens: 88807702 | Flush tables: 1 | Open tables: 32768 | Queries per second avg: 1575.339 |
Extensions Discovered :: wrote:Components :: SITE :: com_mailto (3.0.0) 1 | WF_LINK_SEARCH_TITLE (2.6.9) 1 | WF_LINKS_JOOMLALINKS_TITLE (2.6.9) 1 | WF_POPUPS_JCEMEDIABOX_TITLE (2.6.9) 1 | WF_POPUPS_WINDOW_TITLE (2.6.9) 1 | WF_AGGREGATOR_[youtube]_TITLE (2.6.9) 1 | WF_AGGREGATOR_DAILYMOTION_TITL (2.6.9) 1 | WF_AGGREGATOR_VIMEO_TITLE (2.6.9) 1 | WF_AGGREGATOR_VINE_TITLE (2.6.9) 1 | WF_FILESYSTEM_JOOMLA_TITLE (2.6.9) 1 | WF_STYLESELECT_TITLE (2.6.9) 1 | WF_PRINT_TITLE (2.6.9) 1 | WF_LAYER_TITLE (2.6.9) 1 | WF_MEDIA_TITLE (2.6.9) 1 | WF_IMGMANAGER_TITLE (2.6.9) 1 | WF_FONTSIZESELECT_TITLE (2.6.9) 1 | WF_CHARMAP_TITLE (2.6.9) 1 | WF_PREVIEW_TITLE (2.6.9) 1 | WF_ANCHOR_TITLE (2.6.9) 1 | WF_LINK_TITLE (2.6.9) 1 | WF_CLIPBOARD_TITLE (2.6.9) 1 | WF_FULLSCREEN_TITLE (2.6.9) 1 | WF_NONBREAKING_TITLE (2.6.9) 1 | WF_HR_TITLE (2.6.9) 1 | WF_FONTCOLOR_TITLE (2.6.9) 1 | WF_CONTEXTMENU_TITLE (2.6.9) 1 | WF_TEXTCASE_TITLE (2.6.9) 1 | WF_FONTSELECT_TITLE (2.6.9) 1 | WF_STYLE_TITLE (2.6.9) 1 | WF_BROWSER_TITLE (2.6.9) 1 | WF_INLINEPOPUPS_TITLE (2.6.9) 1 | WF_FORMATSELECT_TITLE (2.6.9) 1 | WF_TABLE_TITLE (2.6.9) 1 | WF_LISTS_TITLE (2.6.9) 1 | WF_ARTICLE_TITLE (2.6.9) 1 | WF_EMOTIONS_TITLE (2.6.9) 1 | WF_SOURCE_TITLE (2.6.9) 1 | WF_VISUALCHARS_TITLE (2.6.9) 1 | WF_CLEANUP_TITLE (2.6.9) 1 | WF_XHTMLXTRAS_TITLE (2.6.9) 1 | WF_SPELLCHECKER_TITLE (2.6.9) 1 | WF_KITCHENSINK_TITLE (2.6.9) 1 | WF_SEARCHREPLACE_TITLE (2.6.9) 1 | WF_VISUALBLOCKS_TITLE (2.6.9) 1 | WF_AUTOSAVE_TITLE (2.6.9) 1 | WF_DIRECTIONALITY_TITLE (2.6.9) 1 | Unknown (-) 1 | com_wrapper (3.0.0) 1 |
Components :: ADMIN :: com_messages (3.0.0) 1 | com_users (3.0.0) 1 | Quick Logout (1.8.0) 1 | com_joomlaupdate (3.6.2) 1 | Unknown (-) 1 | com_regularlabsmanager (7.1.7) 1 | COM_JCE (2.6.9) 1 | com_search (3.0.0) 1 | com_mb2portfolio (2.3.1) 0 | com_admin (3.0.0) 1 | com_associations (3.7.0) 1 | com_cpanel (3.0.0) 1 | JMap (4.3.2) 1 | Akeeba (6.0.0) 1 | com_checkin (3.0.0) 1 | com_banners (3.0.0) 1 | com_templates (3.0.0) 1 | com_phocagallery (4.3.1) 1 | com_advancedmodules (7.1.3) 1 | com_postinstall (3.2.0) 1 | com_weblinks (3.6.0) 1 | com_categories (3.0.0) 1 | com_config (3.0.0) 1 | FLEXIcontent (3.1.1) 1 | com_media (3.0.0) 1 | com_plugins (3.0.0) 1 | com_cache (3.0.0) 1 | com_profiles (1.5.0) 1 | com_content (3.0.0) 1 | com_tags (3.1.0) 1 | com_fields (3.7.0) 1 | com_modules (3.0.0) 1 | com_komento (2.0) 1 | com_finder (3.0.0) 1 | com_redirect (3.0.0) 1 | com_menus (3.0.0) 1 | com_login (3.0.0) 1 | com_languages (3.0.0) 1 | com_contenthistory (3.2.0) 1 | com_installer (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_ajax (3.2.0) 1 |

Modules :: SITE :: mod_finder (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_login (3.0.0) 1 | mod_random_image (3.0.0) 1 | Responsive Contact Form (3.0) 1 | mod_weblinks (3.6.0) 1 | mod_banners (3.0.0) 1 | RSContact (1.1.5) 1 | Mb2 Portfolio (2.3.1) 0 | mod_stats (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_flexicontent (1.3) 1 | EXT Quick Contact Form jQuery (2.2.1) 1 | Slideshow CK (1.4.44) 1 | mod_flexigooglemap (0.9.2) 1 | mod_articles_category (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_feed (3.0.0) 1 | RSSocial! (1.1.1) 1 | JJ Social Slider (2.1.0) 0 | mod_flexiadvsearch (1.0) 1 | mod_j2store_products (3.1) 1 | mod_flexitagscloud (1.1) 1 | mod_breadcrumbs (3.0.0) 1 | Art Universal Lightbox (1.5.3) 1 | mod_tags_popular (3.1.0) 1 | mod_flexicategories (3.0.0) 1 | Komento Comments (1.0.7) 1 | mod_search (3.0.0) 1 | JSitemap module (4.3.2) 1 | mod_flexifilter (1.0) 1 | mod_whosonline (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_custom (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_wrapper (3.0.0) 1 | Komento Activities (1.0.4) 1 | mod_syndicate (3.0.0) 1 | mod_breadcrumbs_adv (3.2) 1 |
Modules :: ADMIN :: mod_stats_admin (3.0.0) 1 | mod_login (3.0.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_submenu (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_status (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_toolbar (3.0.0) 1 | mod_title (3.0.0) 1 | mod_latest (3.0.0) 1 | JSitemap Quickicons (4.3.2) 1 | mod_quickicon (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_cachecleaner (6.0.3) 1 | mod_version (3.0.0) 1 | mod_logged (3.0.0) 1 |

Templates Discovered :: wrote:Templates :: SITE :: it_restaurant3 (1.0.0) 1 | beez3 (3.1.0) 1 | protostar (1.0) 1 |
Templates :: ADMIN :: hathor (3.0.0) 1 | isis (1.0) 1 |

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5501
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Joomla upgrade 3.7 to 3.8 kills website

Post by sozzled » Sat Feb 24, 2018 10:01 pm

@freeloader: You have not attended to the matters I referenced in my previous post

1) The database collation type is latin_swedish_ci (character encoding latin1) which is "wrong" for J! 3.7.4: the standard, from J! 3.5.0 onward, is the collation type to be utf8mb4_unicode_ci (character encoding utf8mb4). I don't know how you created your J! 3.7.4 website but I suspect its life originally began before J! 3.5 and it was updated by not using the Joomla! Update component (that should have fixed this matter).

2) The session path is not writeable (you may need to discuss this with your webhosting provider).

Additionally, there are a couple of "unknown" extensions listed on your FPA. I don't know what they may be but there's not enough information for the FPA reporting tool to identify what they could be.

You have a several extensions that appear to be outdated: e.g. JSitemap v4.3.2, Komento v2.0, Flexicontent v3.1.1, Cache Cleaner v6.0.3, Slideshow CK v1.4.44, J2Store Products module v3.1 and there are probably several others. Some of these [versions] may be incompatible with J! 3.8. I don't know.

You also have the error report level set to "default". You might consider it worthwhile to set it to "maximum". ;)
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”