Update error - full re-install?

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
SadruddinW
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed May 26, 2010 12:10 pm

Update error - full re-install?

Post by SadruddinW » Thu Mar 08, 2018 4:08 pm

Hi. I'm revisiting a 3.4.1 installation.

Should have been a smooth update to 3.6.5 thence to 3.8.5, as far as I can see.
What I've got, though, is errors in the front end, and

"Error 1504 Unknown column 'a-client-id' in 'where clause' when trying to log in to the admin.

So, it seems this is a known error.

Can I install a new copy of 3.8.5 over the top of the old one and hope to retain at least some of the old site?

Thanks in anticipation.
I really like Joomla, but updates are a real pain, and keep catching me out.
This is far from the first time an update has fritzed on me.

mabdelaziz
Joomla! Intern
Joomla! Intern
Posts: 87
Joined: Mon Aug 21, 2006 10:56 am
Location: Alexandria, Egypt
Contact:

Re: Update error - full re-install?

Post by mabdelaziz » Thu Mar 08, 2018 5:11 pm

Hi,
The full re-install will not retain the old site.

Try to run this: http://YOUR-WEBSITE/administrator/index ... tabase.fix

This should fix database issues.
Joomla extensions, tutorials and blogs
https://www.joomreem.com

Custom development is available.
Mohamed Abdelaziz

SadruddinW
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed May 26, 2010 12:10 pm

Re: Update error - full re-install?

Post by SadruddinW » Sat Mar 10, 2018 5:37 pm

OK. Well.
I ran that, then had to roll back a previous version, carefully went through the update, and got the same problem.
So I ran it again, and things seem - just a bit - better.

I'm now getting multiple (well, 4, actually, on consecutive line numbers) of the following:

Warning: Cannot use a scalar value as an array in /home/aswab/667Q0SXV/htdocs/benq/site/libraries/src/HTML/HTMLHelper.php on line 626

I can see the scalar value error - with a fix - elsewhere, but not for this file.

Any ideas? Please?

mabdelaziz
Joomla! Intern
Joomla! Intern
Posts: 87
Joined: Mon Aug 21, 2006 10:56 am
Location: Alexandria, Egypt
Contact:

Re: Update error - full re-install?

Post by mabdelaziz » Sat Mar 10, 2018 5:49 pm

Well, this is a warning, not an error.

So, if nothing else critical in your website, you can disable error reporting in the global configuration, just set it to none, then you will not see this warning again.

Also, you can send a bug report to https://github.com/joomla/joomla-cms/issues/
Joomla extensions, tutorials and blogs
https://www.joomreem.com

Custom development is available.
Mohamed Abdelaziz

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24991
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Update error - full re-install?

Post by Per Yngve Berg » Sat Mar 10, 2018 7:23 pm

Do the upgrade finish? You may have to increase the max_execution_time on the server to at least 120.


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”