Using 3.4.8, do I "need" to upgrade to latest version?

Need help upgrading your Joomla! website or converting to Joomla! 3.x? Please consider the availability of third-party templates and extensions when deciding which Joomla version to use.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
mack2000
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jul 10, 2018 7:04 pm

Using 3.4.8, do I "need" to upgrade to latest version?

Post by mack2000 » Tue Jul 10, 2018 7:21 pm

We are using version 3.4.8 and I am since a few days the new administrator...
I used to update the text on the site.

I was wandering if there is a need to upgrade to the latest version?
What is the need to do this?
What are the do's and don't's?
Is there an article that helps me upgrading and where to find this?
I also read a few issues with the latest version and I am not a well trained administrator...

Rgds and thanks
Last edited by toivo on Wed Jul 11, 2018 11:00 am, edited 1 time in total.
Reason: mod note: marked as solved on request

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5871
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Using 3.4.8, do I "need" to upgrade to latest version?

Post by sozzled » Tue Jul 10, 2018 8:54 pm

Yes, you should update to the latest version of Joomla (currently J! 3.8.10), because:

a) J! 3.4.8 is three years old (it was released in December 2018);
b) there have been several security updates included in the 26 releases of Joomla in the last 3 years;
c) there have been library changes, database changes, new features added since your website was built;
d) a number of extensions have been updated that utilise the changes made to J! 3.x;
e) keeping your website up-to-date will mean that you will have better support opportunities using this forum; and
f) keeping your website up-to-date will mean that you will be better prepared for the improvements that will be coming in J! 4.

Lastly, it is a fact that websites that are not properly maintained—when the software is allowed to fall further behind the current supported release—will eventually become vulnerable to failure (or attack). It's your choice, of course, and it depends on whether you are prepared to take the risk that your website will become unusable because you allowed it to remain unmaintained.

If you haven't already done so, you should make sure that your site is properly backed-up and recoverable from a reliable backup in the event of failure. J! 3.8.10 is safe, secure and reliable. I hope this helps.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3959
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Using 3.4.8, do I "need" to upgrade to latest version?

Post by AMurray » Tue Jul 10, 2018 9:59 pm

More to the 4.0 version coming (at this stage the stable release is likely by the end of 2018), it will use PHP 7, so you need to be sure your host supports that version. In fact, versions less than 3.5 (like your 3.4.8) won't run on PHP 7; therefore, from that perspective you should update, as well as for all the reasons @sozzled has outlined.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

mack2000
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jul 10, 2018 7:04 pm

Re: Using 3.4.8, do I "need" to upgrade to latest version?

Post by mack2000 » Wed Jul 11, 2018 9:33 am

Thanks for the answers. Clear.
Is it possible to upgrade straight to the latest version, or do I need upgrade from version to version?

Rgds

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5871
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Using 3.4.8, do I "need" to upgrade to latest version?

Post by sozzled » Wed Jul 11, 2018 9:44 am

If you go to Components » Joomla! Update in the backend of your website, you will be instructed what to do next.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

mack2000
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Jul 10, 2018 7:04 pm

Re: Using 3.4.8, do I "need" to upgrade to latest version?

Post by mack2000 » Wed Jul 11, 2018 10:05 am

Works.. Great.
Thks for the help / advise

rgds


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”