Website not working after migration from 2.5.28 to 3.5.1

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Domainator
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Apr 23, 2012 10:17 pm

Website not working after migration from 2.5.28 to 3.5.1

Post by Domainator » Fri Dec 21, 2018 11:34 pm

Hi,

I got the error:

Notice: Undefined property: LoginController::$input in /WEBSITE/FOLDER/administrator/components/com_login/controller.php on line 36

Fatal error: Call to a member function set() on a non-object in /WEBSITE/FOLDER/administrator/components/com_login/controller.php on line 36


I tried to migrate a website from 2.5.28 to 3.5.1 regarding to this document: https://docs.joomla.org/Joomla_2.5_to_3 ... gration/de

The old website was hacked, I had some wrong users inside and the unsafe mailer component sent mails to the Admin-Account.

I completed all steps in this document - except the point "deactivate Plugin "System - rember me"" because that was forbidden to do.
In front of migration I've updates the components Akeeba Backup and XMAP to the last working Version, cleaned the cache and all worked fine.

After click on "installation to 3.5.1" the installation runs - and ended with an error:

1062 - Es ist ein Fehler aufgetreten

Duplicate entry '1' for key 'PRIMARY' SQL=INSERT INTO `#__content_types` (`type_id`, `type_title`, `type_alias`, `table`, `rules`, `field_mappings`,`router`) VALUES (1, 'Article', 'com_content.article', '{"special":{"dbtable":"#__content","key":"id","type":"Content","prefix":"JTable","config":"array()"},"common":{"dbtable":"#__core_content","key":"ucm_id","type":"Corecontent","prefix":"JTable","config":"array()"}}', '', '{"common":[{"core_content_item_id":"id","core_title":"title","core_state":"state","core_alias":"alias","core_created_time":"created","core_modified_time":"modified","core_body":"introtext", "core_hits":"hits","core_publish_up":"publish_up","core_publish_down":"publish_down","core_access":"access", "core_params":"attribs", "core_featured":"featured", "core_metadata":"metadata", "core_language":"language", "core_images":"images", "core_urls":"urls", "core_version":"version", "core_ordering":"ordering", "core_metakey":"metakey", "core_metadesc":"metadesc", "core_catid":"catid", "core_xreference":"xreference", "asset_id":"asset_id"}], "special": [{"fulltext":"fulltext"}]}','ContentHelperRoute::getArticleRoute'), (2, 'Contact', 'com_contact.contact', '{"special":{"dbtable":"#__contact_details","key":"id","type":"Contact","prefix":"ContactTable","config":"array()"},"common":

and some other lines.

Can anybody help me? Does anybody have an idea how to fix this problem?

Thank you very much!

Domainator
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Apr 23, 2012 10:17 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Domainator » Sat Dec 22, 2018 12:06 am

One additional information. But I'm not sure whether this is the error or not.
I used the template "Vanenborg 1.5" and there isn't an update for 3.x.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19529
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by leolam » Sat Dec 22, 2018 8:55 am

You have not read my guide viewtopic.php?f=710&t=793171 (which is an extract from the docs-article which I co-wrote) You need to roll back to your backup, than remove all extensions that are not compatible before doing the upgrade. Xmap is a dead product with no more support or upgrades so remove and replace after the upgrade with OSMap.

It is not forbidden to deactivate the Remember-me plugin

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

Domainator
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Apr 23, 2012 10:17 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Domainator » Sat Jan 12, 2019 8:14 pm

Hi Leolam,
thanks for your answer.
No, I havn't read YOUR guide. But another valid guide of THIS site which came from the Joomla documentation. Is this invalid or canceled? Do you have more than one guide for migration in Joomla? Other point: There are no other special things, that I can read in your guide.

For XMAP there is a running version for Joomla 3 from Guillermo Vargas, v.2.3.4.: https://www.joomlainfo.ch/themen/erweit ... rschwindet
Have testet this after update and got no errors.

But I tried it a second time with your hints. Have deleted XMAP.

Why you say, it isn't forbidden to deactivate the "remeber-me" plugin?

Image

This will not work in my installation.

And last point: I got the same error. It's not a fault of XMAP.

Migration doesn't work.

Any other ideas?

Thanks

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19529
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by leolam » Sun Jan 13, 2019 9:51 am

Check your template directory against the install. This will occur if params.ini is missing. You will need to reload the params.ini to your Joomla 2.5 template folder

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37022
Joined: Sat Apr 05, 2008 9:58 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Webdongle » Sun Jan 13, 2019 12:40 pm

Some 3rd party extensions that are 2.5/3.x compatible install different files depending on the version of Joomla they are being installed into.

Best done on localhost:
1. (after uninstalling incompatible extensions and disabling the 'Remember me' plugin) Install a fresh 2.5.28 and edit the configuration.php to connect to the original database. This allows for the database to be updated without 3rd party files interfering with the process.
2. (after updating the database to the latest version) Install the latest Joomla then download the latest versions of your 3rd party extensions and install them.
3. Edit the configuration.php (of the latest install) to connect to the original database. You now have fresh Joomla (and 3rd party) files connected to your updated database.

The above method has the added advantage that it will clean a hacked site.
viewtopic.php?f=710&t=956702

If that method fails at step #1 then chances are that you originally installed Joomla using a 3rd party Template/quick install.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

Domainator
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Apr 23, 2012 10:17 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Domainator » Sun Jan 13, 2019 3:20 pm

Thanks, Leolam.
I've downloaded the original Joomla 2.5.28 install files from https://downloads.joomla.org/de/cms/joomla25/2-5-28.
But there isn't a params.ini inside.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19529
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by leolam » Sun Jan 13, 2019 3:28 pm

What template are you using on your site?

Leo
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

Domainator
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Apr 23, 2012 10:17 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Domainator » Sun Jan 13, 2019 5:38 pm

I think this is equal. I didn't found the file "params.ini" wheter in the Joomla standard installation files, nor in all different templates I've downloaded for tests nor in in the Vanguard-Template.
Last edited by Domainator on Sun Jan 13, 2019 5:43 pm, edited 1 time in total.

Domainator
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Apr 23, 2012 10:17 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Domainator » Sun Jan 13, 2019 5:43 pm

Hi Webdongle, hi Leolam,

I think there is a big bucket of [ redacted ] in the migration of 2.5.28 to 3.5.x.
I tried it according to this method (for a hacked site): viewtopic.php?f=710&t=956702
- made a new installation of J2.5.28 in a new database
- changed the configuration.php to make the fresh site to use the existing database
- made the update regarding to this https://docs.joomla.org/Joomla_2.5_to_3 ... gration/de

And got the same error: 1062

I'm really tired of this.
Last edited by toivo on Sun Jan 13, 2019 6:22 pm, edited 1 time in total.
Reason: mod note: coarse language redacted, please observe the forum rules at https://forum.joomla.org/viewtopic.php?f=8&t=65

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37022
Joined: Sat Apr 05, 2008 9:58 pm

Re: Website not working after migration from 2.5.28 to 3.5.1

Post by Webdongle » Sun Jan 13, 2019 7:00 pm

If you get an error when trying to update the original database with fresh Joomla files then there is a problem with your database. You di try it on the original database not the database after your first fail? In otherwords you deleted the site and replaced it with your backup before trying again ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”