Ugrade 3.6.5 to the latest version 3.9.11

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
valkis
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Sep 20, 2019 7:12 am

Ugrade 3.6.5 to the latest version 3.9.11

Post by valkis » Fri Sep 20, 2019 10:39 am

Hello,
Ugrade the Joomla 3.6.5 to the latest version 3.9.11
I got a backup and started, but the installation wrote the attached error message.
image.png
The site is crashing. Restore the backup.
Is there a solution for this problem?
You do not have the required permissions to view the files attached to this post.

User avatar
bruno28
Joomla! Explorer
Joomla! Explorer
Posts: 267
Joined: Wed May 16, 2012 5:41 am
Location: Chartres, France
Contact:

Re: Ugrade 3.6.5 to the latest version 3.9.11

Post by bruno28 » Fri Sep 20, 2019 2:29 pm

Hello valkis

Have you tried to fix the database

database.png
You do not have the required permissions to view the files attached to this post.
Cordialement, Bruno28 :)
Joomla! 3.9.12 - php 7.3
https://www.bp2i.fr/ - https://www.moneglisesurle.net/

valkis
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Sep 20, 2019 7:12 am

Re: Ugrade 3.6.5 to the latest version 3.9.11

Post by valkis » Mon Sep 23, 2019 6:33 am

Hello Bruno28, thanks for the answer

Yes, and the problem remains the same, the page crashes

User avatar
pmleconte
Joomla! Explorer
Joomla! Explorer
Posts: 409
Joined: Fri Mar 17, 2017 12:55 pm
Location: France

Re: Ugrade 3.6.5 to the latest version 3.9.11

Post by pmleconte » Mon Sep 23, 2019 6:56 am

Hi,

It's just a warning, which means that you are trying to apply a sql patch file that does not need to be done.

On your screen, you have a message telling you that you are using Joomla 3.9.11. So, it seems to be ok.

Is there other errors/warning elsewhere ?

Pascal
If anything can go wrong, it will.
https://www.conseilgouz.com/en

valkis
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Sep 20, 2019 7:12 am

Re: Ugrade 3.6.5 to the latest version 3.9.11

Post by valkis » Mon Sep 23, 2019 7:08 am

Hello Pascal
After upgrading, the front end crash. So I returned the backup in Joomla ver 3.6.5.
Now it works but I can't get in Clobal Configuration menu
the message appears
"Database Settings
Database Type

Fatal error: Class JDatabaseDriverPgsql contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (JDatabaseDriver::getVersion) in /home4/gsf650s/public_html/avmtzn/libraries/joomla/database/driver/pgsql.php on line 19
"

User avatar
Aris Ntatsis
Joomla! Guru
Joomla! Guru
Posts: 820
Joined: Thu Aug 18, 2005 11:18 pm
Location: Athens - Greece
Contact:

Re: Ugrade 3.6.5 to the latest version 3.9.11

Post by Aris Ntatsis » Mon Sep 23, 2019 8:45 am

valkis wrote:
Mon Sep 23, 2019 7:08 am
Hello Pascal
After upgrading, the front end crash. So I returned the backup in Joomla ver 3.6.5.
Now it works but I can't get in Clobal Configuration menu
the message appears
"Database Settings
Database Type

Fatal error: Class JDatabaseDriverPgsql contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (JDatabaseDriver::getVersion) in /home4/gsf650s/public_html/avmtzn/libraries/joomla/database/driver/pgsql.php on line 19
"
Hi @valkis.

Have you checked before the backup you restored?
Joomla Volunteer & Certified Joomla Administrator: https://volunteers.joomla.org/joomlers/ ... is-ntatsis
Υποστήριξη και Υπηρεσίες Joomla από το https://www.onscreen.gr

valkis
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Sep 20, 2019 7:12 am

Re: Ugrade 3.6.5 to the latest version 3.9.11

Post by valkis » Mon Sep 23, 2019 9:08 am

Yes yes it is right


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”