HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
davevdw
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Feb 11, 2013 11:56 pm

HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by davevdw » Sun Jan 12, 2020 8:19 pm

I run a website using Joomla 2.5.28 - PHP 5.6.40-0+deb8u8 and need to update to Joomla 3.9.x - PHP 7.0

1: Joomla 2.5 does not run on PHP 7, Joomla 3.x does not run on PHP 5.6.....

In which order do I need to update (Joomla or PHP first?) ???


2: Updating Joomla using the Joomla! Update component does not work. (update process takes forever, no update being processed).

Is there a way to manual upgrade the site by uploading the new files? (I tried to upload the .zip file into the /tmp dir but that does not work. :'(

Any help will be highly appreciated!

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 8468
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by sozzled » Sun Jan 12, 2020 8:32 pm

davevdw wrote:
Sun Jan 12, 2020 8:19 pm
Joomla 2.5 does not run on PHP 7.x
True (see Requirements for J! 2.5).

davevdw wrote:
Sun Jan 12, 2020 8:19 pm
... Joomla 3.x does not run on PHP 5.6 ...
Not true (see Requirements for J! 3.x).

davevdw wrote:
Sun Jan 12, 2020 8:19 pm
Updating Joomla using the Joomla! Update component does not work. (update process takes forever, no update being processed).
That's a different question. See viewtopic.php?f=710&t=793171 for help.

Supplementary information: PHP 7.0 is not "LTS"; this version of PHP is no longer supported. See https://www.php.net/supported-versions.php for more information about supported versions of PHP.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

davevdw
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Feb 11, 2013 11:56 pm

Re: HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by davevdw » Sun Jan 12, 2020 8:55 pm

Thank you for the quick reply, I will check post viewtopic.php?f=710&t=793171 right now

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37798
Joined: Sat Apr 05, 2008 9:58 pm

Re: HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by Webdongle » Sun Jan 12, 2020 11:02 pm

Best done on wamp localhost as you can change php version on the fly.

An alternative update method viewtopic.php?t=972061#p3569762
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19907
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by leolam » Wed Jan 15, 2020 10:23 am

Webdongle wrote:
Sun Jan 12, 2020 11:02 pm
Best done on wamp localhost as you can change php version on the fly.
Every descent host offers these days multiple PHP (one click). It is not an argument for doing it on a local box. The only good reason to do this on a local box or on an other account etc is that you do not ruin your live site

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37798
Joined: Sat Apr 05, 2008 9:58 pm

Re: HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by Webdongle » Wed Jan 15, 2020 10:45 am

If you do it on remote Host then you have to switch windows/tabs but with wamp you just click a windows tray icon.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19907
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: HELP NEEDED: Joomla 2.5.28, PHP 5.6.40 -> Joomla 3.9.x, PHP 7.0 LTS

Post by leolam » Thu Jan 16, 2020 3:11 am

Webdongle wrote:
Wed Jan 15, 2020 10:45 am
If you do it on remote Host then you have to switch windows/tabs but with wamp you just click a windows tray icon.
Convenient store and not an argument...who cares

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”