Invalid Login trying to update from 3.9.25 to 3.9.26

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
zorroson
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Thu Sep 07, 2006 6:19 pm

Invalid Login trying to update from 3.9.25 to 3.9.26

Post by zorroson » Fri Apr 16, 2021 12:34 pm

Hi,

I have a strange problem, with the update from 3.9.25 to 3.9.26 on all sites, on my Plesk based server.

When using the built-in com_joomlaupdate to perform the update, I get a popup saying "Invalid Login" as soon as I click the "Install update" button. On the server, I can see that the updatefile is actually being downloaded to the tmp dir, but then nothing else happens.

I have searched high and low, and only thing I could find related to this issue, is when the FTP layer is enabled, but I do not use this on any of my sites.

I have apprx. 30 sites on the same Plesk install, and have the issue on all installs, and therefore have an idea that this might be a server/plesk/rights related problem.

Also the issue happens with sites both on PHP 7.2, 7.3.x and 7.4.x using both fastcgi and fpm.

Nothing in Apache access or error.log.
Joomla update log reports no errors, as seen below:

Code: Select all

2021-04-16T10:16:58+00:00	INFO 152.x.x.x	update	Update started by user Super User (123). Old version is 3.9.25.
2021-04-16T10:17:00+00:00	INFO 152.x.x.x	update	Downloading update file from https://s3-us-west-2.amazonaws.com/joomla-official-downloads/joomladownloads/joomla3/Joomla_3.9.26-Stable-Update_Package.zip?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIA6LXDJLNUINX2AVMH%2F20210416%2Fus-west-2%2Fs3%2Faws4_request&X-Amz-Date=20210416T101658Z&X-Amz-Expires=60&X-Amz-SignedHeaders=host&X-Amz-Signature=f5f113813cf1f255b1ff561419786a3aa1915bb43e25e5498a0ff298cf989635.
2021-04-16T10:19:45+00:00	INFO 152.x.x.x	update	File Joomla_3.9.26-Stable-Update_Package.zip downloaded.
2021-04-16T10:20:23+00:00	INFO 152.x.x.x	update	Update started by user Super User (123). Old version is 3.9.25.
2021-04-16T10:20:25+00:00	INFO 152.x.x.x	update	File Joomla_3.9.26-Stable-Update_Package.zip downloaded.
2021-04-16T10:20:26+00:00	INFO 152.x.x.x	update	Starting installation of new version.
But the funny thing is, if I use the mysite.guru platform to update the sites, it works without a glitch! Maybe I have misunderstood this, but it was my understanding that when doing the updates from these remote services, they actually just shout over the commands from the service to the destination server, which then initiates the updates using the same code, as if I did the update from the local server?

Does anyone have an idea as to where to search for solution on this?

I have raised a support ticket at Plesk support, which I am waiting for a response from - but thought maybe someone else have seen this?

Cheers
Henrik Holm Nielsen
Last edited by toivo on Fri Apr 16, 2021 1:01 pm, edited 1 time in total.
Reason: mod note: moved from 3.x General Questions

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6675
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Invalid Login trying to update from 3.9.25 to 3.9.26

Post by AMurray » Fri Apr 16, 2021 10:28 pm

This may be due to having the FTP layer enabled - it is not usually necessary. Disable it under the global configuration. This topic discusses the same or similar issue: viewtopic.php?t=965448
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”