Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
wood1e1
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jun 01, 2021 8:22 am

Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by wood1e1 » Wed Jun 16, 2021 5:25 pm

hi

I worked through the steps on this page: https://docs.joomla.org/Joomla_2.5_to_3 ... _Migration

There was an Joomla_3.5.1-Stable-Update_Package here: https://www.screencast.com/t/wGwdsqvT

But when i click to update, it just never updated, download or installed.. I waited an hour. So gave up.

I then went for a manual update, using the Joomla_3.5.1-Stable-Update_Package.zip

but now I have on front end this error: ECHO jest w��czone. see here: https://www.screencast.com/t/4pKluVCDieYE

And on backend: https://www.screencast.com/t/bCmggYXG with no option to login

Not sure what this means, apart from an update failure!! :).

What would be the next best step?

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6883
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by AMurray » Wed Jun 16, 2021 10:31 pm

I can't see anything in that Migration Guide that mentions you have to do the update manually through FTP. IN fact, if you have only uploaded the new files, then that's half the job and it won't have done the database updates. You could try using the script found here: https://gist.github.com/mbabker/d7bfb4e ... 3607f89281 which should process the database changes required.

Next step - restore from a backup and start over. Try this migration guide: viewtopic.php?f=710&t=793171 (it may cover issues and actions required the other does not).
Regards - A Murray

wood1e1
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jun 01, 2021 8:22 am

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by wood1e1 » Fri Jun 18, 2021 5:29 pm

Yep tried the FTP update process.

You mention the database updates, do you mean these: https://www.screencast.com/t/xYLIwzk0 ?

Because those I did, and the database was updated... was there some other database updates I have missed? is this: https://gist.github.com/mbabker/d7bfb4e ... 3607f89281 on top of what I have already updated?

I did try manual on another site, but that didn't work.. although I have got different errors: https://www.screencast.com/t/ghr76lPKiJxM

Not sure what 'whoopss something went wrong!' means :)

I will reinstall and try again... I will try your suggest update process

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10418
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by sozzled » Fri Jun 18, 2021 5:32 pm

There is no [supported] "FTP update process". Where did you read that?

There is no "manual" update process either. Where did you read that?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)
Testing J! 3.10: https://sintranet.enduring.com.au

wood1e1
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jun 01, 2021 8:22 am

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by wood1e1 » Fri Jun 18, 2021 5:43 pm

oh just made some progress on another site... updated everything, but the site only works on PHP 5.6!! Which defeats the object :)

https://www.screencast.com/t/7txuMYlSH6W as soon as i up the Php version, the front end stops working.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10418
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by sozzled » Fri Jun 18, 2021 5:44 pm

"It" only works in PHP 5.6? What is "it"? Can you please be more specific?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)
Testing J! 3.10: https://sintranet.enduring.com.au

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10418
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by sozzled » Fri Jun 18, 2021 6:19 pm

I am not trying to be difficult; I am just trying to understand the context of your question.

I understand that you have "made some progress on another site"—a Joomla website, of course, I assume—but that other website only works with PHP 5.6.

Can you tell us something more about the other website, please? For example, which version of J! does the other site "only work with PHP 5.6"? If we had a better understanding of the context we would be able to help.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)
Testing J! 3.10: https://sintranet.enduring.com.au

wood1e1
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jun 01, 2021 8:22 am

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by wood1e1 » Sat Jun 19, 2021 5:46 am

I have been trying to update from v2.5 to v3.5 on a number of sites.

Following the 'process' to update.

1) SITE 1 - on the front end I get this error 'Something went wrong... sorry. Please press back in your browser' See here: https://www.screencast.com/t/KIOWGo3axXh

On the back end admin error is: '0 - An error has occurred.Call to a member function set() on null Return to Control Panel' see here: https://www.screencast.com/t/q3BSrxJk

2) Site 2 - On front end I get this error: ECHO jest w��czone. see here: https://www.screencast.com/t/FtdGojoVi

On backend admin I get the same as back end on site 1, see here: https://www.screencast.com/t/6sWCi1npx

3) Site 3 - the front end 'works' albeit with some random 'print/Email' text and on the homepage missing sliders, see here: https://www.screencast.com/t/TohsccEl2pO2 and only on PHP 5.6! - which defeats the purpose of updating, being able to migrate to PHP 7.3/7.4! :)

one back end admin it works fine!

so I am just wondering what I might have done differently on site 3 to make it an almost successful migration! And then can I replicate that on the other two sites!?

Maybe from the errors on site 1 and 2 it can been seen that I have made an error in the update process.

or is it that the themes being used are just not compatible and therefore I cannot ever update successfully update to v3

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10418
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by sozzled » Sat Jun 19, 2021 6:19 am

Unfortunately I can't help you because I don't know what version of J! you're trying to run with PHP 7+.

The error message "ECHO jest w��czone" looks like the website was infected.

There is a process to migrate from J! 2.5 to J! 3.x; the process involves several stages and takes a while. The migration needs to be planned. The actual physical steps don't take long (maybe an hour or so, if you know what you're doing) but the process must be done methodically. It usually takes me about two full days, working non-stop, to plan and execute the migration and tidy everything up afterwards.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)
Testing J! 3.10: https://sintranet.enduring.com.au

moniquecantalz4
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Dec 05, 2020 10:22 pm

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by moniquecantalz4 » Sat Jun 19, 2021 4:24 pm

Thank's you

wood1e1
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Tue Jun 01, 2021 8:22 am

Re: Manual update via FTP from 2.5 to 3.5.1 error on front end: ECHO jest w��czone.

Post by wood1e1 » Sun Jun 20, 2021 1:18 pm

I have decided that the theme can't be updated, as following the 'precise process' several times now, there is a failure on update with one error or another.

But for the record I was trying to update from v2.5 to 3.9 or whatever version allowed PHP 7.3 or 7.4.

Anyway, thanks for the pointers. All the best :)


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”