Upgrading to 3.10.3

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
4thdesign1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 14, 2016 7:53 am

Upgrading to 3.10.3

Post by 4thdesign1 » Tue Oct 26, 2021 4:29 pm

I have a couple of questions:

1. When I attempt to upgrade from 3.10.2 to the 3.10.3 version, my admin page just goes blank. No update has occured, the page just goes blank. Just to confirm, its a website that has no 3rd party extensions, its just a basic site.
Why does it do this?

2. Why are we still getting updates when Joomla 4 is out? And just to add, Joomla 4 for me is flaky and installing this on another of my sites gave me heartache, but managed to do it after 2 days and then failed to update on the latest version. I give up with Joomla 4. In my opinion, its nowhere near ready to be released.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11245
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Upgrading to 3.10.3

Post by sozzled » Tue Oct 26, 2021 7:31 pm

Interesting comments. I haven't, yet, attempted to update any of my J! 3.10.2 websites yet ... even a "vanilla flavoured" one but, from what I've read, other people have been successful. This probably says more about your webhosting environment than it says about the reliability of the update process.

I have nothing to say about "why" J! 3.x releases continue to emerge: read the release notes; the release notes explain the reasons. That's what I do.

I understand your frustration with J! 4 but I disagree with the comment that it's nowhere-near ready for release. I mean, look at the history. The project started in 2016 and you can't seriously expect us to agree that, after five years, it's nowhere-near ready, can you? I agree that J! 4 is arguably not necessarily the best product on the market but a lot of people seem like it; certainly a lot of people are praising it if you have been following the articles written on the internet over the past five to six years. I will agree with someone who says that J4 is quite different to J! 3 and they're having problems accommodating themselves to the new product. I have problems with J! 4 but not because J! 4 is inherently problematic: J! 4 is different.

As far as your "blank screen" issue is concerned, do you want to fix it? "Blank screens" are usually an indication of an error: enable J! debug mode to find the source of the error and then let's see what has caused the problem. OK? ;)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 40489
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading to 3.10.3

Post by Webdongle » Tue Oct 26, 2021 8:32 pm

Custom Template or 3rd party extension.
How did you install Joomla in the first place?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

4thdesign1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 14, 2016 7:53 am

Re: Upgrading to 3.10.3

Post by 4thdesign1 » Tue Oct 26, 2021 8:35 pm

Yes i am using yootheme, its currently out of date by 2 versions, but it works.

Is there a way you can bypass these extensions and still continue to install Joomla 3.10.3
Never had a problem before, so why now??

4thdesign1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 14, 2016 7:53 am

Re: Upgrading to 3.10.3

Post by 4thdesign1 » Tue Oct 26, 2021 8:37 pm

This is the error i get

This page isn’t working is currently unable to handle this request.
HTTP ERROR 500

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11245
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Upgrading to 3.10.3

Post by sozzled » Tue Oct 26, 2021 8:44 pm

As I suspected (and as I wrote before), your webhosting environment has an issue that causes an unspecified HTTP 500 Internal Server Error. There are is no one-size-fits-all solution for the HTTP 500 Internal Server Error because there are literally millions of possible reasons why this error is generated. Please see General help: HTTP 500 Internal Server Errors which, as its title implies, is a very general guide to how to go about analysing of the likely cause of the problem.

In short: Image
Last edited by sozzled on Tue Oct 26, 2021 8:58 pm, edited 1 time in total.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

4thdesign1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 14, 2016 7:53 am

Re: Upgrading to 3.10.3

Post by 4thdesign1 » Tue Oct 26, 2021 8:54 pm

Thanks, but its not my hosting. I have my own server in a datacentre for hosting and its a managed service. Hosting is working correctly.

All my domains are on php8 as I was hoping to upgrade all my domains to Joomla 4. I have only managed it on one of my domains, but now unable to upgrade to the latest version of Joomla4, and to be honest, I give up at the moment with joomla 4, hence why i am sounding very despondent as its never happened with any of the previous joomla versions. And now..... I cant upgrade joomla 3 to the latest version on 2 of my other domains..... yes it sounds like a hosting issue, but i know its not!!!

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 12336
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upgrading to 3.10.3

Post by brian » Tue Oct 26, 2021 8:56 pm

4thdesign1 wrote:
Tue Oct 26, 2021 8:35 pm
Yes i am using yootheme, its currently out of date by 2 versions, but it works.
Obviously not
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11245
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Upgrading to 3.10.3

Post by sozzled » Tue Oct 26, 2021 8:57 pm

Did you read General help: HTTP 500 Internal Server Errors?

4thdesign1 wrote:
Tue Oct 26, 2021 4:29 pm
Just to confirm, its a website that has no 3rd party extensions, its just a basic site.
... except that you're using a third-party template ... >:( unngghh!

Who knows if this third-party template is compatible with PHP 8 (if that's the cause of the error)? Have you checked with the template's author?
Last edited by sozzled on Tue Oct 26, 2021 9:01 pm, edited 1 time in total.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

4thdesign1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 14, 2016 7:53 am

Re: Upgrading to 3.10.3

Post by 4thdesign1 » Tue Oct 26, 2021 9:01 pm

[ redacted ]

As you know... theres nothing wrong with other templates. [ redacted ]

Yes the template is compatible with joomla 4
Last edited by toivo on Tue Oct 26, 2021 11:29 pm, edited 2 times in total.
Reason: mod note: unnecessary commentary removed

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11245
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Upgrading to 3.10.3

Post by sozzled » Tue Oct 26, 2021 9:03 pm

Right! At this point I am reporting this topic to the forum moderators. We don't need this kind of abuse from anyone. We've tried to assist but, evidently, you would be better off taking your litany of complaints to another quadrant of the internet where you may find companionship.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 12336
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upgrading to 3.10.3

Post by brian » Tue Oct 26, 2021 9:08 pm

A template is an extension.

No software is perfect but without a bug report it will never get fixed.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 12336
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Upgrading to 3.10.3

Post by brian » Tue Oct 26, 2021 9:09 pm

"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11245
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Upgrading to 3.10.3

Post by sozzled » Tue Oct 26, 2021 9:16 pm

Are my ears red or what, Brian? :laugh: I hereby withdraw my offer to listen to the OP's complaints. *ouch*
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”