upgrading from 2.5.14 to 3.1.5: just will not work

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Locked
User avatar
onderzoekspraktijk
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Dec 25, 2005 2:01 pm
Location: Rotterdam
Contact:

upgrading from 2.5.14 to 3.1.5: just will not work

Post by onderzoekspraktijk » Sat Aug 31, 2013 5:33 pm

I have tried 5 times to install 3.1.5 on top of a 2.5.14 site: it just won't work!

I deleted all component and plugins and modules that are not core: it won't install.

I changed out-of-the-box templates: it just won't work.

Hours later: this is what I keep getting: ....administrator/index.php?option=com_joomlaupdate&task=update.finalise,
and an blank screen, a white screen of joomla death.

Error-reporting was/is on: nothing, empty space that's it.
Changed inside the configuration file, and got this:
Fatal error: Call to undefined method RuntimeException::get() in /.(date deleted)../..(data deleted)./public_html/voorbeeld2/libraries/joomla/error/error.php on line 797

No idea what it all means.

Very frustrating.

Site is running in a Rochen account: never had this before.

Well: I will wait another year or so before trying again.

Greetings,
Paul

Markstein
Joomla! Hero
Joomla! Hero
Posts: 2268
Joined: Sat Feb 09, 2008 8:27 am
Location: California, USA

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by Markstein » Sat Aug 31, 2013 6:38 pm

Perhaps the following post will help you:

http://forum.joomla.org/viewtopic.php?f=710&p=2999769

Mark

User avatar
onderzoekspraktijk
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Dec 25, 2005 2:01 pm
Location: Rotterdam
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by onderzoekspraktijk » Tue Sep 03, 2013 3:44 pm

Tried 6th and 7th time. Took real care to delete anything and everything not-core. I think I went a bit further to the finishing line: 82,4% complete. Still it did die while performing the task update.finalise.
White screens back and front.

Pity.

axcelia
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Nov 03, 2010 10:40 am

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by axcelia » Fri Sep 20, 2013 9:51 am

I have the exact same problem.
I have followed all the instructions in the linked post and I still get a blank page when I upgrade from 2.5.14 to 3.1.5 (I even removed all extensions that weren't core).

axcelia
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Nov 03, 2010 10:40 am

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by axcelia » Fri Sep 20, 2013 10:35 am

A Little more info now as I've tried this for the 7th time.
All non core extensions removed.
Upgrade gets to 82.4% then redirects to index.php?option=com_joomlaupdate&task=update.finalise
When that loads I get the error message:

Fatal error: Call to undefined method RuntimeException::get() in /home/sites/######.co.uk/public_html/jupgrade25b/libraries/joomla/error/error.php on line 797

Any ideas what is causing this?

axcelia
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Wed Nov 03, 2010 10:40 am

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by axcelia » Fri Sep 20, 2013 11:03 am

Ok I managed to get this working (hallelujah)

This Thread -> http://forum.joomla.org/viewtopic.php?f=710&t=812445
And this post \/ helped me
rbuelund wrote:The sites mentioned here, have they been migrated from J!1.5 earlier on ?
I have discovered that if you have an element in your #__menu table with the id=23 - then the update to 3.1.5 from 2.5.14 will fail - I removed the element and it worked perfectly. Also be shure that if you try an update again from 2.5.14 - none of the new 3.x tables must be left behind in the db - otherwise the update will fail again - so you have to delete these tables:

_contentitem_tag_map
_content_types
_ucm_base
_ucm_content

before you try a new update from 2.5.14

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20268
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by leolam » Mon Sep 23, 2013 3:50 am

You all have these errors because you have not removed all non-core elements/extensions. That is the only case with this message. Even a single small plugin you forget will cause this!

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

User avatar
onderzoekspraktijk
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Dec 25, 2005 2:01 pm
Location: Rotterdam
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by onderzoekspraktijk » Mon Sep 23, 2013 2:26 pm

axcelia wrote:Ok I managed to get this working (hallelujah)

This Thread -> http://forum.joomla.org/viewtopic.php?f=710&t=812445
And this post \/ helped me
Thanks for the link.

Almost at the bottom I found what helped me:
bennieblanco wrote: 1. Install manual Joomla 2.5.x to Joomla 3.0.1 pack as a Joomla extension
2. Go to Extensions -> Extensions Manager -> Database and click on Fix button
3. Go to Extensions -> Extensions Manager -> Discover and install discovered extensions
4. Upgrade from Joomla 3.0.1 to Joomla 3.1.5

but it bugs me because it makes no sense

If any extensions used were not compatible , than I would get errors from 2.5.14 to 3.0.1.
What I did notice is that the update fails at exactly 82.4% and I think it has something to do with tags component.

I also noticed an odd short page refresh on 82.4% right before the update fails.
I did as suggested (googled for the old update) and after lots of clicking the admin template also awoke, and that was that: it now works.

Thanks.
Paul

User avatar
dlm
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Wed Mar 26, 2008 7:56 pm
Location: Bozeman, Montana
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by dlm » Sat Oct 05, 2013 4:23 pm

This is turning into a nightmare! I've uninstalled all the components/modules/plugins that are not 3.0 compatible. All of my 3.0 compatible extensions are upgraded to the latest version. I've manually uninstalled the components that the "manager" can't dump. I've got something called "Smart Search" which I don't recall installing. If I uninstall that, it uninstalls a table called "finder_filters" and that the upgrade wants to do something with it. I deleted id=23 from #_menu (saw an error message about that on one of the attempts). I also deleted the _content_item_tag_map, _content_types, _ucm_base and ucm_content from the database.

I'm on attempt #6 or #7.

My latest attempt produced the following error message -

Code: Select all

Duplicate entry '1' for key 'PRIMARY' SQL=-- -- Dumping data for table `j25n_tags` -- INSERT INTO `j25n_tags` (`id`, `parent_id`, `lft`, `rgt`, `level`, `path`, `title`, `alias`, `note`, `description`, `published`, `checked_out`, `checked_out_time`, `access`, `params`, `metadesc`, `metakey`, `metadata`, `created_user_id`, `created_time`,`created_by_alias`, `modified_user_id`, `modified_time`, `images`, `urls`, `hits`, `language`, `version`) VALUES (1, 0, 0, 1, 0, '', 'ROOT', 'root', '', '', 1, 0, '0000-00-00 00:00:00', 1, '{}', '', '', '', '', '2011-01-01 00:00:01','', 0, '0000-00-00 00:00:00', '', '', 0, '*', 1);
This is really dumb because _tags wasn't in the j2.5.14 version of the database. So the upgrade is trying to install it twice?!

Do I really have to uninstall allll of the non-joomla extensions? I've spent hours customizing them. I guess I can uninstall Easyblog, Ignite Gallery, Mijoshop and the Rocket extensions, run the upgrade and then reinstall, copy the customized files from the backup and load the tables for these extensions in the database manually.

This is such a hassle for an upgrade. If 3.0 didn't have the mobile bootstrap functionality we want, I'd live with 2.5 until it was dead. Migrating from 2.5 has been quite enough of a chore. I thought that it was supposed to get easier after the migration - NOT.

I really appreciate all the notes and tips you've posted here. I just wish one of the magic wands would work and I could get past this part! :'(
Deb

mtgt69
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Apr 09, 2009 1:00 am

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by mtgt69 » Sat Oct 12, 2013 8:26 am

Hi,

1- I try different way to update from 2.5.14 to 3.1.5
First time just in pressing update, and I get the error "/error.php on line 797"
Then I've checked on internet and I've found some topic anout this error and the procedure to do.
2- I've deleted #__menu table with the id=23 and I've uninstalled XMAP on fresh copy of 2.514 backup but upgrade fail
3- I reinstall the backup of 2.5.14, remove the #__menu table with the id=23 - uninstall every plugin, component, module, package, language, template, etc which was not from joomla! Project and I've tried to upgrade to 3.1.5 and that fail!

So I don't know now how to try it, :(

Any help will be really nice
Thans in advance for your answer

mtgt69
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Apr 09, 2009 1:00 am

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by mtgt69 » Wed Oct 16, 2013 6:40 am

Hi,

I don't know if you have solved it, but for my part I've done it!
The only thing which was wrong waw Magic Quote was ON, I've turned OFF and I migrate to 3.15 in using the normal joomla update (STS) without error
Before migrate I just removed JComment and Xmap and I removed on menu table of database the ID_23

And all good
Hope that help somebody ;)

User avatar
dlm
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Wed Mar 26, 2008 7:56 pm
Location: Bozeman, Montana
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by dlm » Wed Oct 16, 2013 3:05 pm

I don't know if this will help anyone but the rest of my process (torture!) in upgrading to 3.1.5 is here - http://forum.joomla.org/viewtopic.php?f=710&t=822186.

Two factors that got me to the finish line were (1) deleting the _tags table and (2) clearing out all the caches, including the discover cache.
Good luck! I hope your journey is easier.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20268
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by leolam » Mon Oct 21, 2013 10:57 am

And if people just follow advise life would be so much easier: http://forum.joomla.org/viewtopic.php?f=710&t=793171

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

doukas
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Oct 21, 2013 2:26 pm

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by doukas » Mon Oct 21, 2013 2:36 pm

Hi! I try this, before i make any changes to my real site. I make a fresh install of 2.5.14, then migrate to 3.15 and I getting: ....administrator/index.php?option=com_joomlaupdate&task=update.finalise,
in white screen like @onderzoekspraktijk
Whats the problem?

User avatar
dlm
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 172
Joined: Wed Mar 26, 2008 7:56 pm
Location: Bozeman, Montana
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by dlm » Mon Oct 21, 2013 2:54 pm

I was never able to get an upgrade from 2.5.14 to 3.1.5 to work. I went from 2.5.14 to 3.0.1, then to 3.1.5.

And I did everything prescribed in the guidelines. I think I went through at least 12 tries.

I hope you can get it to work.

gcollier02
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Fri Feb 03, 2012 2:57 pm

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by gcollier02 » Thu Oct 24, 2013 8:44 pm

This is quite a bit late on this post, but I made a bit of headway when I experienced this issue, today. My upgrade from 2.5.14 was getting the white screen of death, as mentioned above, when it attempted to finalize.

One of the steps I took, I believe, helped; was going to The extension manager and purging the cache, then choosing the database tab (showed several errors that existed) and using the "fix" button. The next time I tried upgrading went flawlessly.

User avatar
ISScyborg
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Mon Jun 04, 2012 1:40 pm
Location: Slovenia
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by ISScyborg » Sat Nov 02, 2013 11:03 am

I got too white screen, but on one of my backups. I will wait on 3.5:)

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20268
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by leolam » Sun Nov 03, 2013 4:06 am

ISScyborg wrote:I got too white screen, but on one of my backups. I will wait on 3.5:)
A white screen is a PHP-error and it won't have any effect if you wait for J35 since that will happen than again. You need to enable error reporting and set to maximum and reload sand see what errors are being generated and act as per errors. Again a white screen is pure PHP (version) related or related to incompatible php extensions

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

User avatar
masoesa
Joomla! Explorer
Joomla! Explorer
Posts: 300
Joined: Mon Sep 26, 2005 7:11 pm
Location: Brooklyn NY
Contact:

Re: upgrading from 2.5.14 to 3.1.5: just will not work

Post by masoesa » Thu Sep 04, 2014 6:22 pm

onderzoekspraktijk wrote:
axcelia wrote:Ok I managed to get this working (hallelujah)

This Thread -> http://forum.joomla.org/viewtopic.php?f=710&t=812445
And this post \/ helped me
Thanks for the link.

Almost at the bottom I found what helped me:
bennieblanco wrote: 1. Install manual Joomla 2.5.x to Joomla 3.0.1 pack as a Joomla extension
2. Go to Extensions -> Extensions Manager -> Database and click on Fix button
3. Go to Extensions -> Extensions Manager -> Discover and install discovered extensions
4. Upgrade from Joomla 3.0.1 to Joomla 3.1.5

but it bugs me because it makes no sense

If any extensions used were not compatible , than I would get errors from 2.5.14 to 3.0.1.
What I did notice is that the update fails at exactly 82.4% and I think it has something to do with tags component.

I also noticed an odd short page refresh on 82.4% right before the update fails.
I did as suggested (googled for the old update) and after lots of clicking the admin template also awoke, and that was that: it now works.

Thanks.
Paul
I like to give this a try. Where can I find: Joomla 2.5.x to Joomla 3.0.1 pack as a Joomla extension
http://going-natural.com
The site where Natural Beauty Shines


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”