Website out after automatic update to 3.4

Need help upgrading your Joomla! website or converting to Joomla! 3.x?
Locked
mtgt69
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Apr 09, 2009 1:00 am

Website out after automatic update to 3.4

Post by mtgt69 » Wed Feb 25, 2015 9:23 am

Hi,

Just after updating the front part website let a palace to 2 error messages.

Code: Select all

Notice: Undefined index: fr-FR in /home3/mtgt69/public_html/nomadsroad/plugins/system/languagefilter/languagefilter.php on line 337

Notice: Trying to get property of non-object in /home3/mtgt69/public_html/nomadsroad/plugins/system/languagefilter/languagefilter.php on line 337
with funny URL. In place of www.nomadsroad.com/fr I had double / after .com www.nomadsroad.com//fr and nothing loading exept this 2 error.

So I unpublished the plugin system "language filter" cear the cache and the website was back.

But the language system is not anymore available and all external url linked to my website get a 404 error page. Url have to be like this : http://www.nomadsroad.com/fr/le-voyage- ... interactif but since the updtate the url are like this http://www.nomadsroad.com/le-voyage-et- ... interactif, so without laguage prefix

Any help will be nice
Thanks in advance
Greg

trebien
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Jul 15, 2010 9:56 am

Re: Website out after automatic update to 3.4

Post by trebien » Wed Feb 25, 2015 10:24 am

Same problem here.

--

Going to Language Manager -> Content
Click on every language and do a save&close seems to fix this.

mtgt69
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Apr 09, 2009 1:00 am

Re: Website out after automatic update to 3.4

Post by mtgt69 » Wed Feb 25, 2015 10:44 am

yep! :D

Thanks Trebien, that works!

jschmi
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Wed Oct 08, 2008 7:14 am

Re: Website out after automatic update to 3.4

Post by jschmi » Wed Feb 25, 2015 10:59 am

hi,

I had the same problem, when multiple languages are installed and language switcher module is active (must be active for multilingual sites) your website will be out and not anymore accessible).

I think, this is a serious migration problem and should either be fixed or at least give the admin a post-installation hint.

greetings,
Jochen

User avatar
AlphaDesign
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Fri Apr 14, 2006 3:12 pm
Location: France - Nîmes
Contact:

Re: Website out after automatic update to 3.4

Post by AlphaDesign » Fri Feb 27, 2015 5:12 pm

Thanks Trebien, for your solution which fixed one of my client multilingual site which was getting an ERR_TOO_MANY_REDIRECTS after the Joomla 3.4 update
Alpha Design : Joomla Template Design & Development since 2005
alphadesign.fr/services/creation-de-sites-templates-joomla-responsives.html
alphadesign.fr

ml44230
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Mar 03, 2015 2:10 pm

Re: Website out after automatic update to 3.4

Post by ml44230 » Tue Mar 03, 2015 2:28 pm

I had the same problem too on a site with the language filter plugin published ( on another site, it was unpublished and everything was fine).
I lost a lot of time finding what was the code reponsible of the problem before finding the languagefilter.php in Plugins/system/languagefilter
I agree to say that this issue is a serious one and must be fixed or documented in the post install messages.


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”