Save / Save & Close Buttons don't work in Joomla 3.4

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Sarr777
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Mar 02, 2015 6:36 pm
Location: Poland
Contact:

Save / Save & Close Buttons don't work in Joomla 3.4

Post by Sarr777 » Mon Mar 02, 2015 7:12 pm

Hello,

After I made two automatic upgrades via Joomla backend on new quickstart site (going from 3.2 to 3.4), Save Button stopped working. It was last upgrade to 3.4 that broke it. Can't save even global configuration (also modules, articles).

Firebug console showed me:
TypeError: document.formvalidator is undefined

I include 2 pics to show the problem. Can you help somehow? I don't know javascript or jquerry language I'm afraid...

Oh, Cancel button works normally. So that's pretty strange to me :/.
You do not have the required permissions to view the files attached to this post.

Nemesiss
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Thu Oct 09, 2008 8:57 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by Nemesiss » Mon Mar 02, 2015 8:38 pm

I am having a similar issue with the save not working and also noticed the when clicking on the quick icons to unpublish articles that also does not work.

Happened after the 3.4 update.

Sarr777
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Mar 02, 2015 6:36 pm
Location: Poland
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by Sarr777 » Mon Mar 02, 2015 8:46 pm

Nemesiss wrote:I am having a similar issue with the save not working and also noticed the when clicking on the quick icons to unpublish articles that also does not work.

Happened after the 3.4 update.
Thanks for writing. Also only on Isis Admin template?

Nemesiss
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Thu Oct 09, 2008 8:57 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by Nemesiss » Mon Mar 02, 2015 9:38 pm

Well maybe mine was unrelated. I also had issues with the Isis admin template and the global config CSS not showing. There is a fix available coming in 3.4.1 and the thread is posted in these forums. Not sure if that is something may help you or not.

Sarr777
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Mar 02, 2015 6:36 pm
Location: Poland
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by Sarr777 » Mon Mar 02, 2015 10:17 pm

Nemesiss wrote:Well maybe mine was unrelated. I also had issues with the Isis admin template and the global config CSS not showing. There is a fix available coming in 3.4.1 and the thread is posted in these forums. Not sure if that is something may help you or not.
Hmm, do you remember where exactly or got the link? Maybe it will fix it for me.
I also can't save to create new tab in GK5 Tabs from here:
https://www.gavick.com/best-free-joomla-tab-module

On 3.3.6 all works fine - I have others sites on this versions to prove it. Only 3.4 breaks save buttons...
I get javascript error in the firebug console:
"TypeError: item.getElements(...)[1] is undefined"

So clearly that's Joomla 3.4 that breaks it, 3.3.6 was is fine.

Nemesiss
Joomla! Explorer
Joomla! Explorer
Posts: 295
Joined: Thu Oct 09, 2008 8:57 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by Nemesiss » Mon Mar 02, 2015 10:56 pm


jcms
I've been banned!
Posts: 2233
Joined: Wed Nov 19, 2014 9:23 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by jcms » Wed Mar 04, 2015 4:34 pm

you can check the class form from: \libraries\joomla\form\

tmckmj
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 21, 2015 3:55 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by tmckmj » Thu Mar 05, 2015 1:08 am

I also upgraded from 3.3.6 to 3.4. Update went smoothly and as far as I can tell, all works fine except I can't save any changes.

I have dead "save" and "save and close" buttons in the backend admin. My site is offline and I can't change that. One item different from other comments above is that I was able to edit and save an article from the front end.

I'm anxious for a solution. Is there any consideration or recommendation to restore the site to the previous backup? Can I go back to what worked until this is resolved?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19884
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by leolam » Thu Mar 05, 2015 8:39 am

You need to clear your browser cache, shut down browser and reload. We are not aware of any "save" errors and I have no problems saving anything on our own sites after the upgrade

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

tmckmj
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sat Feb 21, 2015 3:55 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by tmckmj » Thu Mar 05, 2015 9:14 pm

Great news! I cleared my Chrome browser cache and it did in fact fix the problem. Thank you much!

kecker
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Fri May 18, 2007 9:41 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by kecker » Mon Mar 09, 2015 6:17 am

leolam wrote:You need to clear your browser cache, shut down browser and reload. We are not aware of any "save" errors and I have no problems saving anything on our own sites after the upgrade

Leo 8)
I've found just forcing a hard refresh of the page (Hold Shift, click refresh) does the trick but yeah, this is probably the "correct" way.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19884
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by leolam » Mon Mar 09, 2015 6:37 am

It is the only way indeed and is correct (browser keeps cache)

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

kecker
Joomla! Intern
Joomla! Intern
Posts: 99
Joined: Fri May 18, 2007 9:41 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by kecker » Mon Mar 09, 2015 6:55 am

That's why forcing a hard refresh (not a regular refresh) works. Forces the browser to dump the cache it has and reload from scratch.

manuxx
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 11, 2015 7:29 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by manuxx » Wed Mar 11, 2015 7:34 am

This has nothing to do with browser cache.

Is a bug reported in dozens of websites by many users. Happened to me in 3 installations already in this version.

Please be a bit serious, one reading this may think is solved but this is a present bug!!

juka
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 11, 2015 12:19 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by juka » Wed Mar 11, 2015 12:45 pm

I have one client who has public and developing-versions of his site on server. Both used to use Joomla 3.2 which had problems with Save and Save & Close buttons so i tried to update dev to use Joomla 3.4, but the problem worsened.

In Joomla 3.2 only saving modules (mod_custom) were broken (lost all newly added texts and added lock next to name of module and there was no error message. Saving articles worked). And then in Joomla 3.4 even saving articles is now broken and i get error message "TypeError: document.formvalidator is undefined" whenever i try to use Save or Save & Quit-buttons.

Clearing caches of PHP, Joomla and Web Browser doesn't help, but somehow this is server related because my client used to have his site in other server and it worked fine there and it works just fine in my computer too, but now he has new server and returning to the old one is impossible.

EDIT: Probably max_input_var in php.ini is part of reason why saving doesn't work. In my client's server it is only 256, but it's commented out in my computer. Can't edit thou so i have to wait until their admin makes changes. I recommended them to comment it out or at least put larger number like a few thousands.

wesleykoop
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Mar 11, 2015 8:36 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by wesleykoop » Wed Mar 11, 2015 4:12 pm

all my buttons are gone ive tried clearing cache but didnt work....can someone PM me to help me fix this?

manuxx
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 11, 2015 7:29 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by manuxx » Wed Mar 11, 2015 4:17 pm

Well someone please share a fix for this. I tried in 3 different hosts even with clean installation of 3.4 this happens so there is denitetly something wrong in Joomla.

juka
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 11, 2015 12:19 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by juka » Thu Mar 12, 2015 8:52 am

Joomla 3.2 works now perfect, but 3.4 is still broken. Still somehow it must be server related because if i download client's site to my computer it works perfect from there, but not in client's server. Only major difference is server software (i'm using Apache and client is using Nginx).

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19884
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by leolam » Thu Mar 12, 2015 4:41 pm

manuxx wrote:Well someone please share a fix for this. I tried in 3 different hosts even with clean installation of 3.4 this happens so there is denitetly something wrong in Joomla.
No it is not it is a browser cache that has not been cleared
manuxx wrote:This has nothing to do with browser cache.Is a bug
I am very serious and it is not a bug for sure. It is exactly what I have mentioned and nothing else. If you do not agree please join me in the Joomla Bug Squad and do the job for us since we are all pretty much sure that is the expected behavior

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

pkieran01
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 13, 2015 8:28 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by pkieran01 » Fri Mar 13, 2015 8:33 am

I upgraded a site from 3.3.6 to 3.4 and the process didn't complete successfully. All buttons in the article editor stopped working as a result. Cache clearing didn't resolve the problem.

I noticed that my default editor had switched from JCE to the default. I switched back to JCE in User Manager and the buttons in the article manager now work as expected.

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8808
Joined: Sat Oct 01, 2011 7:06 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by sovainfo » Fri Mar 13, 2015 9:26 am

When the process didn't complete successfully, the update failed. You should restore from backup. fix the issue and update again!

Only resetting the editor to JCE is not FIXING anything!

See https://docs.joomla.org/Category:Version_3.4.0_FAQ for issues with J3.4.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

Simpel78
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Sat May 19, 2007 9:05 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by Simpel78 » Fri Mar 13, 2015 9:33 am

Same problem here, after upgrade to jooma 3.4. I can't save any modules information. like text and menu assignments

bcosby
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Mar 14, 2015 4:25 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by bcosby » Sat Mar 14, 2015 4:47 pm

leolam, I mean no disrespect to you as I know you are a Joomla expert and No, I do not want to join the bug squad. Yes, I am a Joomla newbie. However, with 19 years of desktop software end user support, I am not new to Google Chrome, Microsoft Internet Explorer, and Mozilla Firefox.

That stated, since updating my site to 3.3.6, I have experienced issues with the links on the top menu bar ("system" "users" "menus" "content" "components" "extensions" "help" the preview link and the logout link) as well as the buttons ("save" "save & close" "save & new" "save as copy" and "close"). I upgraded to 3.4 this morning and still have the same issues. It's not just one component, module, or plugin, but all pages. With the 3.4 upgrade, I have also lost the ability to "toggle" between wysiwyg and html code when editing articles.

I have done exactly as you recommended, over and over again, logged out of the site (when the link isn't broken), closed my browsers, cleared the cache, restarted the browser and logged back in. Upon logging in, everything seems to work perfectly.... however, after a few modifications, article edits, switching to various pages using the buttons and links, the sames issues occur. I have tried using all three browsers mentioned above thinking maybe there was just some tiny thing not right, however, I have the same end result.

I literally spent 2 hours creating one (1) article and making minor modifications.

I am at a loss... I have no idea what to do next, so I was hoping someone on this forum could provide insight and assistance. This is a problem. It is not imaginary.

Thanks

newbrownshoe
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Apr 30, 2009 5:09 am

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by newbrownshoe » Sun Mar 15, 2015 12:27 pm

I had this problem straight out of the box. Was making my first Global changes and it wouldn't save. I followed Leolam's instruction to clear cache. I closed Joomla, cleared everything in my 2 browsers IE & Chrome, reopened Joomla and the Save buttons worked.
Unlike earlier versions, If you have to clear Cache to have the Save buttons work, that sounds like a bug to me. Alternatively, it could be written as a new 'instruction' somewhere... "Clear Cache to have Save buttons work".

(Thanks to all developers, bug squad and forum posters - love your work.)

bcosby
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Mar 14, 2015 4:25 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by bcosby » Thu Mar 19, 2015 4:47 pm

This is still not working properly for me. I have tried using all three previously mentioned browsers on multiple computers. Even after clearing the cache repeatedly and running a cleaning tool on the computers, I still have the same response from the administrator side of my Joomla site. Any suggestions?

User avatar
yellowwebmonkey
Joomla! Explorer
Joomla! Explorer
Posts: 328
Joined: Tue Nov 17, 2009 4:22 am
Location: Central Texas
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by yellowwebmonkey » Thu Mar 19, 2015 4:55 pm

Try downloading and installing the Web Developer's Toolbar from http://chrispederick.com/work/web-developer/. Then click on the Sprocket icon for it, and from the OPTIONS tab, hit RESET PAGE.

thune
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Sat Dec 17, 2005 12:03 am
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by thune » Fri Mar 20, 2015 2:24 pm

Have the same problem. Deleted browsercache and refreshed with F5 and more...Can't save or cancel. It's a bug for sure.

I upgraded from 2.5 to 3.4.

flashfs
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Sep 02, 2013 12:49 pm

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by flashfs » Fri Mar 20, 2015 3:09 pm

I've upgraded from 2.5.28 to 3.4.0 and was having this same issue. Tried the "private navigation" from Firefox and the buttons worked. So I came back to the normal navigation, entered on a page where we have the buttons not working and a Control+F5 did the trick for me. Now the buttons are back.

thune
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Sat Dec 17, 2005 12:03 am
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by thune » Fri Mar 20, 2015 3:27 pm

Obviously you had the "cache issue" and I'm glad you fixed it. But this does nothing for me. The buttons don't work in private navigation.

It's pretty strange. It takes a "long" time to load the configuration.php.

User avatar
yellowwebmonkey
Joomla! Explorer
Joomla! Explorer
Posts: 328
Joined: Tue Nov 17, 2009 4:22 am
Location: Central Texas
Contact:

Re: Save / Save & Close Buttons don't work in Joomla 3.4

Post by yellowwebmonkey » Fri Mar 20, 2015 6:02 pm

@thune, do you have any 3rd party admin components, admin modules, or admin templates installed on the admin side?


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”