unable to find installation package xml error after update to joomla 3.8.1

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Fri Oct 20, 2017 6:14 am

Hi i have the same problem {unable to find installation package xml error} after update to joomla 3.8.1

here is my fpa result:
Last edited by gsajoomi on Fri Oct 20, 2017 7:49 am, edited 3 times in total.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: update joomla 3.8.1 error

Post by gsajoomi » Fri Oct 20, 2017 6:51 am

i installed joomla update automayically from update section and not from extention installer
I updated from 3.7.2 to 3.8.1 without error and successfull
The only issue is that after update I cannot install or update extentions, the website works on the frontend.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12865
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by toivo » Fri Oct 20, 2017 7:10 am

@gsajoomi - please follow the instructions and post the FPA output in the correct format.
Toivo Talikka, Global Moderator

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Fri Oct 20, 2017 7:29 am

Log/Error Message :: Forum Post Assistant (v1.3.4) : 20th October 2017 wrote:[20-Oct-2017 08:48:20 Asia/Tehran] PHP Warning: filegroup() has been disabled for security reasons in /home3/xxx/public_html/fpa-en.php on line 1567
Forum Post Assistant (v1.3.4) : 20th October 2017 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.8.1-Stable (Amani) 4-October-2017
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) | Owner: --protected-- . (uid: /gid: ) | Group: --protected-- (gid: ) | Valid For: 3.8
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 1 | SEF ReWrite: 1 | .htaccess/web.config: Yes | GZip: 1 | Cache: 0 | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: 0 | FTP Layer: 0 | Proxy: 0 | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: 0 | SSL: 0 | FrontEdit: 1 | Error Reporting: none | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 1 | Database Credentials Present: Yes

Host Configuration :: OS: | OS Version: | Technology: | Web Server: LiteSpeed | Encoding: gzip, deflate | Doc Root: --protected-- | System TMP Writable: Yes

PHP Configuration :: Version: 7.0.9 | PHP API: litespeed | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 22519 | Log Errors To: error_log | Last Known Error: 20th October 2017 08:53:37. | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: /home3/xxx:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp | Uploads: 1 | Max. Upload Size: 100M | Max. POST Size: 100M | Max. Input Time: 60 | Max. Execution Time: 60 | Memory Limit: 280M

MySQL Configuration :: Version: 5.6.37-log (Client:5.6.37) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 158.77 MiB | #of Tables: 106
Detailed Environment :: wrote:PHP Extensions :: Core (7.0.9) | date (7.0.9) | libxml (7.0.9) | openssl (7.0.9) | pcre (7.0.9) | sqlite3 (0.7-dev) | zlib (7.0.9) | bcmath (7.0.9) | calendar (7.0.9) | ctype (7.0.9) | curl (7.0.9) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.0.9) | ftp (7.0.9) | gd (7.0.9) | gettext (7.0.9) | SPL (7.0.9) | iconv (7.0.9) | session (7.0.9) | intl (1.1.0) | json (1.4.0) | mbstring (7.0.9) | mcrypt (7.0.9) | standard (7.0.9) | mysqli (7.0.9) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $) | Phar (2.0.2) | posix (7.0.9) | Reflection (7.0.9) | imap (7.0.9) | SimpleXML (7.0.9) | soap (7.0.9) | sockets (7.0.9) | exif (1.4 $Id: 8bdc0c8f27c2c9dd1f7551f1f9fe3ab57a06a4b1 $) | tidy (7.0.9) | tokenizer (7.0.9) | wddx (7.0.9) | xml (7.0.9) | xmlreader (7.0.9) | xmlrpc (7.0.9) | xmlwriter (7.0.9) | xsl (7.0.9) | zip (1.13.3) | litespeed () | SourceGuardian (11.1.1) | PDO (7.0.9) | pdo_mysql (7.0.9) | pdo_sqlite (7.0.9) | ionCube Loader () | Zend Engine (3.0.0) |
Potential Missing Extensions :: mysql | suhosin |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) |

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20243
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by leolam » Fri Oct 20, 2017 4:59 pm

You have not uploaded the complete FPA. Please correct

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Fri Oct 20, 2017 6:18 pm

leolam wrote:You have not uploaded the complete FPA. Please correct

Leo 8)
Can you explain in more detail what you mean to upload the complete FPA
i uploaded all results here

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Fri Oct 20, 2017 6:48 pm

Problem Description :: Forum Post Assistant (v1.3.4) : 20th October 2017 wrote:unable to install from extention installer afer update to 3.8.1
Last PHP Error(s) Reported :: Forum Post Assistant (v1.3.4) : 20th October 2017 wrote:[20-Oct-2017 22:06:35 Asia/Tehran] PHP Warning: filegroup() has been disabled for security reasons in /home3/site/public_html/fpa-en.php on line 1567
Forum Post Assistant (v1.3.4) : 20th October 2017 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.8.1-Stable (Amani) 4-October-2017
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) | Owner: --protected-- . (uid: /gid: ) | Group: --protected-- (gid: ) | Valid For: 3.8
Configuration Options :: Offline: 0 | SEF: 1 | SEF Suffix: 1 | SEF ReWrite: 1 | .htaccess/web.config: Yes | GZip: 1 | Cache: 0 | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: 0 | FTP Layer: 0 | Proxy: 0 | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: 0 | SSL: 0 | FrontEdit: 1 | Error Reporting: none | Site Debug: 0 | Language Debug: 0 | Default Access: 1 | Unicode Slugs: 1 | Database Credentials Present: Yes

Host Configuration :: OS: | OS Version: | Technology: | Web Server: LiteSpeed | Encoding: gzip, deflate | Doc Root: --protected-- | System TMP Writable: Yes

PHP Configuration :: Version: 7.0.9 | PHP API: litespeed | Session Path Writable: Yes | Display Errors: 1 | Error Reporting: 22519 | Log Errors To: error_log | Last Known Error: 20th October 2017 22:06:50. | Register Globals: | Magic Quotes: | Safe Mode: | Open Base: /home3/site:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp | Uploads: 1 | Max. Upload Size: 100M | Max. POST Size: 100M | Max. Input Time: 60 | Max. Execution Time: 60 | Memory Limit: 280M

MySQL Configuration :: Version: 5.6.37-log (Client:5.6.37) | Host: --protected-- (--protected--) | Collation: latin1_swedish_ci (Character Set: latin1) | Database Size: 158.77 MiB | #of Tables: 106
Detailed Environment :: wrote:PHP Extensions :: Core (7.0.9) | date (7.0.9) | libxml (7.0.9) | openssl (7.0.9) | pcre (7.0.9) | sqlite3 (0.7-dev) | zlib (7.0.9) | bcmath (7.0.9) | calendar (7.0.9) | ctype (7.0.9) | curl (7.0.9) | dom (20031129) | hash (1.0) | fileinfo (1.0.5) | filter (7.0.9) | ftp (7.0.9) | gd (7.0.9) | gettext (7.0.9) | SPL (7.0.9) | iconv (7.0.9) | session (7.0.9) | intl (1.1.0) | json (1.4.0) | mbstring (7.0.9) | mcrypt (7.0.9) | standard (7.0.9) | mysqli (7.0.9) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: 241ae00989d1995ffcbbf63d579943635faf9972 $) | Phar (2.0.2) | posix (7.0.9) | Reflection (7.0.9) | imap (7.0.9) | SimpleXML (7.0.9) | soap (7.0.9) | sockets (7.0.9) | exif (1.4 $Id: 8bdc0c8f27c2c9dd1f7551f1f9fe3ab57a06a4b1 $) | tidy (7.0.9) | tokenizer (7.0.9) | wddx (7.0.9) | xml (7.0.9) | xmlreader (7.0.9) | xmlrpc (7.0.9) | xmlwriter (7.0.9) | xsl (7.0.9) | zip (1.13.3) | litespeed () | SourceGuardian (11.1.1) | PDO (7.0.9) | pdo_mysql (7.0.9) | pdo_sqlite (7.0.9) | ionCube Loader () | Zend Engine (3.0.0) |
Potential Missing Extensions :: mysql | suhosin |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) |

Elevated Permissions (First 10) :: images/swmenufree/ (757) | images/swmenufree/arrows/ (757) | images/swmenufree/textures/ (757) | images/swmenufree/transmenu/ (757) |
Database Information :: wrote:Database statistics :: Uptime: 4520460 | Threads: 2 | Questions: 1706505442 | Slow queries: 107494 | Opens: 47760902 | Flush tables: 1 | Open tables: 2048 | Queries per second avg: 377.507 |
Extensions Discovered :: wrote:



Plugins :: SITE :: plg_editors_jce (2.5.16) 1 | plg_editors_tinymce (4.5.7) 1 | plg_editors_codemirror (5.28) 1 | DJCatalog2 - CComment (5.3.5) 0 | plg_installer_packageinstaller (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_installer_webinstaller (1.1.1) 0 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_cookie (3.0.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_gmail (3.0.0) 0 | PLG_GSD_SPPAGEBUILDER (1.0) 0 | PLG_GSD_VIRTUEMART (1.0) 0 | PLG_GSD_RSBLOG (1.0) 0 | PLG_GSD_K2 (1.0) 0 | PLG_GSD_CONTENT (1.0) 1 | PLG_GSD_HIKASHOP (1.0) 0 | PLG_GSD_EASYBLOG (1.0) 0 | PLG_GSD_JSHOPPING (1.0) 0 | Adsmanager - CComment (5.3.5) 0 | plg_user_joomla (3.0.0) 1 | plg_user_contactcreator (3.0.0) 1 | plg_user_profile (3.0.0) 1 | Joomgallery - CComment (5.3.5) 0 | PLG_SYSTEM_MODULESANYWHERE (3.6.0PRO) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_remember (3.0.0) 1 | plg_system_redj (1.7.9) 1 | PLG_SYSTEM_JQUERYEASY (1.6.9) 1 | plg_system_nrframework (2.4.1) 1 | plg_system_debug (3.0.0) 1 | System - kareebu Secure (1.0.3) 1 | plg_system_languagecode (3.0.0) 1 | PLG_PWEBOPENGRAPH (1.1.11) 1 | plg_system_gsd (3.0.2) 1 | System - nfrPiwik (3.5.7) 1 | System - Tabulizer CSS (4.1.13) 0 | plg_system_jce (2.5.16) 1 | plg_system_languagefilter (3.0.0) 0 | PLG_SYSTEM_JCH_OPTIMIZE (5.1.2) 0 | System - Tabulizer CSS Legacy (4.1.13) 0 | System - Tabulizer jQuery (4.1.13) 0 | plg_system_redirect (3.0.0) 1 | plg_system_highlight (3.0.0) 1 | System - JSitemap utilities (4.3.1) 1 | plg_system_sef (3.0.0) 1 | Redshop Product - CComment (5.3.5) 0 | plg_system_advancedmodules (7.1.6PRO) 1 | plg_system_fields (3.7.0) 1 | plg_system_p3p (3.0.0) 1 | plg_system_nnframework (16.6.1) 1 | PLG_SYSTEM_HEADERTAGS (3.2.1) 1 | PLG_SYSTEM_CONTENTTEMPLATER (4.10.2PRO) 0 | System - Marco's SQL Injection (1.4) 1 | PLG_SYSTEM_ARTICLESANYWHERE (3.7.0PRO) 0 | plg_system_logout (3.0.0) 1 | plg_system_cache (3.0.0) 1 | PLG_SYS_BYEBYEGENERATOR (1.11) 1 | plg_system_stats (3.5.0) 1 | plg_system_regularlabs (17.7.17782) 1 | PLG_SYSTEM_COMPONENTSANYWHERE (1.4.0PRO) 1 | PLG_SYS_MOOTABLE (1.1.3) 0 | plg_system_log (3.0.0) 1 | System - Helix3 Framework (1.1) 1 | Community - CComment (5.3.5) 0 | CComment Walls (5.3.5) 0 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_jcefilebrowser (2.5.16) 0 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_search_tags (3.0.0) 1 | Search - CComment (5.3.5) 0 | plg_search_content (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_finder_tags (3.0.0) 0 | Smart Search - CComment (5.3.5) 0 | plg_finder_content (3.0.0) 0 | plg_finder_categories (3.0.0) 0 | plg_finder_contacts (3.0.0) 0 | plg_finder_newsfeeds (3.0.0) 0 | plg_extension_joomla (3.0.0) 1 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_twofactorauth_totp (3.2.0) 0 | K2 Plugin - CComment (5.3.5) 0 | Content - Marco's noFollow (1.4) 1 | JEvents - CComment (5.3.5) 0 | Content - Tabulizer CSS (4.1.13) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_finder (3.0.0) 0 | plg_content_joomla (3.0.0) 1 | System - Zoo CComment (5.3.5) 0 | Content - RokInjectModule (1.7) 0 | PLG_CONTENT_EXTRAVOTE (2.5.8) 1 | plg_content_fields (3.7.0) 1 | Content - JSitemap Pingomatic (4.3.1) 1 | plg_content_loadmodule (3.0.0) 1 | Content - CComment (5.3.5) 1 | plg_content_phoca_open_graph (3.1.0) 0 | plg_content_vote (3.0.0) 0 | plg_content_pagenavigation (3.0.0) 1 | plg_content_emailcloak (3.0.0) 0 | HWDMediaShare - Comments (CCom (5.3.5) 1 | PLG_EDITORS-XTD_MODULESANYWHER (3.6.0PRO) 1 | Button - ReTabulizer (4.1.13) 0 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_article (3.0.0) 1 | Button - Tabulizer Data Source (4.1.13) 0 | plg_editors-xtd_pagebreak (3.0.0) 1 | Button - Tabulizer (4.1.13) 0 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_image (3.0.0) 1 | PLG_EDITORS-XTD_ARTICLESANYWHE (3.7.0PRO) 1 | plg_editors-xtd_module (3.5.0) 1 | DOCman - CComment Plugin (5.3.5) 0 | plg_fields_text (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_user (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | DPCalendar - CComment (5.3.5) 0 | Ninjamonials - CComment (5.3.5) 0 | Hikashop - CComment (5.3.5) 0 | plg_captcha_recaptcha (3.4.0) 0 | PLG_AJAX_EXTRAVOTE (1.0) 1 | Helix3 - Ajax (1.1) 1 | CComment - AlphaUserPoints int (5.3.5) 1 | CComment - JomSocial features (5.3.5) 0 |
Templates Discovered :: wrote:Templates :: SITE :: beez3 (3.1.0) 1 | protostar (1.0) 1 | shaper_helix3 (1.1) 1 | shaper_varsita (1.1) 1 |
Templates :: ADMIN :: hathor (3.0.0) 1 | isis (1.0) 1 |

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Fri Oct 20, 2017 10:09 pm

Max. Execution Time: 60 increase to 300
  1. Global configuration ... can you save it twice ?
  2. Components >>> Joomla update ... Check for updates ... can you reinstall core files ?
  3. Components >>> Joomla update ... Check for updates ... can you download https://downloads.joomla.org/cms/joomla ... ackage.zip ? (if not download it with your browser not from within Joomla).
  4. Components >>> Joomla update >>> Upload&Update(tab) ... can you Upload&Install the update package ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 5:07 am

Webdongle wrote:Max. Execution Time: 60 increase to 300
  1. Global configuration ... can you save it twice ?
  2. Components >>> Joomla update ... Check for updates ... can you reinstall core files ?
  3. Components >>> Joomla update ... Check for updates ... can you download https://downloads.joomla.org/cms/joomla ... ackage.zip ? (if not download it with your browser not from within Joomla).
  4. Components >>> Joomla update >>> Upload&Update(tab) ... can you Upload&Install the update package ?
1-Global configuration work fine. i can save and change settings.
2-Yes i can reinstall core files .i reinstalled core files. That went flawlessly.
3-I can download with my browser
4-Yes i can install update package and worked flawlessly

I reinstalled core files and uploded joomla 3.8.1 upgrade packege but my problem not solved . i can not use extention installer.
when i copied and extracted extention package to tmp folder i can install .but via extention installer i Can't install anything.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12865
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by toivo » Sat Oct 21, 2017 6:29 am

gsajoomi wrote:via extention installer i Can't install anything
It sounds like your site still has something that should not be there.
Elevated Permissions (First 10) :: images/swmenufree/ (757) | images/swmenufree/arrows/ (757) | images/swmenufree/textures/ (757) | images/swmenufree/transmenu/ (757) |
These world writable folders have been a security issue and you should remove those folders but also clean your site fully because it may have some back doors installed by hackers.

You must have uninstalled the extension that created those folders because it is not listed by the FPA. According to the website of the developer, "Versions of swMenuFree prior to 8.5 may have a vulnerability with the chmoding of some folders."

Go to the 3.x Security forum and read the instructions in the sticky posts and follow best practice:
viewtopic.php?f=714&t=757645
viewtopic.php?f=714&t=946026
Toivo Talikka, Global Moderator

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 7:19 am

I don't use swmenufree anymore .i unistalled this extention many year ago i think this extention is from j2.5.
thanks for your advice i deleted all swmenu folders

i am not sure that my site hacked .my site worked properly until i udated 3.7.2 to 3.8.1
i updated my site many times in the past .and nothing happened .and i use my site for about 6 years from joomla 1.6 to present

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 8:07 am

I installed a new fresh joomla 3.8.1 full packege in a subfolder with new database and checked again i have same problem with new joomla 3.8.1 !!
joomla installed flawlessly but xtention installer don't work for me !
Error: unable to find install package

Image
Is this unrecommended option (Native Zip Support Off) an incompatibility between versions of Joomla 3.8.1 and php7.

Thx in advance.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6184
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by AMurray » Sat Oct 21, 2017 8:46 am

Outside of Joomla, open configuration.php in a text editor. Edit the following line:.=

Code: Select all

public $gzip = '0';
.
Change "0" to "1". Go back to the installer and refresh the page and see if that gzip setting "Off" changes to "On".

(actually not sure these two things are related - native zip support and Gzip - so setting it to 1 may not make a difference, so above is a bit of guess-work).

This thread may provide some answers re: native zip support:
viewtopic.php?t=725445
(the post is 5 years old (2012), but there is a recent post there from August 2017). I assume the advice contained in it is still relevant today.
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sat Oct 21, 2017 9:32 am

Ownership is OK because Global config can save when configuration.php is 444

/tmp is OK because the Joomla update component can upload and install.

So what's left that can prevent Joomla from finding the file ?

When you attempt to install an extension ... is it unzipped to a folder in /tmp ? If not then perhaps the way Joomla installs extensions has changed and gzip not being on the server is significant ?

btw changing the gzip setting in global configuration/configuration.php does not change the server. It just uses the gzip compression (if installed on the server) when rendering to the browser. The gzip showing as 'No' in System Settings means it's not installed on the server.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 9:45 am

But gzip in my settings have already been turned on .in configure.php file gzip is 1 public $gzip = '1';
i chenged to 0 but my problem not solved

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sat Oct 21, 2017 10:03 am

gsajoomi wrote:But gzip in my settings have already been turned on .in configure.php file gzip is 1 ...
That will make no difference to the System info showing 'No' to gzip because altering Joomla's gzip setting does not install/uninstall gzip on the server,


[quote="gsajoomi"...
i chenged to 0 but my problem not solved[/quote]No because that only tells Joomla to use (1) or not use (0) gzip to render the pages to the browser (if gzip is installed on the server).

I don't think gzip has any affect on the extension install but you could ask your Host to enable it.

When you attempt to install an extension ... is it unzipped to a folder in /tmp ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 10:19 am

When i trying to install zip file via extention installer nothing unzipped in tmp folder. and i must to upload and uzip files manualy with cpanel to tmp folder then i can install extentions.
Last edited by gsajoomi on Sat Oct 21, 2017 10:27 am, edited 1 time in total.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sat Oct 21, 2017 10:27 am

OK ... so Extension installer is not unzipping the .zip file in /tmp
Is it uploading the file to /tmp ? (if we can pin down the part of the Extension installer we can get the devs to look at what's happening).

Perhaps try increasing Max. Input Time: 60 to 300 ?

Do you have any firewalls etc. on the server ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 10:32 am

Can i set input time 300 with htaccess codes?
Yes i think firewall is activated on my server

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 11:02 am

I reistalled joomla 3.8 and 3.8.1 full packeges in new database and problem not solved but when I installed a fresh copy joomla 3.7.5 full package extention installer worked flwlessly !
my problem is with joomla 3.8.X
Last edited by gsajoomi on Sat Oct 21, 2017 11:57 am, edited 2 times in total.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 11:13 am

My installer issues arrised when i using 3.8x joomla version

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sat Oct 21, 2017 1:04 pm

OK ... so something in Extensions Update has changed and now the server won't allow it to upload. Anything in the firewall logs that could lend a clue ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sat Oct 21, 2017 1:34 pm

Webdongle wrote:OK ... so something in Extensions Update has changed and now the server won't allow it to upload. Anything in the firewall logs that could lend a clue ?
Exactly .i agree and i think the same way.
i think joomla 3.8x extention installer system has changed and different from 3.7x versions.
In my host joomla 3.8x extention installer system don't work and still i don't know why this problem happened.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sat Oct 21, 2017 1:52 pm

Either
Something on your server is not correct and 'tighter' coding in Joomla has shown this up
Or
Something is a miss with Joomla's coding and certain servers are picking up on it.

Have asked in the devs mailing list ... waiting for a reply from them. In the mean time can you check see if the firewall is blocking Extensions >>> Install from uploading the file ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

frostmakk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 181
Joined: Sun Dec 28, 2014 9:30 am
Location: Stavanger, Norway

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by frostmakk » Sun Oct 22, 2017 5:02 am

Maybe setting error reporting to 'maximum' in configuration.php can produce some useful leads to where things are going wrong?

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sun Oct 22, 2017 10:45 am

Webdongle wrote: Have asked in the devs mailing list ... waiting for a reply from them. In the mean time can you check see if the firewall is blocking Extensions >>> Install from uploading the file ?
I communicated with my host managers about this, and they said: This problem is not related to the server firewall and has been tested.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sun Oct 22, 2017 11:32 am

gsajoomi wrote:...
I communicated with my host managers about this, and they said: This problem is not related to the server firewall and has been tested.
I have installed J3.2.7 on localhost (wamp) and updated. Unable to reproduce the error.

Question remains what is different about your server/Joomla setup that causes the error when other systems it works ?

Can you try a different php version ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sun Oct 22, 2017 11:48 am

My previous joomla version was 3.7.2 and not 3.2.7
Yes i tried php 5.4.45 _ 5.5.36 _ 5.6.22 And there is still the same error

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39206
Joined: Sat Apr 05, 2008 9:58 pm

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by Webdongle » Sun Oct 22, 2017 12:16 pm

It is
either
Server configuration
or
Something in Joomla

As you have ruled out
PHP version
and
Firewall/Permissions

As other successful updates and J3.8.1 work with different php versions on various servers
then
What's left ?

3rd party extension/Template conflicting ?
Set Protostar as default Template and disable 3rd party extensions (Extensions >>> Manage >>> manage ... order ID descending puts 3rd party extensions at the top)
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

gsajoomi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Oct 20, 2017 6:00 am

Re: unable to find installation package xml error after update to joomla 3.8.1

Post by gsajoomi » Sun Oct 22, 2017 5:51 pm

Webdongle wrote:It is
either
Server configuration
or
Something in Joomla
I agree with you


3rd party extension/Template conflicting ?
Set Protostar as default Template and disable 3rd party extensions (Extensions >>> Manage >>> manage ... order ID descending puts 3rd party extensions at the top)
This is not the right solution to this problem
Because i installed j3.8.1 full fresh copy without any 3rd party extentions and with default settings but installer issues arrised .

I need to find another solution to this problem


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”