Missing Components after upgrade from J2.5 to 3.8.3

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Locked
User avatar
VThomas
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Tue Oct 23, 2007 2:49 pm

Missing Components after upgrade from J2.5 to 3.8.3

Post by VThomas » Wed Jan 03, 2018 5:14 pm

I successfully upgraded a joomla 2.5 site to J 3.8.3.
The site is functioning, but it is missing the typical list of components in the administrative menu (backend).
Some of those I do see are disabled (via Manage) ,and I don't use them (Banners, Contacts, Messaging, News Feeds. But others do appear 'enabled' via the Manage view, and I do want access to them: Joomla Update, Redirects, Search and Smart Search.

I notice in this view, that some of the 'missing' components show "NA" for folder location. See screenshots.
admin-components.JPG
admin-components-na.JPG
How do you recommend I get those 'enabled' components functioning again? and listed on components again?

Thank you, VIcky
You do not have the required permissions to view the files attached to this post.
An old dog can learn new tricks - I saw it on Mythbusters!

User avatar
VThomas
Joomla! Intern
Joomla! Intern
Posts: 64
Joined: Tue Oct 23, 2007 2:49 pm

Re: Missing Components after upgrade from J2.5 to 3.8.3

Post by VThomas » Wed Jan 03, 2018 6:15 pm

Even though it isn't visible in components dropdown menu, I can get to joomla update page via this link:
administrator/index.php?option=com_joomlaupdate

I 've now reinstalled the joomla core files two times, but the views are the same as the screenshots provided in first post. So, I'm still asking for assistance to correct this. Thanks.
An old dog can learn new tricks - I saw it on Mythbusters!

User avatar
pmleconte
Joomla! Explorer
Joomla! Explorer
Posts: 464
Joined: Fri Mar 17, 2017 12:55 pm
Location: France

Re: Missing Components after upgrade from J2.5 to 3.8.3

Post by pmleconte » Wed Jan 03, 2018 6:17 pm

Hi,

Please check viewtopic.php?f=710&t=957683

Pascal
If anything can go wrong, it will.
https://www.conseilgouz.com/en

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9880
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Missing Components after upgrade from J2.5 to 3.8.3

Post by sozzled » Wed Jan 03, 2018 6:59 pm

@VThomas: as @pmleconte has probably correctly identified the cause, from around the time of J! 3.7.x—it could have been earlier (e.g. J! 3.6, I can't be sure)—admin. menus needed to be assigned to the menu=main in the _menu table.

This "missing components from the menu" issue has been discussed in several places before (the following is a list of some other examples):
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Locked

Return to “Migrating and Upgrading to Joomla! 3.x”