Trying to update from 3.9.8 to 3.9.16, error - invalid login Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 3.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by juggernautsei » Wed Apr 08, 2020 1:11 am

I am getting the same message. I am using AWS for hosting. When I go to the tmp folder the. The package is downloaded into the package. This is what is written in the /administrator/logs/joomla_update.php file

#Fields: datetime priority clientip category message
2020-04-07T10:08:31+00:00 INFO 72.214 update Update started by user Super User (258). Old version is 3.9.8.
2020-04-07T10:08:32+00:00 INFO 72.214 update Downloading update file from https://s3-us-west-2.amazonaws.com/joom ... cf45086738.
2020-04-07T10:08:33+00:00 INFO 72.214 update File Joomla_3.9.16-Stable-Update_Package.zip downloaded.
2020-04-07T10:08:33+00:00 INFO 72.214 update Starting installation of new version.
2020-04-07T23:15:25+00:00 INFO 129.174 update Update started by user Super User (258). Old version is 3.9.8.
2020-04-07T23:15:27+00:00 INFO 129.174 update File Joomla_3.9.16-Stable-Update_Package.zip downloaded.
2020-04-07T23:15:27+00:00 INFO 129.174. update Starting installation of new version.
2020-04-07T23:16:00+00:00 INFO 129.174 update Starting installation of new version.
2020-04-07T23:35:29+00:00 INFO 129.174 update Update started by user Super User (258). Old version is 3.9.8.
2020-04-07T23:35:30+00:00 INFO 129.174. update Downloading update file from https://s3-us-west-2.amazonaws.com/joom ... a2422ae31b.
2020-04-07T23:35:32+00:00 INFO 129.174. update File Joomla_3.9.16-Stable-Update_Package.zip downloaded.
2020-04-07T23:35:32+00:00 INFO 129.174. update Starting installation of new version.

I can tell it is downloading and unpacking. Why am I getting the login error?
Last edited by toivo on Wed Apr 08, 2020 1:28 am, edited 1 time in total.
Reason: mod note: split from someone else's topic - please create your own topics in the future!

 
User avatar
abernyte
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3837
Joined: Fri May 15, 2009 2:01 pm
Location: Écosse - Scozia - Escocia - Škotija -स्कॉटलैंड

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by abernyte » Wed Apr 08, 2020 7:56 am

Is this error showing when you are using the the Joomla update component? Ensure it is set to "write files directly".
What we obtain too cheap, we esteem too lightly…Thomas Paine

juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Unable to login to Joomla at all as administrator

Post by juggernautsei » Sun Apr 12, 2020 10:46 pm

I am new to Joomla. I just installed it for the first last week. I got through the setup and launch. No problem. I have been working on the configuration for the past week. I did an update that failed and I could no long login via Chrome. I tried Firefox and I could log in and life was good again. I did more configurations and the last thing that I set up was the SMTP. I got that working and logged off. The next day, I tried to register a new account. I logged off as an administrator and opened the registration page to enter a new user. The page reloaded with no indication that the new account was successful. I checked my admin email and there was no email of new account registration. I tried to log in as admin and the page accepts the login but just returns to the login screen like in these posts.

viewtopic.php?t=717423

Nothing in that post has helped. I have cleared the cache.

Forum Post Assistant (v1.5.0 (midden)) : 12th April 2020 wrote:
Problem Description :: wrote:Can Not log into, no error message just reloads login page
Log/Error Message :: wrote:2020-04-12T21:52:44+00:00 CRITICAL 66.249.64.38 error Uncaught \Throwable of type InvalidArgumentException thrown. Stack trace: #0 /var/www/html/marketplace/components/com_sppagebuilder/sppagebuilder.php(22): Joomla\CMS\MVC\Controller\BaseController::getInstance('Sppagebuilder') #1 /var/www/html/marketplace/libraries/src/Component/ComponentHelper.php(402): require_once('/var/www/html/m...') #2 /var/www/html/marketplace/libraries/src/Component/ComponentHelper.php(377): Joomla\CMS\Component\ComponentHelper::executeComponent('/var/www/html/m...') #3 /var/www/html/marketplace/libraries/src/Application/SiteApplication.php(194): Joomla\CMS\Component\ComponentHelper::renderComponent('com_sppagebuild...') #4 /var/www/html/marketplace/libraries/src/Application/SiteApplication.php(233): Joomla\CMS\Application\SiteApplication->dispatch() #5 /var/www/html/marketplace/libraries/src/Application/CMSApplication.php(196): Joomla\CMS\Application\SiteApplication->doExecute() #6 /var/www/html/marketplace/index.php(49): Joomla\CMS\Application\CMSApplication->execute()
Actions Taken To Resolve wrote:Tried all the suggestions on this page https://joomla.stackexchange.com/questi ... refreshing and all the suggestions on this page viewtopic.php?t=717423
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.8-Stable (Amani) 11-June-2019
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Writable (777) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: false | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 15 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: default | Site Debug: false | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.8: Yes | Database Supports J! 3.9.8: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.15.0-1063-aws | Technology: x86_64 | Web Server: Apache/2.4.29 (Ubuntu) | Encoding: gzip, deflate, br | System TMP Writable: Yes | Free Disk Space : 17.58 GiB |

PHP Configuration :: Version: 7.2.24-0ubuntu0.18.04.3 | PHP API: apache2handler | Session Path Writable: Yes | Display Errors: | Error Reporting: 1 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 30M | Max. POST Size: 30M | Max. Input Time: -1 | Max. Execution Time: 60 | Memory Limit: 512M

Database Configuration :: Version: 5.7.29-0ubuntu0.18.04.1 (Client:mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $) | Database Size: 36.03 MiB | #of Tables with config prefix: 184 | #of other Tables: 552
Detailed Environment :: wrote:PHP Extensions :: Core (7.2.24-0ubuntu0.18.04.3) | date (7.2.24-0ubuntu0.18.04.3) | libxml (7.2.24-0ubuntu0.18.04.3) | openssl (7.2.24-0ubuntu0.18.04.3) | pcre (7.2.24-0ubuntu0.18.04.3) | zlib (7.2.24-0ubuntu0.18.04.3) | filter (7.2.24-0ubuntu0.18.04.3) | hash (1.0) | Reflection (7.2.24-0ubuntu0.18.04.3) | SPL (7.2.24-0ubuntu0.18.04.3) | sodium (7.2.24-0ubuntu0.18.04.3) | session (7.2.24-0ubuntu0.18.04.3) | standard (7.2.24-0ubuntu0.18.04.3) | apache2handler () | intl (1.1.0) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $) | PDO (7.2.24-0ubuntu0.18.04.3) | xml (7.2.24-0ubuntu0.18.04.3) | bcmath (7.2.24-0ubuntu0.18.04.3) | bz2 (7.2.24-0ubuntu0.18.04.3) | calendar (7.2.24-0ubuntu0.18.04.3) | ctype (7.2.24-0ubuntu0.18.04.3) | curl (7.2.24-0ubuntu0.18.04.3) | dom (20031129) | mbstring (7.2.24-0ubuntu0.18.04.3) | fileinfo (1.0.5) | ftp (7.2.24-0ubuntu0.18.04.3) | gd (7.2.24-0ubuntu0.18.04.3) | gettext (7.2.24-0ubuntu0.18.04.3) | iconv (7.2.24-0ubuntu0.18.04.3) | json (1.6.0) | exif (7.2.24-0ubuntu0.18.04.3) | mysqli (7.2.24-0ubuntu0.18.04.3) | pdo_mysql (7.2.24-0ubuntu0.18.04.3) | Phar (2.0.2) | posix (7.2.24-0ubuntu0.18.04.3) | readline (7.2.24-0ubuntu0.18.04.3) | shmop (7.2.24-0ubuntu0.18.04.3) | SimpleXML (7.2.24-0ubuntu0.18.04.3) | sockets (7.2.24-0ubuntu0.18.04.3) | sysvmsg (7.2.24-0ubuntu0.18.04.3) | sysvsem (7.2.24-0ubuntu0.18.04.3) | sysvshm (7.2.24-0ubuntu0.18.04.3) | tokenizer (7.2.24-0ubuntu0.18.04.3) | wddx (7.2.24-0ubuntu0.18.04.3) | xmlreader (7.2.24-0ubuntu0.18.04.3) | xmlwriter (7.2.24-0ubuntu0.18.04.3) | xsl (7.2.24-0ubuntu0.18.04.3) | zip (1.15.4) | Zend OPcache (7.2.24-0ubuntu0.18.04.3) | Zend Engine (3.2.0) |
Potential Missing Extensions ::
Disabled Functions :: pcntl_alarm | pcntl_fork | pcntl_waitpid | pcntl_wait | pcntl_wifexited | pcntl_wifstopped | pcntl_wifsignaled | pcntl_wifcontinued | pcntl_wexitstatus | pcntl_wtermsig | pcntl_wstopsig | pcntl_signal | pcntl_signal_get_handler | pcntl_signal_dispatch | pcntl_get_last_error | pcntl_strerror | pcntl_sigprocmask | pcntl_sigwaitinfo | pcntl_sigtimedwait | pcntl_exec | pcntl_getpriority | pcntl_setpriority | pcntl_async_signals | |

Switch User Environment (Experimental) :: PHP CGI: No | Server SU: No | PHP SU: No | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe

Apache Modules :: core | mod_so | mod_watchdog | http_core | mod_log_config | mod_logio | mod_version | mod_unixd | mod_access_compat | mod_alias | mod_auth_basic | mod_authn_core | mod_authn_file | mod_authz_core | mod_authz_host | mod_authz_user | mod_autoindex | mod_deflate | mod_dir | mod_env | mod_filter | mod_mime | prefork | mod_negotiation | mod_php7 | mod_reqtimeout | mod_rewrite | mod_setenvif | mod_socache_shmcb | mod_ssl | mod_status | Apache/2.4.29 (Ubuntu) |
Potential Missing Modules :: mod_expires | mod_security | mod_evasive | mod_dosevasive | mod_qos | mod_userdir |
Folder Permissions :: wrote:Core Folders :: images/ (777) | components/ (777) | modules/ (777) | plugins/ (777) | language/ (777) | templates/ (777) | cache/ (777) | logs/ (777) | tmp/ (777) | administrator/components/ (777) | administrator/modules/ (777) | administrator/language/ (777) | administrator/templates/ (777) | administrator/logs/ (777) |

Elevated Permissions (First 10) :: templates/ (777) | templates/protostar/ (777) | templates/protostar/css/ (777) | templates/protostar/html/ (777) | templates/protostar/images/ (777) | templates/protostar/images/system/ (777) | templates/protostar/img/ (777) | templates/protostar/js/ (777) | templates/protostar/language/ (777) | templates/protostar/language/en-GB/ (777) |
Database Information :: wrote:Database statistics :: Uptime: 427630 | Threads: 1 | Questions: 3993261 | Slow queries: 0 | Opens: 45498 | Flush tables: 1 | Open tables: 2000 | Queries per second avg: 9.338 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_wrapper (3.0.0) 1 | com_mailto (3.0.0) 1 |
3rd Party::

Components :: ADMIN ::
Core :: com_contenthistory (3.2.0) 1 | com_plugins (3.0.0) 1 | com_installer (3.0.0) 1 | com_actionlogs (3.9.0) 1 | com_languages (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_admin (3.0.0) 1 | com_cpanel (3.0.0) 1 | com_tags (3.1.0) 1 | com_associations (3.7.0) 1 | com_modules (3.0.0) 1 | com_postinstall (3.2.0) 1 | com_menus (3.0.0) 1 | com_checkin (3.0.0) 1 | com_config (3.0.0) 1 | com_login (3.0.0) 1 | com_content (3.0.0) 1 | com_search (3.0.0) 1 | com_banners (3.0.0) 1 | com_messages (3.0.0) 1 | com_cache (3.0.0) 1 | com_ajax (3.2.0) 1 | com_media (3.0.0) 1 | com_categories (3.0.0) 1 | com_templates (3.0.0) 1 | com_redirect (3.0.0) 1 | com_privacy (3.9.0) 1 | com_finder (3.0.0) 1 | com_users (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_fields (3.7.0) 1 |
3rd Party:: com_sellaciousreporting (1.7.3) 1 | SP Page Builder (3.2.5) 1 | com_sellacious (1.7.3) 1 | com_sellaciousopc (1.7.3) 1 | com_sellacioustemplates (1.7.3) 1 | com_importer (1.7.3) 1 | com_sellaciousdelivery (1.7.3) 1 |

Modules :: SITE ::
Core :: mod_wrapper (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_articles_archive (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_languages (3.5.0) 1 | mod_whosonline (3.0.0) 1 | mod_login (3.0.0) 1 | mod_articles_category (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_search (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_stats (3.0.0) 1 |
3rd Party:: mod_sellacious_users (1.7.3) 1 | mod_sellacious_hyperlocal (1.7.3) 1 | mod_sellacious_finder_for_store (1.7.3) 1 | mod_sellacious_finder_for_category (1.7.3) 1 | mod_sellacious_recentlyviewedproduc (1.7.3) ? | mod_sellacious_bestsellingproducts (1.7.3) 1 | mod_sellacious_stores (1.7.3) 1 | mod_sellacious_toolbar (1.7.3) 1 | mod_sellacious_categories (1.7.3) 1 | mod_sellacious_cart (1.7.3) 1 | mod_sellacious_filters (1.7.3) 1 | mod_sellacious_contact (1.7.3) 1 | mod_sellacious_sellerproducts (1.7.3) 1 | mod_sellacious_specialcatsproducts (1.7.3) 1 | mod_sellacious_ewallet (1.7.3) 1 | mod_sellacious_products (1.7.3) 1 | mod_sellacious_finder (1.7.3) 1 | SP Page Builder (1.2) 1 | mod_sellacious_relatedproducts (1.7.3) 1 | mod_sellacious_latestproducts (1.7.3) 1 | mod_usercurrency (1.7.3) 1 |

Modules :: ADMIN ::
Core :: mod_feed (3.0.0) 1 | mod_version (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_title (3.0.0) 1 | mod_latest (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_stats_admin (3.0.0) 1 | mod_submenu (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_login (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_quickicon (3.0.0) 1 | mod_toolbar (3.0.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_sampledata (3.8.0) 0 | mod_status (3.0.0) 1 |
3rd Party:: mod_sppagebuilder_icons (1.0.2) 1 | mod_sppagebuilder_admin_menu (1.3) 1 |

Libraries ::
Core ::
3rd Party:: TCPDF (1.7.3) ? |

Plugins ::
Core :: plg_fields_user (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_content_fields (3.7.0) 1 | plg_content_vote (3.0.0) 1 | plg_content_loadmodule (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_emailcloak (3.0.0) 1 | plg_content_finder (3.0.0) 1 | plg_content_joomla (3.0.0) 1 | plg_content_pagenavigation (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_user_terms (3.9.0) 0 | plg_user_contactcreator (3.0.0) 0 | plg_user_joomla (3.0.0) 1 | plg_user_profile (3.0.0) 0 | plg_privacy_content (3.9.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_message (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_twofactorauth_totp (3.2.0) 0 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_system_stats (3.5.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_redirect (3.0.0) 0 | plg_system_sessiongc (3.8.6) 1 | plg_system_languagefilter (3.0.0) 0 | plg_system_logrotation (3.9.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_privacyconsent (3.9.0) 0 | plg_system_remember (3.0.0) 1 | plg_system_logout (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_log (3.0.0) 1 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 0 | plg_system_p3p (3.0.0) 0 | plg_system_sef (3.0.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_highlight (3.0.0) 1 | plg_finder_content (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_finder_tags (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_newsfeeds (3.0.0) 1 | plg_search_content (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_tags (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_extension_joomla (3.0.0) 1 | plg_authentication_cookie (3.0.0) 1 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_gmail (3.0.0) 0 | plg_captcha_recaptcha (3.4.0) 0 | plg_captcha_recaptcha_invisible (3.8) 0 | plg_installer_packageinstaller (3.6.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | plg_installer_webinstaller (2.0.1) 1 |
3rd Party:: Helix3 - Ajax (2.5.3) 1 | plg_content_sellaciousbuttons (1.7.3) 1 | plg_content_sellaciouscatspecs (2.2.0) 1 | plg_content_sellaciousproductquery (1.7.3) 1 | PLG_SELLACIOUS_USER (1.7.3) 1 | PLG_SELLACIOUS_FIELDTYPEFORMS (1.7.3) 1 | PLG_SELLACIOUS_ORDER (1.7.3) 1 | PLG_SELLACIOUS_MAILQUEUE (1.7.3) 1 | plg_sellaciouspayment_cod (1.7.3) 1 | plg_sellaciouspayment_ewallet (1.7.3) 1 | plg_sellaciouspayment_custom (1.7.3) 1 | plg_sellaciouspayment_paypalstandar (1.7.3) ? | PLG_SYSTEM_SELLACIOUSGOOGLEMARKUP (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSTEMPLATEORDER (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSPRODUCTNOTIFIC (1.7.3) ? | PLG_SYSTEM_SELLACIOUSCACHE (1.7.3) 1 | PLG_SYSTEM_SELLACIOUS (1.7.3) 1 | System - Helix3 Framework (2.5.6) 1 | PLG_SYSTEM_SELLACIOUSHYPERLOCAL (1.7.3) 1 | System - Sellacious Importer (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSREPORTSDELIVER (1.7.3) ? | plg_system_sellaciouscattemplates (2.1.7) 1 | PLG_SYSTEM_SELLACIOUSPRODUCTREDIREC (1.7.3) ? | PLG_SYSTEM_SELLACIOUSRECENT (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSFOREX (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSGST (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSUTM (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSFREESHIPPING (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSMAILER (1.7.3) 1 | PLG_SYSTEM_SELLACIOUSREPORTSCART (1.7.3) 1 | PLG_SELLACIOUSRULES_GEOLOCATION (1.7.3) 1 | PLG_SELLACIOUSRULES_AMOUNTFILTER (1.7.3) 1 | PLG_SELLACIOUSRULES_CLIENT (1.7.3) 1 | PLG_SELLACIOUSRULES_PRODUCT (1.7.3) 1 | plg_finder_sellaciousproduct (1.7.3) 1 | PLG_EDITORS_CKINLINEEDITOR4 (1.7.3) 1 | plg_editors_codemirror (5.40.0) 1 | PLG_EDITORS_CKEDITOR4 (1.7.3) 1 | plg_editors_tinymce (4.5.11) 1 |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) 1 | beez3 (3.1.0) 1 | squick (2.5.3) 1 |
Templates :: ADMIN :: isis (1.0) 1 | hathor (3.0.0) 1 |
Last edited by toivo on Sun Apr 12, 2020 11:23 pm, edited 2 times in total.
Reason: mod note: merged with the current topic

juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by juggernautsei » Sun Apr 12, 2020 11:08 pm

Yes, I am using the Joomla update component. I have just used the FPA tool and changed my folder settings. Soon as I can log in, I will try to run the update again.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12516
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Unable to login to Joomla at all as administrator

Post by toivo » Sun Apr 12, 2020 11:18 pm

It would be better to keep the current issue in the same topic, rather than create a new one if this issue is related to the same website.

The topic you followed belongs to Joomla 2.5 and any actions recommended may not have helped, on the contrary.

SP Page Builder 3.2.5 must be very old. The current version is 3.6.7.

The folder permissions should not be 777, which means world-writable, a security risk.
Toivo Talikka, Global Moderator

juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by juggernautsei » Mon Apr 13, 2020 1:07 am

I tried changing the folder permissions to 766 and the site stops working or anything other than 777. I tried 755 site stops functioning.

These are not related to me. Not being able to log in at all did not happen at the same time as the login error to upgrade Joomla. I could not find any documentation that tells me what the folder permission should be.

Thanks for the response.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12516
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by toivo » Mon Apr 13, 2020 1:34 am

wrote:I tried changing the folder permissions to 766 and the site stops working or anything other than 777. I tried 755 site stops functioning.
If that is the case, something is drastically wrong in the server configuration. You need to speak to your host.

The permissions should be Folders 755, files 644. The file configuration.php is write protected, 444.

Ref. https://docs.joomla.org/Verifying_permissions
Toivo Talikka, Global Moderator

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26930
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by Per Yngve Berg » Mon Apr 13, 2020 10:00 am

PHP API: apache2handler

That will give you File Owner/Permission issues. Use 'fcgi' or 'fpm-cgi'.

https://www.interserver.net/tips/kb/apa ... ntu-18-04/

juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by juggernautsei » Mon Apr 13, 2020 5:11 pm

I have fixed all my folder permissions. What worked is the combination of the 755 and the owner of the directory has to be www-data.

CORE FOLDERS PERMISSIONS CHECKS
MODE WRITABLE FOLDER GROUP OWNER
755 Yes images/ www-datawww-data
755Yescomponents/www-datawww-data
755Yesmodules/www-datawww-data
755Yesplugins/www-datawww-data
755Yeslanguage/www-datawww-data
755Yestemplates/www-datawww-data
755Yescache/www-datawww-data
755Yeslogs/www-datawww-data
755Yestmp/www-datawww-data
755Yesadministrator/components/www-datawww-data
755Yesadministrator/modules/www-datawww-data
755Yesadministrator/language/www-datawww-data
755Yesadministrator/templates/www-datawww-data
755Yesadministrator/logs/www-data

I still cannot log in. There is this critical error below in the log file.





2020-04-13T16:49:09+00:00 CRITICAL 129.174.255.151 error Uncaught \Throwable of type Exception thrown. Stack trace: #0 /var/www/html/marketplace/libraries/src/MVC/Controller/BaseController.php(621): Joomla\CMS\MVC\Controller\BaseController->getView('login', 'json', 'loginView', Array)
#1 /var/www/html/marketplace/sellacious/components/com_login/controller.php(42): Joomla\CMS\MVC\Controller\BaseController->display(false, NULL)
#2 /var/www/html/marketplace/libraries/src/MVC/Controller/BaseController.php(710): LoginController->display()
#3 /var/www/html/marketplace/sellacious/components/com_login/login.php(21): Joomla\CMS\MVC\Controller\BaseController->execute('')
#4 /var/www/html/marketplace/libraries/src/Component/ComponentHelper.php(402): require_once('/var/www/html/m...')
#5 /var/www/html/marketplace/libraries/src/Component/ComponentHelper.php(377): Joomla\CMS\Component\ComponentHelper::executeComponent('/var/www/html/m...')
#6 /var/www/html/marketplace/sellacious/includes/libraries/application.php(205): Joomla\CMS\Component\ComponentHelper::renderComponent('com_login')
#7 /var/www/html/marketplace/sellacious/includes/libraries/application.php(250): JApplicationSellacious->dispatch()
#8 /var/www/html/marketplace/libraries/src/Application/CMSApplication.php(196): JApplicationSellacious->doExecute()
#9 /var/www/html/marketplace/sellacious/index.php(43): Joomla\CMS\Application\CMSApplication->execute()

User avatar
abernyte
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3837
Joined: Fri May 15, 2009 2:01 pm
Location: Écosse - Scozia - Escocia - Škotija -स्कॉटलैंड

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by abernyte » Mon Apr 13, 2020 5:33 pm

Have you checked the Sellacious support forum as there seems to be an outstanding update issue to be fixed in the next release.
There errors are all related to the Sellacious component and not Joomla per se.
What we obtain too cheap, we esteem too lightly…Thomas Paine

juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by juggernautsei » Mon Apr 13, 2020 10:31 pm

I have a ticket in with Sellacious now. I am waiting for their response.

juggernautsei
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Apr 08, 2020 12:51 am

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by juggernautsei » Tue Apr 14, 2020 10:27 pm

Just to update, I ended up reinstalling and starting over. They could not help figure out what was wrong. They said it was a Joomla issue. On a side note. Updates work now.

Being new to Joomla and going through the set up twice. The configuration file is the most bothersome. Sellacious documentation does not say that the configuration file has to be created manually and placed in the webroot directory. It would have been nice to been told upfront what folders needed which permission for everything to run smoothly. This is just my hindsight opinion.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12516
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by toivo » Tue Apr 14, 2020 11:16 pm

juggernautsei wrote:The configuration file is the most bothersome. Sellacious documentation does not say that the configuration file has to be created manually and placed in the webroot directory.
That does not sound right. The standard installation of Joomla sets up the configuration file automatically.

Did you happen to install the Quickstart package from Sellacious? That explains a number of the issues, including version 3.9.8 of Joomla, which had been released two weeks before Sellacious 1.7.3 was published last year.

Quickstart packages are good for demonstrations but they are not recommended for live production sites.
Toivo Talikka, Global Moderator

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5771
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by AMurray » Wed Apr 15, 2020 9:30 am

Yes, there is no configuration file before you install Joomla; the process of installing it creates the configuration.php file.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5771
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Trying to update from 3.9.8 to 3.9.16, error - invalid login

Post by AMurray » Wed Apr 15, 2020 9:31 am

If you try to *reinstall* joomla where there's an existing site, it will only recognise JOomla is already installed. because there's an existing configuration file, but that' not what occurs by default, for a clean install.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

 

Post Reply

Return to “Migrating and Upgrading to Joomla! 3.x”