Problem with the menu on a multi-language site

General questions regarding the use of languages in Joomla! 3.x.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
fonsab
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Thu Sep 28, 2006 12:40 pm

Problem with the menu on a multi-language site

Post by fonsab » Fri Mar 26, 2021 10:31 am

Hi,

I am changing an existing website to a multi language site and have followed the https://docs.joomla.org/J3.x:Setup_a_Multilingual_Site description.

My problem is that only the 'home'-button from the main menu shows up on the place where the menu used to be. On the canvas menu however, the whole menu is showing up and correctly for every single language.

I have 4 languages, swedish (main language), norwegian, danish and finnish.
I have created 4 different menus, one for each language, with associations to the other menus.
The fifth menu (Main Menu) contains only the Home button.

I hope that my description is clear enough.
Can anybody tell me what I am missing?

Edsel

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19079
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problem with the menu on a multi-language site

Post by infograf768 » Fri Mar 26, 2021 10:38 am

Please use the multilingual status admin module modal display to check your settings
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27744
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Problem with the menu on a multi-language site

Post by Per Yngve Berg » Fri Mar 26, 2021 3:43 pm

How do you show the Menu in your template? Do you use a Module Position or custom code?
If the menu is set in the template style, you have to duplicate the style for each language.

fonsab
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Thu Sep 28, 2006 12:40 pm

Re: Problem with the menu on a multi-language site

Post by fonsab » Fri Mar 26, 2021 3:59 pm

Per Yngve Berg wrote:
Fri Mar 26, 2021 3:43 pm
How do you show the Menu in your template? Do you use a Module Position or custom code?
If the menu is set in the template style, you have to duplicate the style for each language.
I use a Module Position and I have duplicated the template for every language.

fonsab
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Thu Sep 28, 2006 12:40 pm

Re: Problem with the menu on a multi-language site

Post by fonsab » Fri Mar 26, 2021 4:07 pm

infograf768 wrote:
Fri Mar 26, 2021 10:38 am
Please use the multilingual status admin module modal display to check your settings
Thank you, I was not aware of its existence.

I enclose the Multilingual Status. One language (english) is not used for the site, only for administrator.
Screen Shot 03-26-21 at 05.03 PM.PNG
You do not have the required permissions to view the files attached to this post.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27744
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Problem with the menu on a multi-language site

Post by Per Yngve Berg » Fri Mar 26, 2021 4:11 pm

You need 4 Menu Modules, one for each Menu.

fonsab
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Thu Sep 28, 2006 12:40 pm

Re: Problem with the menu on a multi-language site

Post by fonsab » Tue Mar 30, 2021 5:54 am

Per Yngve Berg wrote:
Fri Mar 26, 2021 4:11 pm
You need 4 Menu Modules, one for each Menu.
Yes, I have 4 menu modules, one for every language.
Dansk
Norsk
Suomalinen
Svenska
Screen Shot 03-30-21 at 07.48 AM.PNG
The Main menus module is unpublished.
Screen Shot 03-30-21 at 07.53 AM.PNG
You do not have the required permissions to view the files attached to this post.

sokrates_mx5
Joomla! Explorer
Joomla! Explorer
Posts: 265
Joined: Tue Mar 24, 2009 12:30 pm

Re: Problem with the menu on a multi-language site

Post by sokrates_mx5 » Mon Apr 19, 2021 9:32 pm

fonsab wrote:
Tue Mar 30, 2021 5:54 am
The Main menus module is unpublished.
I believe the Main Menu also has to be published. That is how it looks like on my multi-lingual website, where the Main Menu only consist of one menu item, the Home Menu item.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19079
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problem with the menu on a multi-language site

Post by infograf768 » Tue Apr 20, 2021 8:13 am

Look at your menu items manager.

The Main menu home set to ALL languages should be published.

You did OK for the module part.
Screen Shot 2021-04-20 at 10.08.13.png
You do not have the required permissions to view the files attached to this post.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

sokrates_mx5
Joomla! Explorer
Joomla! Explorer
Posts: 265
Joined: Tue Mar 24, 2009 12:30 pm

Re: Problem with the menu on a multi-language site

Post by sokrates_mx5 » Tue Apr 20, 2021 11:14 am

infograf768 wrote:
Tue Apr 20, 2021 8:13 am
The Main menu home set to ALL languages should be published.
I can see at your screen shot that you also have published Hidden Categories for each language. This is not done on my multi-lingual sites, there is only the Menu Home published that is set to ALL languages. Do you mind telling the reason why the Categories are published as hidden?

I've got problem with menus pointing to the same category, but where further selection is made by Tags.

viewtopic.php?f=728&t=985639

Maybe this issue could be caused by not have published the Categories of each language as hidden.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19079
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problem with the menu on a multi-language site

Post by infograf768 » Tue Apr 20, 2021 3:02 pm

My hidden list all categories menu item has nothing to do with the issue at stake.
We use this to make sure we always get a clean url when loading an article, wherever from.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

sokrates_mx5
Joomla! Explorer
Joomla! Explorer
Posts: 265
Joined: Tue Mar 24, 2009 12:30 pm

Re: Problem with the menu on a multi-language site

Post by sokrates_mx5 » Thu Apr 22, 2021 10:18 pm

infograf768 wrote:
Tue Apr 20, 2021 3:02 pm
My hidden list all categories menu item has nothing to do with the issue at stake.
We use this to make sure we always get a clean url when loading an article, wherever from.
Thanks for the clarification.


Post Reply

Return to “Language - Joomla! 3.x”