Bilingual site 404: error on homepage of 1 language

General questions regarding the use of languages in Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Sun Nov 14, 2021 11:04 am

Hi,

I get a 404 error on the homepage of a particular language (ba) in a bilingual site. Other language (en).

I don't see no error in the multilingual status administrator module...

When I turn off SEF in Global Configuration, there is NO 404 error, and link is:


...index.php?option=com_content&view=category&layout=theme3520:category&id=2&Itemid=101&lang=bs


I can send you superuser access to the backend of the site to check it out.

Best regards.
Adi

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28301
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Bilingual site 404: error on homepage of 1 language

Post by Per Yngve Berg » Sun Nov 14, 2021 11:42 am

How is the Layout reflected in the SEF URL?

User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Re: Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Mon Nov 15, 2021 4:38 am

Hi @Per Yngve Berg

I don't undenrstand your question clearly.

When SEF is set to Yes in Global configuration, URL of my website is:

mywebsite.com/index.php

and Layout of my homepage is fine, except that I see error 404 on top of my homepage.

When SEF is set to Yes, URL of my website is:

...index.php?option=com_content&view=category&layout=theme3520:category&id=2&Itemid=101&lang=bs

and Layout of my page is fine, and there is no error 404..

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13800
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Bilingual site 404: error on homepage of 1 language

Post by toivo » Mon Nov 15, 2021 5:23 am

Is your website using the latest version of Joomla 3.x, 3.10.3?

adi_2009 wrote:
Mon Nov 15, 2021 4:38 am
When SEF is set to Yes in Global configuration, URL of my website is:

mywebsite.com/index.php
Set also the option 'Use URL Rewriting' in Global Configuration. Assuming that your web server is Apache, check that the main Joomla folder has the file .htaccess, which was released as htaccess.txt in the latest version of Joomla. Now the string index.php will disappear from the links and the Search Engine Friendly (SEF) URLs will work correctly.
Toivo Talikka, Global Moderator

User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Re: Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Mon Nov 15, 2021 6:23 pm

Hi @toivo,

I use Joomla! 3.9.4 Stable

My issue is not URL writing. Main issue is that I can't disable 404 error page on my main Homepage.

I have managed to disable error 404 page *only* by turning SEF (Search user friendly) in Global configuration, but that is not right solution for me..

Can you help me figure out this?

BR.
Adi

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13800
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Bilingual site 404: error on homepage of 1 language

Post by toivo » Mon Nov 15, 2021 9:02 pm

adi_2009 wrote:
Mon Nov 15, 2021 6:23 pm
I use Joomla! 3.9.4 Stable
Any particular reason why Joomla has not been updated in the past 2.5 years? Outdated third party extensions perhaps?

adi_2009 wrote:
Mon Nov 15, 2021 6:23 pm
Main issue is that I can't disable 404 error page on my main Homepage.
Check Home column of the main menu. Does the menu item flagged as Default by the yellow star, still exist?

What is the URL of the website?

adi_2009 wrote:
Mon Nov 15, 2021 6:23 pm
My issue is not URL writing.
Search Engine Friendly (SEF) links are also user friendly. Non-SEF links look messy and are more difficult to maintain. A small effort can pay off by making the website easier to use, which is the reason behind the earlier advice:
toivo wrote:
Mon Nov 15, 2021 5:23 am
Set also the option 'Use URL Rewriting' in Global Configuration. Assuming that your web server is Apache, check that the main Joomla folder has the file .htaccess, which was released as htaccess.txt in the latest version of Joomla. Now the string index.php will disappear from the links and the Search Engine Friendly (SEF) URLs will work correctly.
Toivo Talikka, Global Moderator

User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Re: Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Tue Nov 16, 2021 5:40 pm

Hi @toivo,
Check Home column of the main menu. Does the menu item flagged as Default by the yellow star, still exist?
Yes, the menu item (Home) flagged as Default by the yellow star still exist.
What is the URL of the website?
I have send you URL and backend access data via pm.

BR.
Adi

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13800
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Bilingual site 404: error on homepage of 1 language

Post by toivo » Tue Nov 16, 2021 8:39 pm

The Joomla site seems to be currently hosted in a subfolder. Enter the URL with the subfolder as path into the variable $live_site in the file configuration.php, as shown in point 3 of the tutorial Moving the site among directories/subdirectories.

Refer to points 4 and 5 of the tutorial, check the .htaccess file in the main folder of this website and also any redirections in the cPanel provided by the host as well.
Toivo Talikka, Global Moderator

User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Re: Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Sun Nov 21, 2021 6:24 am

Hi toivo,

I have made detail checks in the meantime, please see answer bellow:

toivo wrote:
Tue Nov 16, 2021 8:39 pm
The Joomla site seems to be currently hosted in a subfolder. Enter the URL with the subfolder as path into the variable $live_site in the file configuration.php, as shown in point 3 of the tutorial Moving the site among directories/subdirectories.
Turorial notes that "The $live_site variable rarely needs to be given a value. But if it was given a value during installation then edit that path as well." Still, I tried givinig it value "mywebsite.com/subfolder" and error is still visible on homepage, and my other menu items show 404 error on whole page. Now, $live_site = ''; and I only have 404 error on top of my homepage.

Refer to points 4 and 5 of the tutorial, check the .htaccess file in the main folder of this website and also any redirections in the cPanel provided by the host as well.
Point 4 of tutorial - this is content of my htaccesss.txt

Code: Select all

##
# @package    Joomla
# @copyright  Copyright (C) 2005 - 2019 Open Source Matters. All rights reserved.
# @license    GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line 'Options +FollowSymLinks' may cause problems with some server configurations.
# It is required for the use of mod_rewrite, but it may have already been set by your
# server administrator in a way that disallows changing it in this .htaccess file.
# If using it causes your site to produce an error, comment it out (add # to the
# beginning of the line), reload your site in your browser and test your sef urls. If
# they work, then it has been set by your server administrator and you do not need to
# set it here.
##

## No directory listings
<IfModule autoindex>
  IndexIgnore *
</IfModule>

## Suppress mime type detection in browsers for unknown types
<IfModule mod_headers.c>
Header always set X-Content-Type-Options "nosniff"
</IfModule>

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site then comment out the operations listed
# below by adding a # to the beginning of the line.
# This attempts to block the most common type of exploit `attempts` on Joomla!
#
# Block any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root home page
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment the following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
My htaccess never contained URL of my website, so I don't see need to change anything?
5. Verify that no redirect orders to the old subdirectory are in place in your hosting control panel.
Checked this - all fine.


My front homepage is without 404 error ONLY when I set SEF is set to No.

Then URL of my website looks messy:

...index.php?option=com_content&view=category&layout=theme3520:category&id=2&Itemid=101&lang=bs,

and that is not right solution for me..

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28301
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Bilingual site 404: error on homepage of 1 language

Post by Per Yngve Berg » Sun Nov 21, 2021 10:18 am

When a 404 is only showing in a part of the page, it's probably a module failing an Ajax Call.

User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Re: Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Sun Nov 21, 2021 2:40 pm

Hi Per Yngve Berg,

How can I detect whic module is failing an Ajax Call?

I have send you pm with URL, I would appreciate if you could take a look.

Thank you.

BR.
Adi

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28301
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Bilingual site 404: error on homepage of 1 language

Post by Per Yngve Berg » Sun Nov 21, 2021 9:35 pm

It's not a module. It is the content area.

index.php?option=com_content&view=category&layout=theme3520:category&id=2&Itemid=101&lang=bs

If you leave out the "layout", you got a 404.

index.php?option=com_content&view=category&id=2&Itemid=101&lang=bs

User avatar
adi_2009
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Sun Apr 12, 2009 8:46 pm

Re: Bilingual site 404: error on homepage of 1 language

Post by adi_2009 » Mon Nov 22, 2021 4:26 am

Per Yngve Berg wrote:
Sun Nov 21, 2021 9:35 pm

If you leave out the "layout", you got a 404.

index.php?option=com_content&view=category&id=2&Itemid=101&lang=bs
I tried this link, but I don't get error 404.

I have send you access data for backend via pm, I would appreciate if could take a look.

Thanks.
Adi


Post Reply

Return to “Language - Joomla! 3.x”