Cannot Publish Content Language

General questions regarding the use of languages in Joomla! 3.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Xrispeters
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Jan 01, 2023 9:53 am

Cannot Publish Content Language

Post by Xrispeters » Sun Jan 01, 2023 4:31 pm

I have more or less succesfully created a multi language site, amongst others with information which I found on this forum. But now I am stuck, and I have not been able to find a solution

The eproblem is that wwo of the three languages are working up correctly the third one is not, even though I installed and activated them in teh same way.

When I check the "Multilingual Status", I see the following message:

"Warning A Default Home page is assigned to the nl-NL Content Language although a Site Language for this Content Language is not installed or published AND/OR the Content Language is not published."

In the Content Language tab, the content language is marked as not published, but when I tried doing that nothing happened. I did notice that in the content language details for Dutch, information is missing. I tried adding that information but could not save it due to the error message in the attached picture.

I thought about deleting and re-installing Dutch as Site and Content-language but I did not find a way to do that.

I am at a loss what is wrong and would appreciate if someone has suggestions hwo to fix this.
You do not have the required permissions to view the files attached to this post.
Last edited by Xrispeters on Sun Jan 01, 2023 6:19 pm, edited 1 time in total.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 42364
Joined: Sat Apr 05, 2008 9:58 pm

Re: Cannot Publish

Post by Webdongle » Sun Jan 01, 2023 4:40 pm

Welcome
Extensions >>> Manage >>> Manage ... sort ID descending
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 29644
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Cannot Publish

Post by Per Yngve Berg » Sun Jan 01, 2023 5:39 pm

Have you checked that NL is not in the Trash Can?

Xrispeters
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Jan 01, 2023 9:53 am

Re: Cannot Publish Content Language

Post by Xrispeters » Sun Jan 01, 2023 7:46 pm

Hi Webdongle,

thanks, this did not solve my problem, but at least I know where to de-install languages.

The problem remains that the content language (nl-NL) is still there and can not be deleted or unpublished.

Chris

Xrispeters
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Jan 01, 2023 9:53 am

Re: Cannot Publish Content Language

Post by Xrispeters » Sun Jan 01, 2023 7:47 pm

Yngve,

I checked this as well, but it is just unpublished and not in the trash

Chris

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 29644
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Cannot Publish Content Language

Post by Per Yngve Berg » Sun Jan 01, 2023 8:11 pm

Can you Publish it by clicking on the publish icon in the list?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 42364
Joined: Sat Apr 05, 2008 9:58 pm

Re: Cannot Publish Content Language

Post by Webdongle » Sun Jan 01, 2023 8:15 pm

In Extensions >>> Manage >>> Manage ... you should be able to publish, unpublish and uninstall. Are you telling us that you are unable to do that on your site?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

Xrispeters
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Jan 01, 2023 9:53 am

Re: Cannot Publish Content Language

Post by Xrispeters » Sun Jan 01, 2023 8:30 pm

OK, so I have set the published field in the database to 1 (trough phpMyAdmin), that fixes this problem; something I was not able to do through the UI (for this one language). But I can still not edit any fields in that way. I have the feeling that the same language is defined twice or something similar, bt I cannot find it anywhere.

Xrispeters
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Jan 01, 2023 9:53 am

Re: Cannot Publish Content Language

Post by Xrispeters » Sun Jan 01, 2023 8:55 pm

Hi Webdongle, Yngvem

correct, I am not able to publish this one language through the UI. I can also not edit the data (like Title, Title Native etc) though the edit pop-up. What is more the input fields are not populated, even though the data is there in the database (and I can change it directly in the database) .

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 42364
Joined: Sat Apr 05, 2008 9:58 pm

Re: Cannot Publish Content Language

Post by Webdongle » Sun Jan 01, 2023 10:08 pm

Then enable it in the database. Although there is something wrong if when in Extensions >>> Manage >>> Manage ... you are not able to publish, unpublish or uninstall. I Installed the language then used Extensions >>> Manage >>> Manage ... to uninstall it.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".


Post Reply

Return to “Language - Joomla! 3.x”