3.4 version Menu Item Alias not working

General questions regarding the use of languages in Joomla! 3.x.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
iflash
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri May 04, 2007 1:01 am

3.4 version Menu Item Alias not working

Post by iflash » Mon Mar 02, 2015 5:58 am

To check the bug (please correct me if there is no bug)
Step 1. Create a multilingual site.
Step 2. Add two articles, Spanish article and English article
Step 3. Add their Menu Links.
Step 4. Set "Search Engine Friendly URLs" to No
Step 5. Create a Menu item Alias
Step 6. Test the Menu item Alias, will not work.

The link for the original article is:
index.php?option=com_content&view=article&id=6&Itemid=105&lang=en
The link for the Menu item Alias is:
index.php?Itemid=105&option=com_content&lang=en

and will show some kind of category list

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18725
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: 3.4 version Menu Item Alias not working

Post by infograf768 » Mon Mar 02, 2015 6:18 am

I confirm the issue.
Can you create a tracker on issues.joomla.org ?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18725
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: 3.4 version Menu Item Alias not working

Post by infograf768 » Mon Mar 02, 2015 5:16 pm

Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

iflash
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri May 04, 2007 1:01 am

Re: 3.4 version Menu Item Alias not working

Post by iflash » Tue Mar 03, 2015 6:49 pm

Thanks a lot.

mrfisho
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Wed Dec 12, 2007 7:53 pm

Re: 3.4 version Menu Item Alias not working

Post by mrfisho » Sun Jan 24, 2016 4:19 am

I have the same issue but cannot understand the github ?

Mick

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18725
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: 3.4 version Menu Item Alias not working

Post by infograf768 » Sun Jan 24, 2016 6:02 am

This has been solved since J 3.4.1
Please update to 3.4.8
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

mrfisho
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Wed Dec 12, 2007 7:53 pm

Re: 3.4 version Menu Item Alias not working

Post by mrfisho » Sun Jan 24, 2016 6:06 am

I am using the latest .. think it is a Rokettheme Problem .. no idea yet


Locked

Return to “Language - Joomla! 3.x”