Problem in language switching, "en" lang. not loaded / 3.8.2 core module

General questions regarding the use of languages in Joomla! 3.x.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
zasha
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Nov 15, 2017 10:03 am

Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby zasha » Wed Nov 15, 2017 10:11 am

Dear All,

my site (http://www.tasty.hu) is running since several years. Last weekend I updateted from 3.8.1 to 3.8.2. Then I updatetd the template too for a further version. After that I had problem with language swither core module. When I click on the EN flag the english site is not loaded. The screen will be empty, the link is changing to .../en and everything stopped. In several case also the backend freeze. Close the windows, open again, backend works again, frontend still not, also when I just want to open the defult HU version, the link remains EN in the browser. Set offline, then online and HU works again.
In HU the site works well, in EN nothing. Before the update both language worked well.

I have everthing separate: articles, categories, menus, modules, templates too. Plugins (code and filter) enables. Currently no cache is allowed on the complete site. I use JCH also, that is disabled right now.

Do you have idea where could be the problem? Pls advise.

Thanks,
Ákos

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18615
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby infograf768 » Wed Nov 15, 2017 12:39 pm

I see a problem on your /en/ pages
Screen Shot 2017-11-15 at 13.33.40.png
You do not have the required permissions to view the files attached to this post.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

zasha
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Nov 15, 2017 10:03 am

Re: Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby zasha » Thu Nov 16, 2017 12:09 pm

well, I'm not able to solve it. I asked support from the template designer, but the response is still pending.

zasha
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Nov 15, 2017 10:03 am

Re: Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby zasha » Fri Nov 17, 2017 9:17 am

so, I've got the answer and they told I've various javascript related issue and none of them being directly related to their products (template and extensions).

I uninstalled almost all the external extensions, only the template related remained. Problem still exist.
A test was run one of the page speed analyse tool, of course it found many issue, but since the google webmaster tool found also many issue with 503, I'm thinking on the following could be the cause: Browser caching not enabled from these domains called from this page. (attachment)

What do you think? Why only when I change to EN?
You do not have the required permissions to view the files attached to this post.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18615
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby infograf768 » Fri Nov 17, 2017 9:47 am

Error: Script terminated by timeout at:
favprocess_mobile_menu@http://www.tasty.hu/templates/favourite/js/favth-scripts.js:124:16
@http://www.tasty.hu/templates/favourite/js/favth-scripts.js:33:5
favth-scripts.js:124:16
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18615
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby infograf768 » Fri Nov 17, 2017 9:49 am

Therefore, please test your site with the default protostar template and make sure when you test that all system plugins related to your specific template are disabled.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

zasha
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Nov 15, 2017 10:03 am

Re: Problem in language switching, "en" lang. not loaded / 3.8.2 core module

Postby zasha » Fri Nov 17, 2017 11:16 am

You are right. The language switching works well everywhere on Protostar even when the specific template extension are not disabled.
So, there should be an issue in the specific template/extensions.


Return to “Language - Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 3 guests