Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

General questions regarding the use of languages in Joomla! 3.x.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Tue Feb 20, 2018 8:55 am

Goog morning,
My site uses Joomla 3.7.3 version.
It has english and bulgarian version.
1 month ago wrong href lang implementation
error message was received. I checked the
languages and it seems that I have Bulgarian
language pack version 2.5.2.1 but using Joomla
3.7.3. Is ir possible if this could be the problem
sudden downgrade in language pack, because I
can see "Language pack doesn`t match Joomla
version, some strings are missing and will be
displayed in English" error is causing every
url from the BG version where it has cyrillic to
be desplayed with strange symbols like %, letters
and numbers not the words in cyrillic but some
combination code of symbols and numbers or letters.
I already tried the "Reinstall" language but nothing
changed, I have tried the language debbuger which
does not show alerts, but I also this is some kind of
bug because there was nothing changed or done on
the site during the period this thing took place..
Any suggestion >? will be highly appreciated!
As the newest member in the community, excuse my
lack of experience if this article`s place is in another
part of the forum .
Kind Regards!

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Tue Feb 20, 2018 9:11 am

This is the last Bulgarian pack
http://joomlacode.org/gf/download/frsre ... .6.5v2.zip
that you could use by direct install via extensions->install. It may miss some strings but it is not very important.

If the site is set to use Unicode Aliases (Setting in Global Configuration), then the urls are percent-encoded and may show such when copied/pasted from Firefox bar. They should show correctly with Unicode characters though in the browser bar.

This has nothing to do with the language pack.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Tue Feb 20, 2018 9:46 am

Thank You very much for the quick reply!
Yes, they show correctly in the browser bar,
but if You see the page source code the
cyriclic urls are displayed in strange codes,
I thought this Language pack not matching
Joomla version could be the problem because,
noone have changed nothing in the GLobal
Configuration setting, this error appeared
suddenly and made a lot of not indexed
articles trouble for me, without playing
with the setting in global configuration.

for example: url /bg/автомобилен-транспорт
in the source code is looking like : /bg/%D0%B0%D0%B2%D1%82%D0%BE%D0%BC%D0%BE%D0%B1%D0%B8%D0%BB%D0%B5%D0%BD-%D1%82%D1%80%D0%B0%D0%BD%D1%81%D0%BF%D0%BE%D1%80%D1%82
doestn`t even show any cyrillic letters at all..

It looks like I have the same language
version installed, but will try with the
link and way You suggested.
Thanks again!

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Tue Feb 20, 2018 9:50 am

P.S Yes, Global Configuration Setting Unicode Aliases is Enabled.

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Tue Feb 20, 2018 12:14 pm

No success with reinstall language again..

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Tue Feb 20, 2018 3:43 pm

Any suggestions >? Why can urls like :"/bg/автомобилен-транспорт" be displayed in the page source code like:
/bg/%D0%B0%D0%B2%D1%82%D0%BE%D0%BC%D0%BE%D0%B1%D0%B8%D0%BB%D0%B5%D0%BD-%D1%82%D1%80%D0%B0%D0%BD%D1%81%D0%BF%D0%BE%D1%80%D1%82 " Every url alias which contains cyrillic letters is transformed in code
looking similar to this. Why is this happening if it is not because of the Some strings may be missing and displayed in English.." Pack does not match Joomla version error.. I keep investigating but the signs are pointing to this issue,
because I have also found that search engine can`t read these /%D0%B0%D0%B2%D1%82%D0%BE%D0%BC%D0%BE%D0%B1%D0%B8%D0%BB%D0%B5%D0%BD-%D1%82%D1%80%D0%B0%D0%BD%D1%81%D0%BF%D0%BE%D1%80%D1%82 codes and is automatically picking the corresponding EN alias version. This is the result of "some strings ..will be displayed in English" message. For example /bg/автомобилен транспорт can not be read as bg//%D0%B0%D0%B2%D1%82%D0%BE%D0%BC%D0%BE%D0%B1%D0%B8%D0%BB%D0%B5%D0%BD-%D1%82%D1%80%D0%B0%D0%BD%D1%81%D0%BF%D0%BE%D1%80%D1%82 and the bot decides to put in the /bg/ url , the one from the en/ version which results in url: /bg/road-transport which has never been created or existed , correct ones are: bg/автомобилен-транспорт;/en/road-transport, but because the cyrillyc alias is presented as code with "% 0 B" not cyrillic letters, the bot decides
that the urls is combination of the bg/english version/ : bg/road-transport and for all other cyrilic url pages too.
This results in all of the pages with cyrillic in the url to not be found - 404.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Wed Feb 21, 2018 7:27 am

Again: this has nothing to do with the language pack at all!!

Search engines DO perfectly understand percent encodings.
For example source will show
<base href="http://localhost:8888/testwindows/trunkgitnew/mk/%D0%BA%D0%BE%D1%87%D0%BE-%D1%80%D0%B0%D1%86%D0%B8%D0%BD.html">

And any modern browser bar will show

Code: Select all

http://localhost:8888/testwindows/trunkgitnew/mk/кочо-рацин.html


If you copy paste the percentencoded url in a browser bar, it will correctly display the page and you will NOT get a 404.

Basically, if your site is set as a multilingual site (core functionnality) and you find such errors, it means you made some mistakes in your settings.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Wed Feb 21, 2018 7:56 am

First display the multilingual status module to see if you have some obvious mistakes.
viewtopic.php?f=711&t=958595#p3511885
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Wed Feb 21, 2018 8:36 am

Good Morning,
Thank You very much for the explanation.
This is a multilingual site, but the point is that this issue started itself, there was nothing changed and noone made changes in the period. This strange urls are a major problem all the pages in sitemap suddenly without changing settings have dropped - only 2 from 43 pages indexed.
I believe this is connected with the error message from the traslation language (BG) because all the
urls that are displayed as /%D0%B0%D0%B2%D1% have been normally displayed before the issue with the wrong hreflang implementation and "language pack not match joomla version error popped up".

Anyway, I tried the multilingual status with a result :
Status
Language Filter Plugin
Enabled

Published Language Switcher Modules.
1

Published Default Home pages (including 1 assigned to language "All").
3
Language

Published Site Languages en-GB GYes bg-BG GYes

Published Content Languages en-GB GYes bg-BG GYes

Published Default Home pages en-GB GYes bg-BG GYes

seems nothing is wrong, I tried the language debbuger:
Red line in the first paragraph: "Load the errors in language files":

files: JROOT/language/en-GB/en-GB.tpl_ja_company.ini : error(s) in line(s) 129, 130

but when You open that en-GB.tpl_ja_company.ini 129, 130 line there is no important error
on that line:

129 line: T3_TPL_DESC_3 ="JA Company Template – Joomla template for company website and can be used for Business website. The template also integrates JoomlArt featured product – JA Joomla Page Builder to help you create stunning landing pages (multiple pre-made landing pages will be included in demo and quickstart), it is built with T3 framework and supports EasyBlog component.
130 line: JA Company is built with T3 Framework, it is easy to customize based on powerful admin control panel with built-in functionalities: visual layout configuration, responsive layout configuration, megamenu builder, optimization, etc."
Second paragraph: Loaded language files:
**Loaded** : JROOT/language/bg-BG/bg-BG.ini
**Loaded** : JROOT/language/bg-BG/bg-BG.lib_joomla.ini
**Not Loaded** : JROOT/administrator/language/bg-BG/bg-BG.plg_system_shlib.ini
**Not Loaded** : JROOT/plugins/system/shlib/language/bg-BG/bg-BG.plg_system_shlib.ini
**Loaded** : JROOT/administrator/language/bg-BG/bg-BG.plg_system_updatenotification.ini
**Not Loaded** : JROOT/administrator/language/bg-BG/bg-BG.plg_system_fields.ini
**Not Loaded** : JROOT/plugins/system/fields/language/bg-BG/bg-BG.plg_system_fields.ini
**Loaded** : JROOT/administrator/language/bg-BG/bg-BG.plg_system_logout.ini
**Not Loaded** : JROOT/administrator/language/bg-BG/bg-BG.plg_system_t3.ini
**Not Loaded** : JROOT/plugins/system/t3/language/bg-BG/bg-BG.plg_system_t3.ini
**Not Loaded** : JROOT/language/bg-BG/bg-BG.tpl_ja_company.ini
**Not Loaded** : JROOT/templates/ja_company/language/bg-BG/bg-BG.tpl_ja_company.ini
**Loaded** : JROOT/language/en-GB/en-GB.tpl_ja_company.ini
**Loaded** : JROOT/language/bg-BG/bg-BG.com_content.ini
**Loaded** : JROOT/language/bg-BG/bg-BG.mod_custom.ini
**Loaded** : JROOT/language/bg-BG/bg-BG.mod_menu.ini
**Not Loaded** : JROOT/language/bg-BG/bg-BG.mod_acymailing.ini
**Not Loaded** : JROOT/modules/mod_acymailing/language/bg-BG/bg-BG.mod_acymailing.ini
**Loaded** : JROOT/language/bg-BG/bg-BG.com_acymailing.ini
**Not Loaded** : JROOT/language/bg-BG/bg-BG.com_acymailing_custom.ini
**Not Loaded** : JROOT/language/bg-BG/bg-BG.mod_jamasthead.ini
**Not Loaded** : JROOT/modules/mod_jamasthead/language/bg-BG/bg-BG.mod_jamasthead.ini
**Loaded** : JROOT/language/bg-BG/bg-BG.mod_languages.ini
**Loaded** : JROOT/administrator/language/bg-BG/bg-BG.plg_system_debug.ini
and Third Paragraph: Line without translation: - Nothing to show.

Please, look at these results and share Your thoughts if somebody could help.
I don`t have that extra 250euro asked now, for paying about resolving this bug or error.
Next time I order building a website I will ask about that so needed guarantee period.
With Respect
Thanks again!

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Wed Feb 21, 2018 8:51 am

Hi again, Yes , I know that if I type the percentage code in the browser I will get to the page
but the search engine is the problem It is automatically trying to reach page from the bulgarian version
/bg/ + the english alias, it is deciding to do this and results in 404 in the search console
For example there are pages /bg/автомобилен-транспорт/
/en/road-transport/
but (maybe because ..some strings may be missing and will be displayed in English"):
the robot decides not to read cyrilic letter, not to read the percentage codes too
and is automatically crawling a link combined from /bg/+en alias /link which does not exist and is true-404.
for example /bg/road-transport/ which never existed. Correct are /bg/автомобилен-транспорт & /en/road-transport.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Wed Feb 21, 2018 9:29 am

Code: Select all

but (maybe because ..some strings may be missing and will be displayed in English"):

NO and NO and NO again. The strings have nothing to do with urls.

Concerning the debug error

Code: Select all

129 line: T3_TPL_DESC_3 ="JA Company Template – Joomla template for company website and can be used for Business website. The template also integrates JoomlArt featured product – JA Joomla Page Builder to help you create stunning landing pages (multiple pre-made landing pages will be included in demo and quickstart), it is built with T3 framework and supports EasyBlog component.
130 line: JA Company is built with T3 Framework, it is easy to customize based on powerful admin control panel with built-in functionalities: visual layout configuration, responsive layout configuration, megamenu builder, optimization, etc."


The return after "EasyBlog component." should not be there which creates a debug error.

Do some of your menu items or links show errors when clicked on frontend?

If you get errors, then it is one of your extensions that does.
Do you use any SEF extension?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Wed Feb 21, 2018 9:39 am

For you to understand fully, look at wikipedia in Russian

Code: Select all

https://ru.wikipedia.org/wiki/%D0%9C%D0%B0%D1%80%D1%82%D1%8B%D1%89%D0%B5%D0%BD%D0%BA%D0%BE,_%D0%9C%D0%B8%D1%85%D0%B0%D0%B8%D0%BB_%D0%93%D0%B0%D0%B2%D1%80%D0%B8%D0%BB%D0%BE%D0%B2%D0%B8%D1%87

URL in bar is

Code: Select all

https://ru.wikipedia.org/wiki/Мартыщенко,_Михаил_Гаврилович


Now look at source of that page:

Code: Select all

<link rel="canonical" href="https://ru.wikipedia.org/wiki/%D0%9C%D0%B0%D1%80%D1%82%D1%8B%D1%89%D0%B5%D0%BD%D0%BA%D0%BE,_%D0%9C%D0%B8%D1%85%D0%B0%D0%B8%D0%BB_%D0%93%D0%B0%D0%B2%D1%80%D0%B8%D0%BB%D0%BE%D0%B2%D0%B8%D1%87"/>


I think that one cannot consider wikipedia as badly coded or do you?
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Wed Feb 21, 2018 10:17 am

Hi again,
Oh, I understand, I just didn`t realise that it could be one of the extensions,
I never got errors from menu or link. All working fine.

I paid for them extensions last year but is was never explained to me how to
use those paid extensions .
For SEO we have Jsitemap PRO and also sh404SEF,
sh404SEF is not even configured.In extensions manager I also see System-SEF
plugin enabled.
There are settings like SEO stats enabled-ON, validation type - standard,
Indexing status analysis-Yes, Parse Urls - Yes, append site domain - yes....
in Jsitemap Pro but there was nothing changed since installation, to have result
in such links displayed in the source code.
The extensions ask for update. But the specialist who installed it are asking
money to make the update. I thought I paid a one year of use no matter the
version - but now, after 7 months of usage they will update such applications
only if I pay.In the way of thinking - there is possibility that the bug is coming
because of not updated extensions. I have read that I need the extensions updated
before the Joomla version update, but now I will have to update the Joomla version
without updating the extensions first, because of the paid service.
Thank You very much for the help!
I will try investigating the extensions + that "The return after "EasyBlog component."
should not be there which creates a debug error." You suggested!
Many thanks again!
Best Wishes!

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Thu Feb 22, 2018 2:27 pm

Good afternoon.
I have started investigating from the beginning: The message with error from google: Wrong hreflang implementation.
I still can`t understand why this happened and why it is wrong, because no changes were made since the web development company gave us the login details. But I already ran a hreflang tester tool and it gives me the
following result: I am attaching the screenshot with the problem from where it started. Google still shows that.
Please, if someone has an idea - share Your experience with this problems.

wrong hreflang implementation.jpg


Thanks in advance.
You do not have the required permissions to view the files attached to this post.

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Sun Mar 04, 2018 10:50 am

What a precious "help" the forums of joomla offer.. thank You very much everyone expert in this site!

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 24402
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby Per Yngve Berg » Sun Mar 04, 2018 3:58 pm

Clinking the BG flag does not take you to the same article in Bulgarian. Check the associations of the English and Bulgarian Articles of the same topic.


PS. Update your Joomla. The current version is 3.8.5

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Wed Mar 07, 2018 10:30 am

Good afternoon,

"Clinking the BG flag does not take you to the same article in Bulgarian.." - Yes! You are right,
but the associations were not set before the problem too, also Joomla was not updated too..
nothing was done on the site too.. I can`t understand why this happened then..
I will try updating the Joomla version, but let`s see if this will help or make the situation worse..
Thanks for Your reply, Per Yngve Berg! I appreciate Your suggestion.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Wed Mar 07, 2018 12:07 pm

Looked at your site.
The home pages are always associated in joomla multilang.
For your home pages the hreflang are correct.
<link href="https://yourdomain.com/bg/" rel="alternate" hreflang="bg-BG" />
<link href="https://yourdomain.com/en/" rel="alternate" hreflang="en-GB" />

and further down
<link href="https://yourdomain.com/bg/" rel="alternate" hreflang="x-default" />

I see no associations for the other stuff which is OK if you have not implemented them yet.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Wed Mar 07, 2018 5:03 pm

Good evening all,

Thank You very much for the support and all the hints Mr. Jean-Marie Simonet!

Me and my colleague had spotted this "x-default" in the source code of the page
before, it has to be connected with the rsform pro application no matter it already
has en and bg versions...., still 0indexed pages and hreflang tags found.. I can`t
make the Joomla update, because most of the components are paid, but I don`t have
the user data to update them first (before updating Joomla core version, as suggested).
We will try it as a "last chance" on Friday without updated components, just in case
something bad happen, it will be resolved until Monday.. and will keep it posted here,
if sombebody is interested, willing to help or faced the same issues.
Kind Regards!

danikr
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Feb 19, 2018 6:48 pm

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby danikr » Wed Mar 07, 2018 6:50 pm

Still nothing after setting the associations, x-default remains unchanged,
I also found strange things in the "redirects" field like:

Code: Select all

https://sitedomain.com/bg/bigm.php  ->  http://site.ru

Code: Select all

  https://sitedomain.com/bg/components/com_creativecontactform/fileupload/files/shell.php   -> http://sitedomain.com/components/com_creativecontactform/fileupload/files/shell.php 

but I never had such creative contact form component.. I am starting to think we were attacked by hackers or something..

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18591
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Joomla 3.7.3 BG Language bug showing urls with symbols, letters, numbers..

Postby infograf768 » Thu Mar 08, 2018 7:00 am

Indeed
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Return to “Language - Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 3 guests