Page 1 of 1

Multilanguage joomla problem

Posted: Thu Apr 11, 2019 1:38 pm
by calypso_man
Hi,
I create a several website using multilanguage system in joomla.
All website work fine, except one website.

I'll explain what I did, and what is the problem:

I install language: German, Italian and English is installed.
I create 4 menu: Main menu - that is defoult for all language - marked with yellow star
German menu - with defoult item - marked with greman flag
English menu - with defoult item - marked with english flag
Italian menu - with defoult item - marked with italian flag

All menus have created template and all templates was assigned to correct menu.
Everything works fine. But problem is showing in google result.

Google show 4 hompages:
www.mysite.com
www.mysite.com/en/
www.mysite.com/de/
www.mysite.com/it/

If I click on the "www.mysite.com" then system immediately redirect on "www.mysite.com/en/". English language is set for defoult site language.

My question is; whay google see this link: www.mysite.com, How to fix that. Is that a problem?
On my other multilingual websites I dont have this problem.
Whay is 4 hompage in joomla, if I have only 3. Whay google see this link. www.mysite.com - that is menu basic in joomla marked with yellow star on multilanguage site.

Re: Multilanguage joomla problem

Posted: Thu Apr 11, 2019 2:24 pm
by Per Yngve Berg
Mod. Note: Relocated the topic to the Language Forum.

In the options of Language Filter Plugin, you can set the default language to not show the language code.