language chooser not working properly

General questions regarding the use of languages in Joomla! 3.x.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
wazoo22
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Mar 07, 2019 8:26 am

language chooser not working properly

Post by wazoo22 » Wed Jun 19, 2019 7:57 am

I have a multilingual site that's running pretty well, with a couple exceptions.
1) The language chooser, when in the default French homepage, if the user calls the English site he or she ends up in the featured English article with no modules on either side- homepage is ok, but just not reached. Associations are OK, I think.
2) How can I make the French home page reliably the default landing page?
language-autrement.com
joomla 3.9.8
Help is needed, finally.
Thanks,
Jim Miller

wazoo22
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Mar 07, 2019 8:26 am

Re: language chooser not working properly

Post by wazoo22 » Wed Jun 19, 2019 7:59 am

Sorry- wrong site. langlais-autrement.com
Jim Miller

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22157
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: language chooser not working properly

Post by pe7er » Wed Jun 19, 2019 8:13 am

Could you check your Modules? via Extensions > Modules

Have you added any Modules (assigned to the English language) to the English pages?
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

wazoo22
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Mar 07, 2019 8:26 am

Re: language chooser not working properly

Post by wazoo22 » Wed Jun 19, 2019 3:04 pm

Will check.

wazoo22
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Mar 07, 2019 8:26 am

Re: language chooser not working properly

Post by wazoo22 » Wed Jun 19, 2019 3:23 pm

Actually, --yes, several. I added a contact form in both languages, and a "what's new" module, in the form of a picture of a baby chick. I used a custom module for the chick.
There's something I'm not understanding about menus, because none of them show on the front end of the site, even though they seem properly done.
Sorry, but I'm very much a learner.
Thanks

wazoo22
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Mar 07, 2019 8:26 am

Re: language chooser not working properly

Post by wazoo22 » Wed Jun 19, 2019 3:37 pm

Actually, I solved my menu mistake, but still, the menu I made for English language articles does not show when I select "English" on the chooser--only the default main content.
Sorry, but I'm very much a learner.
Thanks

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18830
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: language chooser not working properly

Post by infograf768 » Thu Jun 20, 2019 8:39 am

Testing your site
Both Home pages are normally associated by default, i.e. no use to associate them.
If I use `langlais-autrement.com/index.php/en/` I get the real home page for English, with its menu.
But in this case the switcher loads for French `langlais-autrement.com/index.php/fr/la-difference`
this one being displayed the switcher loads for english `langlais-autrement.com/index.php/en/what-s-so-different` and this one has no modules.

I think you messed up somewhere. Hard to help without super user access to your site.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Post Reply

Return to “Language - Joomla! 3.x”