Page 1 of 1

page error 404 on second language page

Posted: Sun Aug 18, 2019 8:35 am
by jesperfredskild
Hi
I am trying to setup multilanguage.

I believe I have setup:
- the menu's correctly, (one hidden with language All and the 2 diff. main menu with "home" and "language")
- the switcher correctly (enambled the filter plugin and gave it a position)
- and installed the languages.(danish and english, danish is default)
- I have no indication in the Language status bar.
Have attached the pic of the: plugin, menus, and status.

If I activate (Yes) the "Remove URL Language Code" I can remove the 404 page error on the default page (As understood from previous forum, it is working correct when only removed on default page).
But the problem i the other page. there I still have the 404 page error and the language code is in the URL.

So how can I get rid of the 404 page error, when I can't remove the code in the URL.

Please help
/Jesper

Re: page error 404 on second language page

Posted: Sun Aug 18, 2019 8:39 am
by jesperfredskild
multilang-uk-menu.JPG
multilang-plugin.JPG
multilang-menus.JPG
multilang-hiddenmenu.JPG
multilang-DK menu.JPG

Re: page error 404 on second language page

Posted: Sun Aug 18, 2019 9:10 am
by Per Yngve Berg
Have you tried to turn off SEF in Global Configuration?

As the Language Status Module show all green, I would trouble shoot SEF.

Solved: Re: page error 404 on second language page

Posted: Sun Aug 18, 2019 11:49 am
by jesperfredskild
Have tried now. and it worked. The URL looks awfull, but it worked.
Any change this conflict can be fixed other ways?

Many tanks for your reply.

Re: page error 404 on second language page

Posted: Sun Aug 18, 2019 2:29 pm
by Per Yngve Berg
Are you hosted on Apache?

Have you renamed htaccess.txt to .htaccess?