Page 1 of 1

Rewriting a specific URL structure doesn't work

Posted: Tue Feb 05, 2013 7:41 am
by alagazam
I have made a lot of rewrites in my .htaccess to solve the problem with no longer existing URLs. The rewrites are working just fine, with one exception: URLs like the one below still results in error code 500.

/component/content/4-fotoblogg/sessioner/25-de-foersta-vinterdagarna?Itemid=11

The problem seems to be related to URLs beginning with /component/content

I am using the default .htaccess file that comes with the Joomla installation, and I have just added my rewrites. Below you can see workning and non-working rewrites.

WORKING

RewriteCond %{QUERY_STRING} ^option=com_content&view=frontpage&Itemid=5$
RewriteRule ^index.php$ http://www.bilderavmig.se/bilder/brollop? [R=301]

NON-WORKING

RewriteCond %{QUERY_STRING} ^option=com_content&view=frontpage&Itemid=11$
RewriteRule ^component/content/4-fotoblogg/sessioner/25-de-foersta-vinterdagarna$ http://www.bilderavmig.se/fotobloggen/s ... terdagarna? [R=301]

I have a lot of URLs that are killing my SEO ranking and I really need a solution. Anyone?

Re: Rewriting a specific URL structure doesn't work

Posted: Sun Mar 24, 2013 6:11 am
by Humbert Humbert
There are few REWRITE mod specialists here, When I have such a problem, I consult more knowledgeable people, like on Mod_Rewrite Forums.

Hummy

Re: Rewriting a specific URL structure doesn't work

Posted: Sun Mar 24, 2013 11:47 am
by Per Yngve Berg
Have you tried to use the Redirect Component inside Joomla?