Page 1 of 1

Search engine friendly problem

Posted: Tue Aug 27, 2013 10:01 am
by zorkan
I have a problem with managing my SEFurls. Its been two days now and I still cant get it to work.
I have renamed my htacces.txt to .htaccess, I have installed ACESEF plugin which tells me that apache_mod_rewrite is enabled on joomla. I also tried commenting out
Options +FollowSymLinks, commenting out RewriteBase, just like adding a subfolder name to the RewriteBase

This is how my .htaccess looks like
http://pastebin.com/TrtEZcSq

This is how my acesef looks like
http://www.deviantpics.com/image/3l3

and this is how my global configuration looks like
http://www.deviantpics.com/image/3lK

I can only open main page, and for each other article or item menu i get 404 page not found.
Can you help me please

Re: Search engine friendly problem

Posted: Wed Aug 28, 2013 1:20 pm
by jzlcdh
Suggest you first do a test with no .htaccess, no url rewriting and no 3rd party SEF plugin but just set SEFurls to "Yes" in "Global Configuration" in the backend.

Re: Search engine friendly problem

Posted: Wed Aug 28, 2013 2:03 pm
by zorkan
jzlcdh wrote:Suggest you first do a test with no .htaccess, no url rewriting and no 3rd party SEF plugin but just set SEFurls to "Yes" in "Global Configuration" in the backend.
Ok, I will try that. Can you please tell me what should I except to happen when I do that?

Re: Search engine friendly problem

Posted: Wed Aug 28, 2013 2:21 pm
by jzlcdh
It should show any aliases you have insteasd of the standard long url. As described in the help:

Search Engine Friendly URLs. When set to Yes, URLs are rewritten to be more friendly for search engine spiders. For example, the URL: http://www.example.com/index.php?option ... t&view=etc..., would turn into: www.example.com/alias. Most of the items created in Joomla! have an Alias box where a search engine friendly URL can be inserted.