Not Found [CFN #0005]

Discuss Search Engine Optimization in relation to Joomla! 3.x. This forum will also have discussions on SEF/SEO Joomla! 3.x extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Tue Jul 15, 2008 11:34 pm

Not Found [CFN #0005]

Postby darrenforster99 » Sun Aug 20, 2017 8:01 am

I recently moved a site from a temporary server ( to it's new server (

I put it in a folder called newsite to make sure it's all working fine before replacing the existing site.

It looked ok until I went and clicked on any of the URL's within the site. All of them are coming up with the Not Found [CFN #005] error.

The host is BT Internet so I don't know whether this affects it that much, also it seems that the previous site never made use of SEF URL's it just seemed to have multiple folders each with a basic PHP file in them, although I'd be very surprised if a host as big as BT doesn't support Mod_rewrite.

Anyway to try and fix this I checked through my configuration files and also checked the .htaccess file - everything looks fine in there and it works fine on the old site, all references to have now been changed to the right current working directory (using getcwd function to find it).

Login on the backend all works fine and the backend works fine although that appears to use non-SEF friendly URLs.

I've also tried to turn of SEF friendly URLs in the global configuration and yet they are still on, I'm also using K2 as well in the system and I've turned the SEF URLs off in K2 too and yet they still seem to be switched on (and besides the contact-us form seems to be still set with SEF on).

Obviously I know that ideally SEF URLs need to be on - but I'm turning them off for now until I can figure out what is going on - but for some reason SEF URLs are not being replaced. I've also checked in configuration.php and that has the SEF variable set to 0

public $sef = '0';
public $sef_rewrite = '0';
public $sef_suffix = '0';

I've also tried multiple options in htaccess - turning mod_rewrite off, commenting out the follow symlinks option, using the original htaccess.txt from joomla, copying .htaccess from another folder on the site... and yet I'm getting absolute nothing.

Any ideas?? I presume it is some kind of SEF problem but why is it ignoring me when I turn SEF off - I've even tried clearing the cache and expired cache, pressing ctrl+f5 on my browser, opening the website up in an incognito window to make sure it's not cached here. I can only presume I'm missing some kind of cache somewhere in Joomla??

User avatar
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4972
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Not Found [CFN #0005]

Postby sozzled » Sun Aug 20, 2017 9:36 pm

Check (and double-check) the .htaccess file for any site-specific rules. A good way to see if your .htaccess file is causing this "mischief" is to rename your existing .htaccess file to htaccess.old and then rename the file htaccess.txt —the file as originally supplied with the current Joomla installation package—to .htaccess. If this works—if it allows you to use SEF URLs—then it probably explains why you're having this problem.

This is not an solid guarantee that the above approach will identify the cause of the problem, however. There may be other reasons why a website works in one hosted environment but not in another one.
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Tue Jul 15, 2008 11:34 pm

Re: Not Found [CFN #0005]

Postby darrenforster99 » Wed Aug 23, 2017 7:06 am

Thanks sozzled for your help. It turned out it kind of was the .htaccess file misbehaving.

In ecohosting it seems to be that it accepts URLs without index.php in them, but on BT hosting it needs the index.php for the SEF to work so if I had something like <a href="/products/items">Items</a> that would work fine on ecohosting as ecohosting would automatically correct it to <a href="/index.php/products/items">Items</a> but BT wouldn't.

So all my menu links needed index.php adding to them at the beginning and they now work. I noticed there was a solution on one site where it says I could use rewriterule in htaccess but BT's hosting just seems to ignore this rule and still produces the same error (I think BT hosting actually seems to ignore all of htaccess) so the simple solution I could find was just to add index.php to each link, it also seemed to only affect the one module I'd created, all the other modules like k2 had automatically figured out the index.php was needed in the links and on ecohosting k2 realises it doesn't need index.php (I guess they're using a different function to create the link that is querying this - and I presume I'm creating the links wrong in my module?)

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 4 guests