Module Not Showing inside Article

Everything to do with Joomla! 3.x templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
Duckdown
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Sat Jun 25, 2016 7:00 am

Module Not Showing inside Article

Postby Duckdown » Sun Jan 14, 2018 12:17 am

I am redesigning my site on a localhost and trying to insert different slideshows in articles on a number of pages. One page will show photos of England, another page France, and so on. I have looked at all the things mentioned here and on many other sites through searches but none give me enough to make it work. Yes I have had it 'above' the article in a template position.
I have J3.8 and using Beez3 template. Modules/Plugins installed that I think are relevant are J51_Slideshow (plus others I have tried), Content - Load Module. I have duplicated J51_SlideshowModule for each (eg:J51SlideshowEngland) so I can source the images from different folders.
One site sugggested creating a custom position but nothing will allow me to do this. I tried what I thought was the appropriate css to put <jdoc:include type="modules" name="mypos" /> but doesn't work.
I have tried the {loadposition etc} and {loadposition etc} but haven't got my head around it. Most of the articles I read about this issue seem to focus on a particular part but I think I am at the stage where start to finish instructions would be great and of course there may be a simpler way to accomplish what I want.
Last edited by imanickam on Sun Jan 14, 2018 3:20 am, edited 1 time in total.
Reason: Split from the topic f=619&t=628439 and moved to the forum Extensions for Joomla! 3.x. In the future, for your issues, please create a separate topic.

deathbat87
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Fri Sep 15, 2017 9:16 am

Re: Module Not Showing inside Article

Postby deathbat87 » Tue Jan 16, 2018 3:15 am

Try using the regular labs -> module anywhere. It can include module in the article.

You may download that plugin here.

User avatar
Duckdown
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Sat Jun 25, 2016 7:00 am

Re: Module Not Showing inside Article

Postby Duckdown » Tue Jan 16, 2018 4:00 am

deathbat87. Thanks for your response and I have installed. However I am no wiser as to how I put the slideshow in the article and would appreciate further instructions.

deathbat87
Joomla! Intern
Joomla! Intern
Posts: 81
Joined: Fri Sep 15, 2017 9:16 am

Re: Module Not Showing inside Article

Postby deathbat87 » Tue Jan 16, 2018 4:19 am

You need to enable the sourcerer in the extension->plugin.

Then go to extension->module manager->get your slideshow module id.

Go to article where you want to place your slideshow, write this {module module_id}.

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5105
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Module Not Showing inside Article

Postby sozzled » Tue Jan 16, 2018 4:57 am

Duckdown wrote:I have tried the {loadposition etc} and {loadposition etc} but haven't got my head around it.
Let's try to simplify this.

Let's say you have a module and we'll use the title of this module (for the sake of the discussion), J51SlideshowEngland. So you go to the Joomla Module Manager and assign a position to it (although it's not absolutely necessary to do this) but I'm just trying to help out. Let's assign the module called "J51SlideshowEngland" to the position "myslideshowposition-1" (literally, just type this text into the Position field)

You can use any name you in the Position field (even if this position doesn't or is not used by your template): see https://docs.joomla.org/How_do_you_assi ... osition%3F

The last thing to do in the Module Manager is to tell the module which pages you want it to appear on; you could, for instance, have this module appear on all pages (but it will only appear on pages where there's a "myslideshowposition-1" position available. That's the next step.

Go back to where you're editing your article and use either of the following constructs:

Code: Select all

{loadposition myslidsehowposition-1}


or

Code: Select all

{loadmodule J51SlideshowEngland}


Either of these methods should work without the need to install any third-party extenstions.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

User avatar
Duckdown
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Sat Jun 25, 2016 7:00 am

Re: Module Not Showing inside Article

Postby Duckdown » Wed Jan 17, 2018 9:29 am

Thank you gentlemen for your assistance and all is as I require. So what has worked for me:

1. Checked the plugin "Content - Load Modules" was active.
2. In the Article I typed {loadposition Engslide} and below it {loadmodule J51SlideshowEng}
3. Opened Module "J51SlideshowEng" and in the 'position' typed "Engslide" and hit Enter.
4. On the Menu Assignment tab I selected the page I wanted these slides displayed and the Settings Tab for the source of the slides.

Items 2-4 were repeated and modified for each set of slides particular Article & Module.

What was really throwing me was trying to type in a Custom Position. I was typing and saving the Module and the position was not appearing. I have to be honest that it was one of those simple dumb mistakes. I forgot to hit ENTER before saving.

I did find this page helpful
https://www.cloudaccess.net/joomla-know ... a-3-0.html


Return to “Templates for Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 9 guests