nav menu missing

Everything to do with Joomla! 3.x templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 138
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

nav menu missing

Post by asearle1 » Sat Mar 28, 2020 11:40 am

Hallo everyone,

I am using Beez3 but believe that this topic is not specific to a template ...

I installed updates (Joomla 3.x) and installed a new template (Xeon) which I wanted to experiment with.

But then I noticed that the nav menu was missing: The links were there but were all jumbled in the corner and the formatting and layout was missing. So I compared (using Firefox Inspector) with an almost identical site which I have and noticed the following ...

On the "good" site there is this item ...

Code: Select all

<div id="menuwrapper" role="menubar">
  <ul class="nav menu mod-list">
The first item seems to reference "position.css" (but I can't find a specific entry)
The second line is "personal.css"

In the "bad" site the syntax is the following ...

Code: Select all

<ul class="nav">
Referencing "position.css"

In the "bad" site the entries for

Code: Select all

<ul class="nav menu mod-list">
seem to be available in personal.css

... but somehow

Code: Select all

<div id="menuwrapper" role="menubar">
is not being found or picked up.

Can someone help me with this? Can I fix it myself?

I could (maybe) copy over the .css files from the "good" site but I would rather know what has happened and actively fix it myself.

Many thanks for any tips that you can give me.

Yours,
Alan

from Cologne

 
User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 26835
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: nav menu missing

Post by Per Yngve Berg » Sat Mar 28, 2020 2:02 pm

Is the menu modules published in the same position?

Have you checked "Module Class Suffix" and "Module Chrome"?

asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 138
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

Re: nav menu missing

Post by asearle1 » Sat Mar 28, 2020 4:47 pm

Hallo Per,

Many thanks for your tips.

I made sure that only one module is allocated to that position ... and ...

I checked the two module settings between the good and the bad site and they were the same.

Do you have any other ideas what I could check?

Many thanks.

Yours,
Alan

asearle1
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 138
Joined: Sun Jun 28, 2009 7:55 am
Location: Cologne, Germany

Re: nav menu missing

Post by asearle1 » Sun Mar 29, 2020 4:58 pm

Hallo Everyone,

This thing is turning into a real pain. I have done the following ...

1. Re-copied over the Beez3 files from a previous version
2. De-installed the Template (Xeon) that I wanted to experiment with
3. Tested with ProtoStar (the other default template)

... but the "nav menu" remains lost: The links are there (off at one end) but all formatting is missing.

This is the case with Beez3 and with ProtoStar so the problem is not Template specific.

This is turning into a real show-stopper for me. Does anyone have any ideas?

Many thanks.

Yours,
Alan (in Cologne)

 

Post Reply

Return to “Templates for Joomla! 3.x”