Error after upgrading to Joomla 3.9.18

Everything to do with Joomla! 3.x templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
sylwekb
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 243
Joined: Mon Mar 14, 2011 5:08 pm

Error after upgrading to Joomla 3.9.18

Post by sylwekb » Tue Jun 02, 2020 10:57 am

After upgrading to Joomla 3.9.18, the following error occurred. How can I solve it?

Fatal error: require_once(): Failed opening required '/home/users/xxxx/public_html/libraries/joomla/document/html/renderer/head.php' (include_path='.:/usr/multiphp/php7.2/usr/share/php:/home/lib/php7.2:/home/lib/php7.2/pear') in /home/users/xxxx/public_html/templates/lt_envico/error.php on line 27
Last edited by toivo on Tue Jun 02, 2020 11:43 am, edited 1 time in total.
Reason: mod note: moved from 3.x Administration

 
User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 12510
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Error after upgrading to Joomla 3.9.18

Post by toivo » Tue Jun 02, 2020 11:50 am

Which version of Joomla did you upgrade from? Do you have a full backup so that you can restore the website?

The version of the template LT Envico you have does not support Joomla 3.x. According to the error message, the error page function of the template is trying to load the file libraries/joomla/document/html/renderer/head.php, which is used in Joomla 2.5 but does not exist in Joomla 3.9.18.
Toivo Talikka, Global Moderator

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2216
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Error after upgrading to Joomla 3.9.18

Post by JAVesey » Tue Jun 02, 2020 1:08 pm

toivo wrote:
Tue Jun 02, 2020 11:50 am
Which version of Joomla did you upgrade from? Do you have a full backup so that you can restore the website?
Are you able to login to Administrator?

If so, Joomla 3.x comes with a template called Protostar. Select this as your site template and work from there.
John V
Cardiff, Wales, UK
Uses Joomla 3.9.19 and PHP7.3.x

 

Post Reply

Return to “Templates for Joomla! 3.x”