Page 1 of 1

Global Config page Broken

Posted: Mon Dec 21, 2015 5:11 am
by drobertson123
My Global Configuration page loads without any CSS or other outside references. Basicly it is just a raw HTML page that does nothing.

I just noticed the issue in the last few days. I tried doing an upgrade to Joomla 3.4.6, but that did nothing to help the problem.

Yes, I have cleared the Joomla Cache, my browsers cache and every other cache I could find and it didn't fix anything. The normal answer to this problem seems to be to clear your cache, but that did not help.

I set error reporting to maximum, but since nothing is coming through on that page except HTML I can't tell if there are errors or not. Both the Joomla error log, the PHP error log and the Apache2 error log show no errors that seem to be related to this. If someone has a suggestion for an error log to look at I would appreciate the guidance.

As a test I actually downloaded a bootstrap version of the admin template and tried that instead of the standard Isis template (hmm, time to change the name on that one). Regrettably it didn't do anything to fix the issue.

I could seriously use some help on this.

Thanks

Re: Global Config page Broken

Posted: Mon Dec 21, 2015 7:23 am
by toivo
Use Firebug or the Web Developer extension in Firefox or Chrome, press F12 and check the Network tab and the Console tab for missing files or javascript errors, which can explain the missing styling.

Re: Global Config page Broken

Posted: Mon Dec 21, 2015 7:40 am
by drobertson123
I actually did that. I just ran it through Firefox and Firebug again.

The page only has one request and that returns the page HTML. There are no references in the page to anything else. No CSS, no Javascript, no images, nothing.

The page only has the Form tag and its contents. There is no header or body tags at all. It is just a chunk of HTML.

Re: Global Config page Broken

Posted: Thu Dec 24, 2015 7:32 pm
by 314_ter
Hi!
I just registered to report the same problem. I spent two last days looking for any solutions, trying all the ideas i could find with no avail, including all the steps mentioned by OP, resolving all the potential problems with database (Fix), installed components (Discover), clearing cache etc, ensuring the PDO is installed and active, etc. Similar problem in J2.5 has been reported many times, but it looks like the usual fixes are already implemented in the current version.
I'm on Joomla 3.4.7.
The Global Configuration page is rendered without the head section, no css and stops at the beginning of "Database Settings":
Image

Firebug console, Apache error log (reporting set to max) do not show any errors.
Looking at the page source (beginning):
Image

and the end:
Image

it shown an open <form> action, which is not closed. It looks like rendering the page breaks around the database settings section.

Re: Global Config page Broken

Posted: Thu Dec 24, 2015 8:28 pm
by drobertson123
314_ter Yes, this is exactly the problem I am seeing. Thank you for putting up more detailed info.

Re: Global Config page Broken

Posted: Sat Dec 26, 2015 2:04 pm
by 314_ter
FOUND IT!!! :)
Luckily i had an older version of the site on one of my local servers, still on J3.3.6.
I managed to successfully update it to 3.4.8 with the GlobalConfig page working normally. Having that and a second broken version (also updated to 3.4.8 ) on another local server i started to compare the file structure on both.
The broken site had a bclass.php file placed in:

(remove the _ from the last dir, seems like the forum does not like that word)

PATH_TO_JOOMLA_SITE/libraries/joomla/database/d_r_i_v_e_r

which is not present in the old, working fine version of the site.
After removing/renaming that file the Global Configuration page went back to normal.

Re: Global Config page Broken

Posted: Mon Jan 04, 2016 5:03 am
by minchala
This was PERFECT!! Did the trick for me! Thanks so much!!

Re: Global Config page Broken

Posted: Mon Jan 04, 2016 8:17 am
by toivo
The broken site had a bclass.php file placed in:

(remove the _ from the last dir, seems like the forum does not like that word)

PATH_TO_JOOMLA_SITE/libraries/joomla/database/d_r_i_v_e_r
That file is not part of Joomla. Your site must have been hacked. Follow these instructions in the 3.x Security forum: http://forum.joomla.org/viewtopic.php?f=714&t=757645

Re: Global Config page Broken

Posted: Mon Jan 04, 2016 5:42 pm
by 314_ter
toivo wrote:That file is not part of Joomla. Your site must have been hacked. Follow these instructions in the 3.x Security forum: http://forum.joomla.org/viewtopic.php?f=714&t=757645
I'm afraid you're right. After doing more research it turned out that file was a PHP backdoor (@extract ($_REQUEST);@die ($c($f));)
Deleting it and doing a deeper security check is highly recommended!

Re: Global Config page Broken

Posted: Mon Jan 04, 2016 5:44 pm
by drobertson123
I have this same issue. I am not a security guru in any way. Does anyone have suggestions for dealing with the security hole this is creating? Or testing the site for security issues in general?

Re: Global Config page Broken

Posted: Mon Jan 11, 2016 5:16 pm
by Falcon22
THANKS SO MUCH,
I was looking for a solution to this for weeks and deleting the bclass.php in the /public_html/libraries/joomla/database/driver solved the problem.

Re: Global Config page Broken

Posted: Wed Jan 27, 2016 3:06 pm
by drstine
Yes, [root]/libraries/joomla/database/d_r_i_v_e_r/ on my site contained a bclass.php malware file.

I also found a trojan file called pclass.php dated the same day at libraries/joomla/string/

It's an obfuscated file is clearly a hack and should be removed.

I have the decoded version if anyone is interested in it.

Re: Global Config page Broken

Posted: Wed Jan 27, 2016 3:16 pm
by leolam
That all is not enough. You need to follow (ALL) the steps as outlined in http://forum.joomla.org/viewtopic.php?f=714&t=757645 otherwise your site is not cleansed and you still face the same issue

Leo 8)

Re: Global Config page Broken

Posted: Fri Jan 29, 2016 6:08 am
by Bernard T
Thanks to Falcon22 I have been able to directly check what happens on a similarly infected website.
First of all, no JS was used in this case.

* libraries/joomla/database/drive_r/bclass.php
* libraries/joomla/string/pclass.php
* several malware files in templates/atomic/ folder, easily recognizable by random string names
* malware (specially crafted for Joomla, using Joomla framework) injected into a model in components/com_content which enabled automatic creation and random display of spammy links in the main menu
* spammy links inserted into menu database
* modified main index.php file to redirect spammy link from index.html to another HTML file injected into a webroot

As you can see, this attack is specially crafted for Joomla sites, some malicious parts are hard to do recognize. It is utmost important to strictly follow the cleanup instructions provided here, deleting and replacing all core and extension files, to remove files injections and/or extra malware files.

Re: Global Config page Broken

Posted: Sun Jan 31, 2016 5:31 am
by regexaurus
Just reporting that I experienced the same problem--was recently subjected to a hack and went through a cleanup procedure, but found and removed /libraries/joomla/database/driver/bclass.php. This resolved a problem with Global Configuration. Now working through these steps: http://forum.joomla.org/viewtopic.php?f=714&t=757645

Re: Global Config page Broken

Posted: Wed Feb 03, 2016 11:01 pm
by jk15060
OMG!! This thread just saved me a world of hurt! Have a former client who needed a bit of help and turns out his site had that bclass.php file in /libraries/joomla/database/driver!!! Once I removed it, I was able to view the Global Configuration again in the backend of Joomla. Now I'm walking through all those security steps just to be sure.

Now I have to figure out why extensions won't install because of a "Site temporarily unavailable. Connection timed out."

THANK YOU THANK YOU THANK YOU for this thread/post and help!!

Re: Global Config page Broken

Posted: Mon Feb 22, 2016 6:34 pm
by tonymontezuma
314_ter wrote:FOUND IT!!! :)
Luckily i had an older version of the site on one of my local servers, still on J3.3.6.
I managed to successfully update it to 3.4.8 with the GlobalConfig page working normally. Having that and a second broken version (also updated to 3.4.8 ) on another local server i started to compare the file structure on both.
The broken site had a bclass.php file placed in:

(remove the _ from the last dir, seems like the forum does not like that word)

PATH_TO_JOOMLA_SITE/libraries/joomla/database/d_r_i_v_e_r

which is not present in the old, working fine version of the site.
After removing/renaming that file the Global Configuration page went back to normal.
WORKS VERY WELL FOR ME!!! TKS
DAYS AND DAYS SEARCH ALL THE FORUM RSRS

Re: Global Config page Broken

Posted: Fri Feb 02, 2018 11:01 am
by VersHandel
SAME ISSUES, DIFFERENT CAUSE
---------------------------------------
I had the same issues with the global config page, but i could not find any of the already mentioned problems (Joomla 3.8 ).
I have made a backup (Akeeba) of the hosted site and installed it on a small Ubuntu server at home and activated "all errors" to be logged. In the logs i then found this error:

PHP Fatal error: Class 'JDatabaseDriverMySQLi' not found in /<Joomla root>/libraries/joomla/database/driver/mysqli_fab.php on line 21

Since Joomla uses PDOmysql, i decided to rename the file and see what happens.
It solved the issues.

I expect the file to be part of the Fabrik extension. I have detected the issues with the global config after installing Fabrik. However i'm not sure the issues weren't there prior to installing Fabrik.

Maybe this can help others.

Re: Global Config page Broken

Posted: Fri Feb 02, 2018 12:40 pm
by fcoulter
It is true, that file does seem to be part of Fabrik, it installs the drivers 'mysql_fab.php', 'mysqli_fab.php', 'pdomysql_fab.php' when it installs.

Re: Global Config page Broken

Posted: Wed Feb 13, 2019 1:51 pm
by bracha
SAME ISSUE, NO SOLUTION YET
------------------------------------
I am having the same issues with the global config page, but I could not find any of the problems mentioned above (my Joomla version is: 3.3.3 running on Fatcow hosting).

I am not as tech savvy as some of the other members that have commented on this issue above, so any and all detailed help would be greatly appreciated. I have already cleared the Joomla cache several times, but that did not seem to resolve the issue.

Thank you.

Re: Global Config page Broken

Posted: Thu Feb 14, 2019 9:32 am
by AMurray
Given you're way behind in Joomla installs (3.3 ??? ???) instead of 3.9.3 no wonder you have been hacked. You're using very outdated software.

It's not required to have an extensive knowledge of the security implications or any development stuff - it just take a a little effort and time to keep your site safe, and updated. Joomla basically does the work - you just press the button that says "Update"!

Re: Global Config page Broken

Posted: Mon Feb 18, 2019 10:53 am
by bracha
I appreciate the incite with regards to the outdated version I am using.
As this is a live site, I have a few concerns, which I would appreciate if you (or any other member, who cares to assist) would address:
1. Is it possible that an update to the latest version will "break" any of the existing functionality in my website?
2. Is the behavior I am experiencing definitely due to a website hack or could it be a different reason that I may be able to fix, without an update? If so, any help would be greatly appreciated.
3. If the problem is due to a website hack, will an update to the latest version differently resolve the problem or is it possible that the issue will remain?

Thank you.
AMurray wrote:
Thu Feb 14, 2019 9:32 am
Given you're way behind in Joomla installs (3.3 ??? ???) instead of 3.9.3 no wonder you have been hacked. You're using very outdated software.

It's not required to have an extensive knowledge of the security implications or any development stuff - it just take a a little effort and time to keep your site safe, and updated. Joomla basically does the work - you just press the button that says "Update"!

Re: Global Config page Broken

Posted: Wed Apr 17, 2019 2:23 pm
by gabrieldeluca
fcoulter wrote:
Fri Feb 02, 2018 12:40 pm
It is true, that file does seem to be part of Fabrik, it installs the drivers 'mysql_fab.php', 'mysqli_fab.php', 'pdomysql_fab.php' when it installs.
Just rename the files 'mysql_fab.php' and 'mysqli_fab.php' and the problem is solved.

Re: Global Config page Broken

Posted: Wed Apr 17, 2019 2:26 pm
by gabrieldeluca
VersHandel wrote:
Fri Feb 02, 2018 11:01 am
SAME ISSUES, DIFFERENT CAUSE
---------------------------------------
I had the same issues with the global config page, but i could not find any of the already mentioned problems (Joomla 3.8 ).
I have made a backup (Akeeba) of the hosted site and installed it on a small Ubuntu server at home and activated "all errors" to be logged. In the logs i then found this error:

PHP Fatal error: Class 'JDatabaseDriverMySQLi' not found in /<Joomla root>/libraries/joomla/database/driver/mysqli_fab.php on line 21

Since Joomla uses PDOmysql, i decided to rename the file and see what happens.
It solved the issues.

I expect the file to be part of the Fabrik extension. I have detected the issues with the global config after installing Fabrik. However i'm not sure the issues weren't there prior to installing Fabrik.

Maybe this can help others.
When Fabrik is installed on Joomla 3.9.x, the files 'mysql_fab.php', 'mysqli_fab.php', 'pdomysql_fab.php' are installed in the folder /<Joomla root>/libraries/joomla/database/driver/.
Just rename the files 'mysql_fab.php' and 'mysqli_fab.php' and the problem is solved.

Re: Global Config page Broken

Posted: Thu Sep 12, 2019 1:37 pm
by gabrieldeluca
En el archivo configuration.php cambiar el $dbtype = 'mysqli' o 'pdomysql' segun corresponda.
Este problema sucede a veces cuando se hace una migración de un hosting a otro.