Akeeba Backup v6.0.0 Bricked my test site

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
User avatar
jdwires
Joomla! Intern
Joomla! Intern
Posts: 93
Joined: Wed Aug 12, 2009 2:22 am
Contact:

Akeeba Backup v6.0.0 Bricked my test site

Post by jdwires » Fri Feb 09, 2018 10:05 pm

Just an FYI to everyone out there I just tried updating my version of Akeeba Backup to the newly released v6.0.0 on my test site running the current version of joomla (3.8.5) running on apache with PHP7 with all other extensions up to date. It bricked the site and I got a page with this:

Code: Select all

 Fatal error: Class 'FOF30\Utils\InstallScript' not found in mySiteRootHere/public_html/tmp/install_5a7e143f91509/install_5a7e144019546/script.com_akeeba.php on line 17
Now the admin and the front end of the test site are just returning:

Code: Select all

An error has occurred.
500 FOF 3.0 is not installed
Thank goodness for backups and testing environments. :) Although, I find it ironic that the backup software caused a problem that will mean I need to reinstall from a backup...

I might be missing something, but just a word of caution, remember to backup before installing updates!
Joel

User avatar
sozzled
Joomla! Champion
Joomla! Champion
Posts: 5308
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: Akeeba Backup v6.0.0 Bricked my test site

Post by sozzled » Fri Feb 09, 2018 10:31 pm

I haven't seen a problem with Akeeba Backup v 6.0 on at least half-a-dozen websites that I manage. I haven't look at all of my sites but I don't think this is a universal problem. Sorry to hear that you had this issue; it might be something you need to report the the author.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

KianWilliam
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 145
Joined: Thu Jan 12, 2017 10:13 am

Re: Akeeba Backup v6.0.0 Bricked my test site

Post by KianWilliam » Sat Feb 10, 2018 12:47 pm

I just updated some sites of mine with last version of akeeba back up, no problem so far, why you do not uninstall the extension and install the latest version of akeeba from scratch? it takes less than 5 minutes, also check related plugins in your site to be sure they are all enabled and active
Kian William

User avatar
Jaydot
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 184
Joined: Sun Jun 04, 2017 12:11 pm
Location: The Netherlands
Contact:

Re: Akeeba Backup v6.0.0 Bricked my test site

Post by Jaydot » Sat Feb 10, 2018 2:07 pm

I've updated eleven sites to 6.0.0 without a hitch.

It would seem FOF30 is missing in your Joomla installation (it should be in /libraries/utils).
Search Akeeba's documentation for "the installation/upgrade broke my site", which addresses this issue.
The fact that an opinion is widely held is no evidence whatsoever that it is not utterly absurd.
Personal website: https://jaydot.nl

User avatar
jdwires
Joomla! Intern
Joomla! Intern
Posts: 93
Joined: Wed Aug 12, 2009 2:22 am
Contact:

Re: Akeeba Backup v6.0.0 Bricked my test site

Post by jdwires » Tue Feb 13, 2018 5:15 pm

Thanks for the replies everyone. I ended up restoring the site from a recent backup and then performed the update and everything worked as expected. I wasn't too worried about the problem since I had backups. I just wanted to give everyone a friendly reminder that if it doesn't exist in two places, it doesn't exist. :)

@KianWilliam, I couldn't do anything with the site. Both front and back ends of the site went straight to a 500 error page.

@Jaydot, thanks on the location info.


Post Reply

Return to “Extensions for Joomla! 3.x”