403 error updating Akeeba Admin Tools

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
yolknet
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Oct 01, 2014 9:28 pm

403 error updating Akeeba Admin Tools

Post by yolknet » Thu Aug 16, 2018 9:23 pm

For over a year updating Admin Tools gives an 403 error, just as described at https://www.akeebabackup.com/support/ad ... r-403.html. Whether we use Watchfull, MyJoomla or directly in the Joomla backend. At first I thought of a bug, but after a few updates the problem was still there. Even the upgrades of Joomla didn't solve the problem. This summer holiday I've spend most of my time searching for a clue on our servers, but with no end.
By accident I finally found the solution: it's the backend language. But I don't if it's a bug of Akeeba, Joomla or a mix of coincidences.
Here is how I solved the problem:

- Checked the download ID. This was different than the one we always use.
- I pasted the new ID in Admin Tools
- In the backend I went to Extensions --> Language(s) --> Installed
- The client_id (the dropdown left from the search bar) I changed to "Backend" ("Beheergedeelte" in Dutch)
- Dutch is the default language, I changed it to "English (en-GB)"
- I went back to Extensions --> Manage --> Updates and clicked on the button "Find Updates"
- Again you'll see there is an update for Admin Tools. But now you can install the update without error

If you update without the last two steps you'll still get the error.

Does Joomla compare the language to an update file?

User avatar
PhilTaylor-Prazgod
Joomla! Ace
Joomla! Ace
Posts: 1163
Joined: Sat Aug 20, 2005 12:32 pm
Location: Weymouth, UK
Contact:

Re: 403 error updating Akeeba Admin Tools

Post by PhilTaylor-Prazgod » Fri Aug 17, 2018 10:55 am

The step that actually fixed this for you was to use the CORRECT DOWNLOAD ID.

There is no issue other than that

As you are a paying (I assuming as you have a download id) subscriber of Akeeba products why not seek support from Nic and his team, who would have first told you it was a download id issue at the start and saved yourself hours of debugging.
Phil Taylor - Full Time Joomla/PHP Security Expert
Blue Flame Digital Solutions Limited.
-- https://myJoomla.com/ Multi Award Winning Joomla Security & Auditing Service
-- https://www.phil-taylor.com/

yolknet
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Oct 01, 2014 9:28 pm

Re: 403 error updating Akeeba Admin Tools

Post by yolknet » Fri Aug 17, 2018 12:40 pm

Thank you for your reply Phil.
The download ID was changed, just I don't know when this happened. It was always a different one. I recently noticed it was changed.
As I mentioned changing the ID didn't fix the problem. The only way is when I change the backend language to en-GB.
I want to ask Akeeba the same question, but "Our support services and our offices will remain closed from August 11th, 2018 18:00 EEST to August 20th, 2018 10:00 EEST for summer vacations and the observance of the religious holiday on August 15th in our countries."

User avatar
PhilTaylor-Prazgod
Joomla! Ace
Joomla! Ace
Posts: 1163
Joined: Sat Aug 20, 2005 12:32 pm
Location: Weymouth, UK
Contact:

Re: 403 error updating Akeeba Admin Tools

Post by PhilTaylor-Prazgod » Fri Aug 17, 2018 12:45 pm

Well you just have to respect holidays. I am in fact on holiday but replying to you, but Nic has a wife and a child whereas my child is in a different country with her mum (the ex wife) so Im on a laptop on holiday - such is life.

The fact is, your issue is nothing to do with language. the "403" is a HTTP ERROR CODE which means Forbidden. And the only reason you are getting that is to do with your download id being incorrect.

Language plays no part in the update process.

Ultimately the Joomla Update process will load this url - appended with your download id:

https://www.akeebabackup.com/component/ ... .zip&dlid=

if you click that link without a download id, you will see a 403, if you append your download id, you will get the admin tools zip file.
Phil Taylor - Full Time Joomla/PHP Security Expert
Blue Flame Digital Solutions Limited.
-- https://myJoomla.com/ Multi Award Winning Joomla Security & Auditing Service
-- https://www.phil-taylor.com/

yolknet
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Oct 01, 2014 9:28 pm

Re: 403 error updating Akeeba Admin Tools

Post by yolknet » Fri Aug 17, 2018 1:00 pm

Indeed Phil, that's what I would expect too. But the same ID with a Dutch backend language doesn't work. When I change it to English the update installs perfectly. That's why I don't think it's just the download ID.

Have a nice holiday by the way ;-)

yolknet
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Wed Oct 01, 2014 9:28 pm

Re: 403 error updating Akeeba Admin Tools

Post by yolknet » Fri Aug 24, 2018 5:56 pm

I finally found the cause of all the trouble: it's some Joomla cache. Nicholas explains the solution in this ticket: https://www.akeebabackup.com/support/ad ... 3-6-4.html
"In any case, you will need to press Clear Cache followed by Find Updates twice to let Joomla finally use the correct Download ID in its URL."
After hitting the Find Updates button twice I was able to install the update.


Post Reply

Return to “Extensions for Joomla! 3.x”