Can't update plugins after updating to Joomla 3.9.26

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
User avatar
LAMF
Joomla! Guru
Joomla! Guru
Posts: 710
Joined: Fri Jul 03, 2009 9:51 am

Can't update plugins after updating to Joomla 3.9.26

Post by LAMF » Wed Apr 14, 2021 1:44 pm

Hi,

I have updated like 7 out of 10 of my joomla sites to 3.9.26 and then when attempting to update some plugins I get this error message:
"Argument 1 passed to FOF30\Platform\Joomla\Platform::__construct() must be an instance of FOF30\Container\Container, instance of Akeeba\Backup\Admin\Container given,
called in /home/mydomain/domains/mydomain.se/public_html/libraries/fof40/Container/Container.php on line 213"
This has occurd on 3 of my sites.
Any suggestions on how to solve this is highöy appreciated.

BR
LAMF
Last edited by toivo on Thu Apr 15, 2021 12:10 am, edited 1 time in total.
Reason: mod note: moved from 3.x Administration

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6665
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Can't update plugins after updating to Joomla 3.9.26

Post by AMurray » Wed Apr 14, 2021 9:18 pm

I had the same issue (after update to J! 3.9.26)

I think the problem lies with an out of date FOF plugin that Akeeba Backup/Admin Toolls requires. The FOF plugin was updated in recent weeks, alongside the updates to the main Akeeba extensions.

I'm not sure what the solution is; perhaps an uninstall of the akeeba extensions, then install the latest FOF plugin, and then reinstall the Akeeba extensions.

The FOF plugin usually would install as part of the Akeeba package but can be installed separately and is a download on akeeba.com

Suggest contacting Akeeba for further advice, or review their knowledge-base/documentation.
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
LAMF
Joomla! Guru
Joomla! Guru
Posts: 710
Joined: Fri Jul 03, 2009 9:51 am

Re: Can't update plugins after updating to Joomla 3.9.26

Post by LAMF » Thu Apr 15, 2021 7:03 am

Thanks, I have solved it by installing Akeeba Backup, FOF40, FOF30 separately and then install the entire packet of Akeeba Admin Tools the regular upload-way. After that it seems to work as it should at least til next update...


Post Reply

Return to “Extensions for Joomla! 3.x”